Software Manager won't open

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 4
Joined: Sat Jul 10, 2010 3:20 am

Software Manager won't open

Postby animaleyes76 » Wed Jan 23, 2013 10:12 am


I have a problem with the software manager in Mint 14 (64bit) Cinnamon

Everytime i open the software manager it asks for my password but then nothing happens. When i run mintinstall from terminal i get the following:-

/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/ GtkWarning: could not open display
warnings.warn(str(e), _gtk.Warning)
Traceback (most recent call last):
File "/usr/lib/linuxmint/mintInstall/", line 28, in <module>
from widgets.pathbar2 import NavigationBar
File "/usr/lib/linuxmint/mintInstall/widgets/", line 1025, in <module>
class PathBarThemeHuman:
File "/usr/lib/linuxmint/mintInstall/widgets/", line 1038, in PathBarThemeHuman
animate = gtk.settings_get_default().get_property("gtk-enable-animations")
AttributeError: 'NoneType' object has no attribute 'get_property'

I did a dkpg -l mintinstall and it gives me the following.

| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)

Has anyone any idea what's going on? I even tried a complete reinstall but exactly the same thing happens.

I've tried removing/installing mintinstall, I did the same with GTK2 but no joy.

Ok, i had a problem installing wine as well with the follwoing, it could kinda explain why a wndow isn't being created perhaps... (guessing)

Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
err:systray:initialize_systray Could not create tray window

Any help would be much appreciated.



Level 1
Level 1
Posts: 4
Joined: Sat Jul 10, 2010 3:20 am

Re: Software Manager won't open

Postby animaleyes76 » Wed Jan 30, 2013 4:36 am

Anyone? :(

User avatar
Level 6
Level 6
Posts: 1369
Joined: Sun Dec 16, 2012 7:29 pm

Re: Software Manager won't open

Postby passerby » Wed Jan 30, 2013 5:17 am

At a glance it looks like a problem with python-gtk2, but that's just my guess.

Possible solutions to the problem: ... python-gtk
Home PC: Xubuntu 14.04 x64, Nvidia GTX650, i7 3770K, 16GB RAM, Asus Xonar DX
Work PC: Mint 13 x64 XFCE, Nvidia GT620, i5 3470, 8GB RAM
Laptop: System76 Kudu Pro, Xubuntu 14.04 x64

My HTML5 login themes + screenshots

Return to “Newbie Questions”