I can't copy and paste files due to permissions

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
JF007
Level 1
Level 1
Posts: 27
Joined: Sat Nov 14, 2009 8:01 am

I can't copy and paste files due to permissions

Post by JF007 » Mon Feb 18, 2013 10:07 am

Forgive me if this has been asked many times as I've done a search on here and google and worked out how to access superuser via the terminal, but it doesn't seem to solve my issue.

I've downloaded applets for Cinnamon, extracted and now wish to copy and paste the folder to "~/.local/share/cinnamon/applets/", I can access the applet folder via the graphical window but if attempt to copy and paste or drag and drop, i get the following messages

"cannot be copied because you do not have permissions to create it in the destination"

How do I solve this? and is there a way to make it a permanent fix?

cecar
Level 4
Level 4
Posts: 370
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden

Re: I can't copy and paste files due to permissions

Post by cecar » Mon Feb 18, 2013 10:20 am

Open up a terminal and do:

Code: Select all

gksu nemo
Now you have a filebrowser with elevated priviligies.
Last edited by cecar on Mon Feb 18, 2013 10:42 am, edited 1 time in total.

Detonate
Level 2
Level 2
Posts: 86
Joined: Fri Oct 14, 2011 7:40 pm
Location: Ault, Colorado
Contact:

Re: I can't copy and paste files due to permissions

Post by Detonate » Mon Feb 18, 2013 10:36 am

Yep. That will open your file manager with elevated (sudo) privileges. One of the first things I do with a new distro installed, is create a menu item labeled "Root File Manager" with the above command. Of course change it to open your file manager, in my case I am running Mate, so the command is

Code: Select all

gksu caja
Only use this when you need it, because if you start manipulating files in your home directory with this, you may end up with ownership problems.

When in this elevated privilege mode, if you select to edit a file, that file will open in your text editor with elevated privileges, so use with care.

JF007
Level 1
Level 1
Posts: 27
Joined: Sat Nov 14, 2009 8:01 am

Re: I can't copy and paste files due to permissions

Post by JF007 » Mon Feb 18, 2013 7:21 pm

Cheers, that worked for two of the applets!

The only other issue I have, is that I can't change the Menu (i'm running Mint 13) to the advanced mint menu that I downloaded via software manager (I can't see any option to switch to the menu) and I also tried downloading the applet but the link provided on the cinnamon applet site must be outdated.

Any suggestsions on how to fix this?

JF007
Level 1
Level 1
Posts: 27
Joined: Sat Nov 14, 2009 8:01 am

Re: I can't copy and paste files due to permissions

Post by JF007 » Mon Feb 18, 2013 7:24 pm

Also how do I exit this mode, as I typed in "exit" but I can still copy and paste so I assume I'm running as a privileged user?

Detonate
Level 2
Level 2
Posts: 86
Joined: Fri Oct 14, 2011 7:40 pm
Location: Ault, Colorado
Contact:

Re: I can't copy and paste files due to permissions

Post by Detonate » Mon Feb 18, 2013 8:03 pm

When you enter sudo mode, you stay in sudo mode for 5 minutes, you can exit this by running the command

Code: Select all

sudo -K
This will take you out of sudo mode.

JF007
Level 1
Level 1
Posts: 27
Joined: Sat Nov 14, 2009 8:01 am

Re: I can't copy and paste files due to permissions

Post by JF007 » Mon Feb 18, 2013 9:05 pm

Many thanks :D

Post Reply

Return to “Newbie Questions”