using Ctrl + Alt + F2 Console

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 20
Joined: Fri Nov 09, 2012 6:09 pm

using Ctrl + Alt + F2 Console

Postby thebluesky » Thu Feb 28, 2013 9:45 pm

I updated my kernel to 3.7 but I have some problems at start -up so I decide to reinstall my nvidia driver according to this source

Nvidia Troubleshooting

For unexpected problems with the Nvidia driver, you may fix your system using the following instructions:

- Press CTRL+ALT+F2 and enter these commands:

cd /usr/src/linux-headers-3.7.6-030706/arch/x86/include

sudo cp -v generated/asm/unistd* ./asm

sudo apt-get install --reinstall nvidia-current

but when I write "cd /usr/src/linux-headers-3.7.6-030706/arch/x86/include "
it says there is no file or dir like this sth like that

could you possibly help me please? thanks alot

User avatar
Level 6
Level 6
Posts: 1052
Joined: Fri Feb 16, 2007 2:26 am

Re: using Ctrl + Alt + F2 Console

Postby grimdestripador » Thu Feb 28, 2013 11:46 pm

A shot in the dark here. I don't think the command you have, was written specifically for you, and there sure a lot of version numbers in it. Perhaps you could customize the cp command for your computer. have a look in the folder /usr/src, you will notice the linux headers folders, but probally not the same version as your cp command your posted here.

Code: Select all

uname -a

Also you might want to consider other folder similear like x64 for a replacement of x86.
You didn't post much information, so i have to guess a lot.

Level 1
Level 1
Posts: 20
Joined: Fri Nov 09, 2012 6:09 pm

Re: using Ctrl + Alt + F2 Console

Postby thebluesky » Fri Mar 01, 2013 2:09 am

Thanks for your reply yes you are right . I have been reading forums for a few days which made even confused more .I didnt know which info I should share :)

I run Mint 14 Nadia Cinnamon 64 bit.
at first everything used to work fine except my system was llttle bit slow.

1.I updated my kernel to 3.7.1
when I was trying to update kernel, the codes seems to have worked fine but ended up with a notice which says :
Error! Bad return status for module build on kernel: 3.7.1-030701-generic (x86_64)
Consult /var/lib/dkms/virtualbox-guest/4.1.18/build/make.log for more information.

there was no problem at start up except a few warning .

2.I updated my Nvidia 210 M Grapich card driver

I used this code

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

there are some warnings at startup .the system works smoothly and faster.
I dont have a desktop en. anymore probably. it looks like windows or kinda XFCE DE
but mouse icon disappeare when it comes on an icon. and Nvidia X server setting says :
You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

3.I updated my kernel to 3.7.6 with this code

cd /tmp
wget ... rnel-3.7.6 -O kernel-3.7.6
chmod +x kernel-3.7.6
sudo sh kernel-3.7.6
sudo reboot

there are still problems similar to before

4.I tried to restore my kernel to 3.5.0 by using " previous versions" option at booting
now my kernel is 3.5 but there are some problems at start up and the problems with nvidia driver is the same

I dont want to have latest kernel or nvidia driver..I just want them to work together smoothly ..I dont know if I installed open code nvidia driver or not btw.

Now system tools > system setting> graphics says my driver is VESA: GT218 Board - 0689a740

uname -a says
3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

inxi -Fc 0 says

System: Host: Lenovo-G550 Kernel: 3.5.0-17-generic x86_64 (64 bit) Desktop: Gnome Distro: Linux Mint 14 Nadia
Machine: System: LENOVO product: 20023 version: Lenovo G550
Mobo: LENOVO model: NITU1 version: REFERENCE Bios: LENOVO version: 18CN37WW(V2.10) date: 09/18/2009
CPU: Dual core Pentium CPU T4300 (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 ssse3)
Clock Speeds: 1: 1200.00 MHz 2: 1200.00 MHz
Graphics: Card: NVIDIA GT218 [GeForce G210M]
X.Org: 1.13.0 drivers: vesa,nouveau (unloaded: fbdev) FAILED: nvidia Resolution: 1280x720@0.0hz
GLX Renderer: N/A GLX Version: N/A
Audio: Card-1: NVIDIA High Definition Audio Controller driver: snd_hda_intel Sound: ALSA ver: 1.0.25
Card-2: Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel
Network: Card-1: Broadcom BCM4312 802.11b/g LP-PHY driver: b43-pci-bridge
IF: N/A state: N/A mac: N/A
Card-2: Broadcom NetLink BCM5906M Fast Ethernet PCI Express driver: tg3
IF: eth0 state: up speed: 100 Mbps duplex:
Drives: HDD Total Size: 894.2GB (1.2% used) 1: id: /dev/sda model: HITACHI_HTS54502 size: 250.1GB
2: USB id: /dev/sdb model: External_USB_HDD size: 640.1GB 3: USB id: /dev/sdc model: Cruzer size: 4.0GB
Partition: ID: / size: 20G used: 5.0G (28%) fs: ext4 ID: /home size: 563G used: 4.0G (1%) fs: ext4
ID: swap-1 size: 5.24GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 37.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 150 Uptime: 3:02 Memory: 573.5/1998.3MB Client: Shell inxi: 1.8.4

Return to “Newbie Questions”