Computer Won't Shut Down

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
curmudgeon2
Level 1
Level 1
Posts: 10
Joined: Mon May 21, 2012 7:51 pm
Location: Sequim WA

Computer Won't Shut Down

Post by curmudgeon2 » Sat Mar 02, 2013 6:31 pm

My Computer won't shut down using the 'Menu' "quit" cmd, after a fresh Mint 13, 'Mate' install, as well as installing all the updates and updating the xserver-xorg-core. I have to use the power button to shut down.

I've been using Mint 13, Mate, since it's release, without any problems until a recent corruption in the boot process made access to anything, but the BIOS, impossible, including the terminal. :?:

Any ideas?

User avatar
karlchen
Level 20
Level 20
Posts: 11319
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Computer Won't Shut Down

Post by karlchen » Sun Mar 03, 2013 12:32 pm

Hello, curmudgeon2.

Just to make sure that I have understood the history right:
  • You had a working Mint 13 Mate installation. It started up and shutdown properly.
  • Some recent corruption rendered this installation totally unusable.
  • You re-installed Mint 13 Mate from the scratch.
  • This new Mint 13 Mate installation does not shutdown and poweroff. You have to poweroff manually.
Is this chronology correct?
If it is this might suggest that the corruption - the nature of which I have not really grasped - and the current problem might be related.

In order to analyze what is going on during shutdown:
  • When you want to shutdown do not use the Mint menu item.
  • Instead use <ctrl><alt><f1> in order to switch to pseudo console terminal no. 1.
  • Logon.
  • Run

    Code: Select all

    sudo shutdown -h now
    when asked to give your password, do so. The shutdown procedure will start and write status messages to the screen.
If it worked as designed the last message which you might be able to read would be something about "[power off]" and the same moment the screen would be switched off, same as the whole machine.

In your case, however, the expected behaviour is that the shutdown procedure will not be able to power off the screen and the machine. It would be really helpful to learn the last messages which are written to the screen before the machine stops doing anything (and you would normally press the power button).

Kind regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

curmudgeon2
Level 1
Level 1
Posts: 10
Joined: Mon May 21, 2012 7:51 pm
Location: Sequim WA

Re: Computer Won't Shut Down

Post by curmudgeon2 » Sun Mar 03, 2013 2:12 pm

Karl,

Thank you for your prompt response. First, Yes, you have accurately stated the chronology of events leading to my Mint 13, Mate, reinstall and subsequent shut down problems. I can add that at one time, and one time only, I had a msg to the affect that "the 'virtual kernel' failed to load. I can also add that the "restart" cmd from the "quit" menu functions as it should.

I actually have two HDs, with the same Mint release on them; but I have to go into the BIOS to switch between the two HDs. So, when the problem ocurred, I switched HDs only to find that it was also affected and allowed me no access to anything on the second HD,, including the terminal.

Back to your instructions: 1) the <ctrl><alt><f1> took me to a blank screen, not the terminal, just as the menu "quit" cmd would do: and I had to shut down the machine manually. However; after I restarted the machine, I went to the terminal from the menu and entered the <sudo shutdown -h now> cmd and it shut down the machine. After restarting, I tried the menu "quit" cmd and it shut down the machine as it should. It's a mystery to me, but it works, and evidently the problem is resolved. :roll:

Now I'll call upon your expertise again, if you don't mind. When loading Mint, I always select the "automatic" log in option at start up; and it worked, initially. However, of late, it's gone back to requiring me to log in with user name and password. How do I switch back to 'automatic log in"?? Thank you again for the benefit of your time and expertise.

Terry

User avatar
karlchen
Level 20
Level 20
Posts: 11319
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Computer Won't Shut Down

Post by karlchen » Sun Mar 03, 2013 2:30 pm

Hello, curmudgeon2.

Congratulations that the problem has been solved. - Hope it really has.

A remark on the blank black pseudo console monitor:
1) the <ctrl><alt><f1> took me to a blank screen, not the terminal,
This suggests that during boot up Grub uses a screen resolution which is not compatible with either your graphics card or your monitor. I can reproduce such a problem on a Notebook having an ATI graphics card and a wide screen. - Admittedly, I have not spent too much time on figuring out a solution or finding one in the forum. :oops: The machines that I use everyday all do not exhibit this problem. (NVidia graphics cards and Intel graphics card) :D

How to re-enable automatic login:
How do I switch back to 'automatic log in"??
Open a terminal window and execute

Code: Select all

sudo mdmsetup
Note:
I hope that Mate uses mdm and therefore mdmsetup as Cinnamon and Xfce do. Else you may have to wait for another Mate user to chime in.

Inside the "Login Window Preferences" dialogue window activate the tab "Security".
Tick the option [X] Enable automatic login.
Select a user account from the "User:" drop down list. Click on [Close].
This should do the trick.

Kind regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

curmudgeon2
Level 1
Level 1
Posts: 10
Joined: Mon May 21, 2012 7:51 pm
Location: Sequim WA

Re: Computer Won't Shut Down (RESOLVED)

Post by curmudgeon2 » Sun Mar 03, 2013 4:40 pm

A remark on the blank black pseudo console monitor:

1) the <ctrl><alt><f1> took me to a blank screen, not the terminal,

This suggests that during boot up Grub uses a screen resolution which is not compatible with either your graphics card or your monitor
Oops, I failed to mention that I have a problematic monitor. I've tried to resolve the issure with the help of some very savvy forum members; but in the end, the decision was made that it has an internal problem. I haven't chosen to replace it because it still works, just not as well as it should.

Note:
I hope that Mate uses mdm
Yes, it does. I'll give it a try. Thanks again for your help.
Terry

Post Reply

Return to “Newbie Questions”