All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
User avatar
Gandalf the Wizard
Level 1
Level 1
Posts: 1
Joined: Mon Feb 04, 2013 6:46 am
Location: Middle Earth
Contact: error

Postby Gandalf the Wizard » Sun Mar 03, 2013 6:17 pm

My Cinnamon LinuxMint shows the Update Manager with a red X in its shield indicating Error in, could not refresh the list of packages.

Extract from mintUpdate log:
++ MintUpdate is in tray mode, performing auto-refresh
++ Starting refresh
++ Auto-refresh timer is going to sleep for 15 minutes, 0 hours and 0 days
-- Error in, could not refresh the list of packages

How do I fix this?

When I manually run the Update Manager, the red X clears and the green checkmark appears.
However, if left alone, the red X will reappear.

Main: i7-975@3.33GHz, DFI LP UT X58-T3eH8 X58, 2x EVGA GeForce GTX 285, Win7
2nd: i7-950@3.06GHz, ASUS Sabertooth X58, 2x EVGA GeForce GTX 650, LinuxMint

Add a [SOLVED] at the header beginning, if your question has been answered and solved.

Level 1
Level 1
Posts: 1
Joined: Wed Mar 13, 2013 8:22 am

Re: error

Postby JeDie2004 » Wed Mar 13, 2013 8:35 am


It seems that I got almost same problem but with one more not good thing: locks the database and I am not able to run update check manually
using GUI or do other package related things.

As I figured out the problem is in proxy settings, which was set system wide and should
be available to all who depends on it. But for some reason when I do

Code: Select all

sudo bash

I get stalled for reasonable ammount of time and finish with error. checkAPT tries to connect
directly rather using proxy. After issuing

Code: Select all

export http_proxy=

I see how it connects and do update checks as normal.

For now I see no solution other than dirty hack into or configuration files located
at /etc/apt/.


PS: Using Maya x86 within virtual machine and there no option to get direct internet connection.

User avatar
Level 2
Level 2
Posts: 87
Joined: Thu Nov 15, 2007 9:41 am
Location: Germany

Re: error

Postby goetzkluge » Sun Jan 05, 2014 1:28 pm

I solved a perhaps related issue by by correcting clock settings:

Return to “Newbie Questions”

Who is online

Users browsing this forum: Mick-Cork and 13 guests