.dmrc ignored

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
donec
Level 4
Level 4
Posts: 333
Joined: Sun Nov 18, 2007 5:21 pm
Location: Texas
Contact:

.dmrc ignored

Post by donec » Sun May 25, 2008 11:20 pm

When I boot up I get a message saying user $home .dmrc ignored. What can I do about this?
Don
http://bestwebstop.webcentr.net
Links and accurate information provide the best answer, while garbage in provides garbage out.ImageRegistered Linux user # 449322
Moved up to LM17 KDE

User avatar
67GTA
Level 6
Level 6
Posts: 1300
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: .dmrc ignored

Post by 67GTA » Sun May 25, 2008 11:40 pm

The permissions in your /home folder has changed. Have you done anything recently to change it?
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke

Lantesh
Level 6
Level 6
Posts: 1214
Joined: Sat Apr 12, 2008 1:02 pm

Re: .dmrc ignored

Post by Lantesh » Mon May 26, 2008 2:49 am

Oh I'd be willing to bet you changed permissions on either your home folder, or a sub-folder of it. I had this issue once, and the fix wasn't pretty. I had to delete the user, and delete the user's home folder. I then had to re-create the user again after words. This was a pain in the rear end as it was my main user 1000. The lesson I learned from this was never ever modify home folder permissions other than the data folders like music or documents.

Also I should state that I certainly tried to repair the damage first. I fixed the permissions on the .dmrc file the computer was referencing. It just didn't work.

User avatar
Zwopper
Level 10
Level 10
Posts: 3077
Joined: Fri Nov 30, 2007 12:20 pm
Location: Deep in the Swedish woods
Contact:

Re: .dmrc ignored

Post by Zwopper » Mon May 26, 2008 3:53 am

Find the .dmrc file in your home folder, open it and check the contents, it should say "Session=Gnome" (depending on what version your running!), if it says anything else, change it.
...another option is to delete it, and the system will create a new one on your next login.
I first got this error after installing The main edition after KDE with the /home being intact from the former install.
Image
My artwork at deviantART | My Band - Electric Alchemea
CREA DIEM!

Lenovo U330P | i5 | 16GB | 128GB - SSD | Elemantary OS 0.4

Lantesh
Level 6
Level 6
Posts: 1214
Joined: Sat Apr 12, 2008 1:02 pm

Re: .dmrc ignored

Post by Lantesh » Mon May 26, 2008 4:55 am

Zwopper wrote:another option is to delete it, and the system will create a new one on your next login.
Damn really? I wish I would have known that back when I had the same problem. While my solution worked it was a hell of a lot more complicated. I can't believe all I had to do was delete the file, lol.

donec
Level 4
Level 4
Posts: 333
Joined: Sun Nov 18, 2007 5:21 pm
Location: Texas
Contact:

Re: .dmrc ignored

Post by donec » Mon May 26, 2008 1:38 pm

67GTA wrote:The permissions in your /home folder has changed. Have you done anything recently to change it?
Not that I know of.
Don
http://bestwebstop.webcentr.net
Links and accurate information provide the best answer, while garbage in provides garbage out.ImageRegistered Linux user # 449322
Moved up to LM17 KDE

donec
Level 4
Level 4
Posts: 333
Joined: Sun Nov 18, 2007 5:21 pm
Location: Texas
Contact:

Re: .dmrc ignored

Post by donec » Mon May 26, 2008 1:41 pm

Lantesh wrote:Oh I'd be willing to bet you changed permissions on either your home folder, or a sub-folder of it. I had this issue once, and the fix wasn't pretty. I had to delete the user, and delete the user's home folder. I then had to re-create the user again after words. This was a pain in the rear end as it was my main user 1000. The lesson I learned from this was never ever modify home folder permissions other than the data folders like music or documents.

Also I should state that I certainly tried to repair the damage first. I fixed the permissions on the .dmrc file the computer was referencing. It just didn't work.
I already tried changing the permissions on the .dmrc file with no help. It looks like there may be an easier way than yours so I'll try them first. :D
Don
http://bestwebstop.webcentr.net
Links and accurate information provide the best answer, while garbage in provides garbage out.ImageRegistered Linux user # 449322
Moved up to LM17 KDE

donec
Level 4
Level 4
Posts: 333
Joined: Sun Nov 18, 2007 5:21 pm
Location: Texas
Contact:

Re: .dmrc ignored

Post by donec » Mon May 26, 2008 1:48 pm

Zwopper wrote:Find the .dmrc file in your home folder, open it and check the contents, it should say "Session=Gnome" (depending on what version your running!), if it says anything else, change it.
...another option is to delete it, and the system will create a new one on your next login.
I first got this error after installing The main edition after KDE with the /home being intact from the former install.
I'll try changing Session=default to Session=Gnome and see if that helps then I'll delete it.
Don
http://bestwebstop.webcentr.net
Links and accurate information provide the best answer, while garbage in provides garbage out.ImageRegistered Linux user # 449322
Moved up to LM17 KDE

donec
Level 4
Level 4
Posts: 333
Joined: Sun Nov 18, 2007 5:21 pm
Location: Texas
Contact:

Re: .dmrc ignored

Post by donec » Mon May 26, 2008 2:10 pm

I tried changing the contents no help. I tried deleting it and it did not make a new one. So I am creating one and we'll see.
Don
http://bestwebstop.webcentr.net
Links and accurate information provide the best answer, while garbage in provides garbage out.ImageRegistered Linux user # 449322
Moved up to LM17 KDE

User avatar
67GTA
Level 6
Level 6
Posts: 1300
Joined: Wed Jun 06, 2007 9:49 pm
Location: Kentucky, USA

Re: .dmrc ignored

Post by 67GTA » Mon May 26, 2008 3:32 pm

Post the output of

Code: Select all

ls -l .dmrc
from a terminal.
"The only thing necessary for the triumph of evil is for good men to do nothing." Edmund Burke

darco
Level 4
Level 4
Posts: 205
Joined: Sat May 24, 2008 5:03 pm

Re: .dmrc ignored

Post by darco » Mon May 26, 2008 4:51 pm

I had this problem in Ububtu and I fixed it w/this command:

Code: Select all

chmod 700 /home/<yourusername>
chmod 644 /home/<yourusername>/.dmrc
reboot now
good luck!
darco

donec
Level 4
Level 4
Posts: 333
Joined: Sun Nov 18, 2007 5:21 pm
Location: Texas
Contact:

Re: .dmrc ignored

Post by donec » Mon May 26, 2008 6:28 pm

darco wrote:I had this problem in Ububtu and I fixed it w/this command:

Code: Select all

chmod 700 /home/<yourusername>
chmod 644 /home/<yourusername>/.dmrc
reboot now
good luck!
darco
Thanks darco, that fixed it. And thanks to everyone that tried to help. You guys are great.
Don
http://bestwebstop.webcentr.net
Links and accurate information provide the best answer, while garbage in provides garbage out.ImageRegistered Linux user # 449322
Moved up to LM17 KDE

Post Reply

Return to “Newbie Questions”