[SOLVED] Black screen after samba removal

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
velky_pivo
Level 2
Level 2
Posts: 62
Joined: Fri Sep 30, 2011 10:02 pm

[SOLVED] Black screen after samba removal

Post by velky_pivo » Wed Apr 17, 2013 6:33 pm

I decided to remove samba, python-smbc, libwbclient0, samba-common and samba-common-bin (used sw manager for removal), thinking that I did not need them.

Now when I restart the laptop, I get black screen (mouse pointer can be moved around), no Mate desktop, and the only way that I can think of to get out of that is via power button.
How can I reinstall those services ?

(I have 2 Hard Drives, each drive has just about identical installation of Mint 13 Maya 64bit on it, so I can peek from one HD to the other if that helps.
Each HD also has Windows on it.
I guess, broke my own golden rules "don't mess with what already works great", and "do research before you decide to mess with anything".)

Any help is appreciated
Last edited by velky_pivo on Thu Apr 18, 2013 12:35 pm, edited 1 time in total.

User avatar
bigj231
Level 5
Level 5
Posts: 790
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere
Contact:

Re: Black screen after samba removal

Post by bigj231 » Wed Apr 17, 2013 8:04 pm

Sounds like you hosed your x-server. You can switch to a different virtual console and log in there. Use [CTRL]+[ALT]+[F1] to switch. Your normal session is on F8. Try reinstalling MDM.

Code: Select all

sudo apt-get remove mdm
sudo apt-get install mdm
Running on a 4-slot toaster @ 60Hz

velky_pivo
Level 2
Level 2
Posts: 62
Joined: Fri Sep 30, 2011 10:02 pm

Re: Black screen after samba removal

Post by velky_pivo » Wed Apr 17, 2013 9:20 pm

It did not help. Still no Mate desktop. I also reinstalled Samba.
Any other suggestions ?

velky_pivo
Level 2
Level 2
Posts: 62
Joined: Fri Sep 30, 2011 10:02 pm

Re: Black screen after samba removal

Post by velky_pivo » Thu Apr 18, 2013 12:30 pm

Turns out that x server was running ok, and I could switch between terminal and desktop,
only the desktop was all dark, with all desktop components missing, and clicking anywhere on it with mouse did nothing.

I checked the Mate configuration files in /etc against the ones in my other Maya install, and found out that the uninstall of the samba related packages did make a modification to one (or more) of those Mate config files.

Since this now appeared to be a Mate desktop environment issue, I decided to reinstall Mate environment (without removing it first) :

sudo apt-get install mate-desktop-environment

This worked for me, and it did not touch desktop files, links, display settings or drivers, or other apps; so I am good to go.

Post Reply

Return to “Newbie Questions”