Linux Mint MATE and XRDP

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
bdman
Level 1
Level 1
Posts: 2
Joined: Thu Jun 13, 2013 7:39 am

Linux Mint MATE and XRDP

Postby bdman » Sat Jun 15, 2013 12:51 pm

I currently am running Linux Mint 15 with Mate desktop.
When I log into the Mint machine and then RDP from a Windows box, the desktop shows up fine and all a go. Using XRDP server and connecting with XRPD's RDP protocol.
When I am not logged into the Mint machine and RDP from a Windows box, the "Menu" button in the lower left is missing, and I have to hit ALT F1 to show the application menu.
Any assistance on which setting needs to be adjusted to fix this issue would be appreciated.

User avatar
boallen
Level 1
Level 1
Posts: 4
Joined: Wed Nov 21, 2012 1:54 am
Location: Colorado
Contact:

Re: Linux Mint MATE and XRDP

Postby boallen » Fri Sep 13, 2013 3:00 pm

Since this page comes up first in Google for "mint mate xrdp", I am going to post the solution to the problem I was having here :)

For some reason, my xrdp started having trouble (loading only desktop folders/files and no other UI elements). To fix this, I:


1.) Edited /etc/xrdp/startwm.sh to comment out the default and add "mate-session". Looks like this:

Code: Select all

#!/bin/sh

if [ -r /etc/default/locale ]; then
  . /etc/default/locale
  export LANG LANGUAGE
fi

# Default
#. /etc/X11/Xsession

# MATE
mate-session


2.) Created the .Xclients file in my home dir and made it executable. Commands:

Code: Select all

sudo echo "mate-session" > ~/.Xclients
sudo chmod +x ~/.Xclients


3.) Restarted xrdp:

Code: Select all

/etc/init.d/xrdp restart


Boom, fixed. <3

martinbaines
Level 1
Level 1
Posts: 8
Joined: Wed Sep 25, 2013 1:59 pm

Re: Linux Mint MATE and XRDP

Postby martinbaines » Wed Sep 25, 2013 2:06 pm

I had this same issue and tried the above and it did not fix the problem HOWEVER a little more probing and I found a solution that worked for me.

For many of the utilities to work remotely you must have a .Xauthority file in your home directory. To create one is simple from any terminal just use the following command

Code: Select all

touch ~/.Xauthority


Logout and log back in and it all should just work - or at least it did for me.

larryvc
Level 1
Level 1
Posts: 1
Joined: Mon Nov 10, 2014 4:19 pm

Re: Linux Mint MATE and XRDP

Postby larryvc » Mon Nov 10, 2014 5:18 pm

martinbaines post is spot on for Linux Mint 17 too. No changes to /etc/xrdp/startwm.sh were needed. Just having the .Xauthority file in your home directory does the trick.

User avatar
Voltron
Level 2
Level 2
Posts: 58
Joined: Tue Oct 21, 2014 12:48 am
Location: Indiana University--Bloomington

Re: Linux Mint MATE and XRDP

Postby Voltron » Wed Feb 04, 2015 4:06 am

Hello, larryvc:

I am trying to use xrdp & Remmina, to remote into a Linux Mint 17.1 (MATE) notebook computer; but, I am having problems getting connected. I have been successful creating an SSH tunnel and using the default VNC client (Vino) inside this tunnel; however, it is slow and it only opens the logged-in session, on the remote system. I would like to use xrdp to log onto my own session, on the remote system, without needing someone, on the remote system, to be already logged on. Do I need to install something other than Vino, to make this work, with xrdp or can xrdp use Vino, too? And, regarding your post from November 10, 2014, do I simply need to create a blank .Xauthority file in my own home directory? Is this the home directory on my local system or the remote system?

I would greatly appreciate your assistance, as this appears to be the last thing I need to get working, to complete my remote administration-related tasks. Thank you, larryvc and thanks to anyone for their assistance; this Linux Mint "newbie" greatly appreciates the help.


Return to “Newbie Questions”

Who is online

Users browsing this forum: No registered users and 8 guests