How to disable mouse accel and change polling rate?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Locked
pejorative
Level 1
Level 1
Posts: 1
Joined: Fri Aug 02, 2013 5:50 am

How to disable mouse accel and change polling rate?

Post by pejorative » Fri Aug 02, 2013 6:08 am

Greetings to you.

The last couple of days I've been trying to completely and permanently remove mouse accel, as well as set mouse hz (polling rate) to 500.
I want to do this because I play Quake and need a "true" mouse response. Google did not help much.

These pages have given me some idea of what to do, but I usually get stuck when trying to find the files that are refered to (do they even exist in mint?).
https://wiki.archlinux.org/index.php/Mouse_Polling_Rate
https://wiki.archlinux.org/index.php/Mouse_acceleration

Also, how do you change the mouse sensitivity (resolution)? On a low-DPI mouse, the cursor moves too slow on a x1080p screen.
The mouse preferences program sems to only change acceleration strength and threshold.

System info:
Mint 15, MATE, x64
System: Host: SafeMint Kernel: 3.8.0-19-generic x86_64 (64 bit, gcc: 4.7.3) Desktop: N/A Distro: Linux Mint 15 Olivia
Machine: Mobo: ASUSTeK model: P8Z68-V PRO version: Rev 1.xx Bios: American Megatrends version: 3402 date: 05/07/2012
CPU: Quad core Intel Core i5-2500K CPU (-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27198.6
Clock Speeds: 1: 3399.833 MHz 2: 3399.833 MHz 3: 3399.833 MHz 4: 3399.833 MHz
Graphics: Card: Advanced Micro Devices [AMD] nee ATI Cape Verde XT [Radeon HD 7770 GHz Edition] bus-ID: 01:00.0
X.Org: 1.13.3 drivers: ati,fglrx (unloaded: fbdev,vesa,radeon) Resolution: 1920x1080@60.0hz
GLX Renderer: AMD Radeon HD 7700 Series GLX Version: 4.2.12002 - CPC 9.012 Direct Rendering: Yes
Audio: Card-1: Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Card-2: Advanced Micro Devices [AMD] nee ATI Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] driver: snd_hda_intel bus-ID: 01:00.1
Card-3: Texas Instruments Japan PCM2900B Audio CODEC driver: USB Audio usb-ID: 08bb:29b0
Sound: Advanced Linux Sound Architecture ver: k3.8.0-19-generic
Network: Card: Ralink RT2561/RT61 802.11g PCI driver: rt61pci ver: 2.3.0 bus-ID: 07:01.0
IF: wlan2 state: up mac: <filter>
Drives: HDD Total Size: 3184.7GB (46.3% used) 1: id: /dev/sda model: C300 size: 64.0GB
2: id: /dev/sdb model: KINGSTON_SV300S3 size: 120.0GB 3: id: /dev/sdc model: WDC_WD1001FALS size: 1000.2GB
4: id: /dev/sdd model: G3_Station size: 2000.4GB
Partition: ID: / size: 102G used: 6.6G (7%) fs: ext4 ID: swap-1 size: 9.13GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: None detected - is lm-sensors installed and configured?
Info: Processes: 191 Uptime: 2:02 Memory: 1056.9/7953.8MB Runlevel: 2 Gcc sys: 4.7.3 Client: Shell inxi: 1.8.4
safethrow@SafeMint /usr/share/X11/xorg.conf.d $ xinput list-props 9
Device 'DATACOMP SteelS쀁Љ̒DATA':
Device Enabled (142): 1
Coordinate Transformation Matrix (144): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
Device Product ID (260): 1204, 257
Device Node (261): "/dev/input/event3"

Mouse
Device 'Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)':
Device Enabled (142): 1
Coordinate Transformation Matrix (144): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
Device Accel Profile (273): 0
Device Accel Constant Deceleration (274): 1.000000
Device Accel Adaptive Deceleration (275): 1.000000
Device Accel Velocity Scaling (276): 10.000000
Device Product ID (260): 1118, 64
Device Node (261): "/dev/input/event5"
Evdev Axis Inversion (277): 0, 0
Evdev Axes Swap (279): 0
Axis Labels (280): "Rel X" (152), "Rel Y" (153), "Rel Vert Wheel" (272)
Button Labels (281): "Button Left" (145), "Button Middle" (146), "Button Right" (147), "Button Wheel Up" (148), "Button Wheel Down" (149), "Button Horiz Wheel Left" (150), "Button Horiz Wheel Right" (151)

User avatar
Spearmint2
Level 15
Level 15
Posts: 5759
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: How to disable mouse accel and change polling rate?

Post by Spearmint2 » Fri Aug 02, 2013 11:53 pm

mouse settings are in the Hardware section of the Control Center, available from the Menu button.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
loligater
Level 1
Level 1
Posts: 8
Joined: Tue Aug 13, 2013 5:39 pm

Re: How to disable mouse accel and change polling rate?

Post by loligater » Tue Aug 13, 2013 5:41 pm

Spearmint2 wrote:mouse settings are in the Hardware section of the Control Center, available from the Menu button.
This is not configurable there, at least the ability for 1:1 is not available.

OP: I have actually used the links you provided to figure it out. I will post back later with my results. I have since reinstalled Mint and don't have my files anymore, it took a lot of poking around.

If no one else gets back to you, I'll be back with what I have tonight or tomorrow afternoon.

EDIT: I know I did work in the xorg.conf.d folder:

Code: Select all

cd /usr/share/X11/xorg.conf.d
and:

Code: Select all

cd /usr/lib/X11
Otherwise if you wanna do it with explorer, just open terminal and type:

Code: Select all

sudo nemo
Last edited by loligater on Sun May 15, 2016 11:33 pm, edited 1 time in total.

User avatar
loligater
Level 1
Level 1
Posts: 8
Joined: Tue Aug 13, 2013 5:39 pm

Re: How to disable mouse accel and change polling rate?

Post by loligater » Fri Aug 16, 2013 4:23 pm

Alright here is my fix.

Open Terminal and run the following command. Then find your mouse/touchpad on the list

Code: Select all

xinput list
Then do the following

Code: Select all

cd /usr/share/X11/xorg.conf.d
sudo touch 50-mouse-acceleration.conf
sudo gedit 50-mouse-acceleration.conf
Paste the following into the file

Code: Select all

Section "InputClass"
	Identifier "My Mouse"
	MatchIsPointer "yes"
	Option "AccelerationProfile" "-1"
	Option "AccelerationScheme" "none"
EndSection
Replace "My Mouse" with the name of the mouse/touchpad you got out of xinput earlier. Keep the double quotes. Example, mine shows as: "ETPS/2 Elantech Touchpad"

I hope this helps!

vishal
Level 1
Level 1
Posts: 4
Joined: Wed Oct 03, 2018 10:30 pm

Re: How to disable mouse accel and change polling rate?

Post by vishal » Wed Oct 03, 2018 10:39 pm

@loligater
This solved the issue at first. But when I started my laptop next morning the mouse acceleration was still there. The conf file was also present there with the same values that worked after logout & login.

Operating System: Linux Mint 19
Laptop: Dell Vostro 15
Last edited by vishal on Wed Oct 03, 2018 10:44 pm, edited 1 time in total.

User avatar
Pierre
Level 18
Level 18
Posts: 8687
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: How to disable mouse accel and change polling rate?

Post by Pierre » Wed Oct 03, 2018 10:43 pm

Hi vishal,

it would be prudent, to start another post about your issue,
& where you can get some better advice about your mouse issue.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Locked

Return to “Newbie Questions”