Page 1 of 1

dummy card sound issues

Posted: Tue Aug 27, 2013 1:00 am
by accessdennied
after tyring a bunch of forums none helped so ill try a more personal approach i cant get any sound from my pc what so ever help

Re: dummy card sound issues

Posted: Tue Aug 27, 2013 1:20 am
by nomko
Please, read this first and in particular rule #5:
[5] Details! Details! Details!
Include the version and architecture (32-bit, 64-bit) of Linux Mint.
List any relevant hardware or software specifications. 'inxi' is a useful terminal command for listing this. Use inxi -h for help. Generally it suffices to type the following in terminal and include the output in your post -> inxi -Fxz
List what Display Environment you are using if relevant (GNOME, KDE, XFCE, LXDE, etc).
So, to follow up this rule, please copy/paste the output of the following terminal command here:

Code: Select all

inxi -F

Re: dummy card sound issues

Posted: Wed Aug 28, 2013 8:29 pm
by accessdennied
System: Host: augmentation Kernel: 3.8.0-19-generic x86_64 (64 bit) Desktop: Gnome Distro: Linux Mint 15 Olivia
Machine: System: Hewlett-Packard product: HP G62 Notebook PC version: 058F110000242710010620100
Mobo: Hewlett-Packard model: 1444 version: 69.37 Bios: Hewlett-Packard version: F.29 date: 04/07/2011
CPU: Dual core AMD Athlon II P340 (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 sse4a svm)
Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz
Graphics: Card: Advanced Micro Devices [AMD] nee ATI RS880M [Mobility Radeon HD 4225/4250]
X.Org: 1.13.3 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1366x768@59.6hz
GLX Renderer: Gallium 0.4 on AMD RS880 GLX Version: 3.0 Mesa 9.1.3
Audio: Card-1: Advanced Micro Devices [AMD] nee ATI RS880 HDMI Audio [Radeon HD 4200 Series]
Card-2: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)
Network: Card-1: Atheros AR9285 Wireless Network Adapter (PCI-Express) driver: ath9k
IF: wlan0 state: up mac: 90:00:4e:22:b6:43
Card-2: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver: r8169
IF: eth0 state: down mac: 98:4b:e1:a8:40:cf
Drives: HDD Total Size: 320.1GB (14.3% used) 1: id: /dev/sda model: WDC_WD3200BEVT size: 320.1GB
Partition: ID: / size: 291G used: 43G (16%) fs: ext4 ID: swap-1 size: 2.95GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 92.5C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 150 Uptime: 18:23 Memory: 842.6/2754.1MB Client: Shell inxi: 1.8.4

srry bout that half asleep not thinking

Re: dummy card sound issues

Posted: Wed Aug 28, 2013 9:51 pm
by Spearmint2
Two sound chips active at the same time?

Code: Select all

Audio: Card-1: Advanced Micro Devices [AMD] nee ATI RS880 HDMI Audio [Radeon HD 4200 Series]

Card-2: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)
[url=]I see you tried some adjusting for HDMI for a TV earlier,[/url] but didn't get any answer in these forums to your problem. You solved that problem already? You say no sound whatsoever, but does that also include no sound to the TV? Or does the TV serve as both TV and monitor for you? Are you currently connected to the TV or another monitor by HDMI?

Re: dummy card sound issues

Posted: Thu Aug 29, 2013 1:44 pm
by accessdennied
No i do not have anything in my hdmi port but i found a fix (pretty simple) i downloaded the driver for my said chipset and worked fine got sound back and even sound through hdmi which i did not have before (if any ones reading this for an answer)

go to your fav search site (google, etc) and type in the kind of computer u have
EX. "hp g62 drivers"
to find out what drivers came with ur system before linux install
(if u have the same computer as mine ul have a realtek driver)
now that u know the \name of the driver that originally came with your computer u can download said driver
since my driver is realtek i ended up googling that
EX. xxxxxxxxxxxxxx (the x's being the specific driver that came with your pc)

1. Download said driver

2. Open terminal.

3. Type: "sudo su" and enter root password.

4. Change to the folder where you downloaded the driver (ie: "cd ~/Downloads")

4. Type: "tar -xjf LinuxPkg_XXX.tar.bz2" , where XXX is the version of your downloaded driver (as sown in filename, example: "tar -xjf LinuxPkg_5.17rc13.tar.bz2").

5. Type: "cd realtek-linux-audiopack-YYY" , where YYY is the version of your downloaded driver (as shown if folder name, example: "cd realtek-linux-audiopack-5.17").

6. Type "tar -xjf alsa-driver-ZZZ.tar.bz2" , where ZZZ is the version corresponding to the filename (example: "tar -xjf alsa-driver-1.0.25-5.17rc13.tar.bz2").

7. Type "cd alsa-driver-WWW" , where WWW is the version corresponding to the folder name (example: "cd alsa-driver-1.0.25").

8. Type "./configure --with-cards=hda-intel"

9. Type "make"

10. Type "make install"

11. Reboot

12. Test the audio output. You can do this by right-clicking on you speaker icon and selecting sound preferences -> hardware -> select the desired audio output -> select the desired surround profile (ie: Analog Surround 5.1 Output + Analog Stereo Input) -> Test Speakers. During the installation the sound level can be mutted, check out in the slider if it is not mute!

if u do not have a realtek driver or chipset please just replace "realtek" with what ever ur specific driver name

Re: dummy card sound issues

Posted: Fri Aug 30, 2013 12:53 am
by z1p101
This has been a problem with the xorg ati HDMI driver for a while now.They disabled the HDMI sound to fix some other bug that applies to some brand of monitor. Went through it myself a couple of weeks ago.

What you need to do is open the file /etc/default/grub as root (use sudo) with a text editor and add ""to the line GRUB_CMDLINE_LINUX=.

It should look something like

Code: Select all

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"
Just add "", don't delete other things if they are there and then run

Code: Select all

sudo update-grub
Reboot and HDMI sound should be there.

[url=]Here is a list of other things you may want to add.[/url] This only appies to the xorg radeon driver not the Catalyst one.