Page 1 of 1

synaptic error - won't start

Posted: Sun Sep 01, 2013 3:53 pm
by KoD
Hi,

I made the following n00b mistake:

I added the kali repos THROUGH synaptic.
After that synaptic won't start, it flashes for 1/2 second, then goes away. ALL package tools are broken.
Already dusted off /etc/apt/sources.list && /etc/apt/sources.list.save as both were corrupted.
Also already tried using live cd & chroot (mnt --bind /dev & /proc & /sys & /etc/apt) to
(i) sudo apt-get install aptitude --reinstall
(ii) sudo apt-get install synaptic --reinstall

==> NO ERRORS, but DIDN'T solve the Problem.

I already thought about a complete reinstall, but I installed so mutch software already, that I don't want to go through the pain of having to precure it again.

Code: Select all

sudo inxi -Sr

System:    Host: <blackened> Kernel: 3.8.0-29-generic x86_64 (64 bit) Desktop: N/A Distro: Linux Mint 15 Olivia
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com olivia main upstream import #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu raring main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu raring-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ raring-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ raring partner
           Active apt sources in file: Binary file /etc/apt/sources.list.d/bumblebee-stable-raring.list matches
           Binary file /etc/apt/sources.list.d/bumblebee-stable-raring.list matches
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com olivia main upstream import
           deb http://archive.ubuntu.com/ubuntu raring main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu raring-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ raring-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ raring partner
           Active apt sources in file: /etc/apt/sources.list.d/steam.list
           deb [@] http://repo.steampowered.com/steam/ precise stea m
           deb-src http://repo.steampowered.com/steam/ precise steam
           Active apt sources in file: /etc/apt/sources.list.d/ubuntu-x-swat-x-updates-raring.list
           deb [p] http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ raring mai n
           deb-src [�] http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ raring mai n


thanks for a speedy reply

KoD

P.S.: Does anyone have a complete Kali software list? I prefer LinuxMint to Kali but am rdesigning my network from scratch and want to be able to monitor it regularly from Mint (on the side, for sec & pure interest, as I'm new to this sort of thing)

Re: synaptic error - won't start

Posted: Sun Sep 01, 2013 11:23 pm
by Spearmint2

Code: Select all

info dpkg

Code: Select all

info make
http://debian.lcs.mit.edu/debian/pool/main/a/apt/apt_0.9.7.9.tar.gz

Run Make after unzipping

Back up the tree and you can find deb type package files for use with dpkg

Re: synaptic error - won't start

Posted: Mon Sep 02, 2013 3:27 am
by z1p101
Try what I suggested here [url=http://forums.linuxmint.com/viewtopic.php?f=90&t=143297]viewtopic.php?f=90&t=143297[/url] bottom post.

Something is messed up with synaptic and mint I think.

Re: synaptic error - won't start

Posted: Mon Sep 02, 2013 4:14 pm
by KoD
Hi,

1. thanks for your quick replies

2. @ z1p101:
I already tried out what you'd suggested there (thanks anyway).

3. @ Speramint2:
I ran

Code: Select all

dpkg --get-selections >  <backup folder>
cd <folder with unpacked apt package>
make
(...)
checking db.h usability... no
checking db.h presence... no
checking for db.h... no
checking for curl_easy_init in -lcurl... no
configure: error: failed: I need CURL due https support
make: *** [build/config.status] Error 1
I checked the dpkg --get-selections list and found:
libcurl3:amd64
libcurl3-gnutls:amd64

I googled libcurl.tar but couldn't determine (lack of XP again), wether the website was trustworthy or not.

how should I proceed?



Greetings

KoD

Re: synaptic error - won't start

Posted: Mon Sep 02, 2013 7:07 pm
by Spearmint2
I googled libcurl.tar but couldn't determine (lack of XP again), wether the website was trustworthy or not.
how should I proceed?
If talking the link I gave you, it's MIT, aka Massachusetts Instituted of Technology.

http://debian.lcs.mit.edu/debian/pool/main/a/apt/

Is the main folder. Maybe the one I linked to was wrong for a 64 bit system.

I downloaded it, extracted and then ran make -n on it and got make: Nothing to be done for `/home/mint14/Downloads/Makefile'.

Why not just search all "apt" folders in the Mint LIVE disc and transfer the folders into the installed version?

Re: synaptic error - won't start

Posted: Wed Sep 04, 2013 4:56 am
by KoD
Progress!

/etc/apt/sources.list.de/* : files contained random space characters. Taking them out at least got (graphic) synaptic to print the following error message:
E: Malformed line 1 in source list /etc/apt/sources.list.d/steam.list ([option] too short)
E: The list of sources could not be read.
Go to the repository dialog to correct the problem.
E: _cache->open() failed, please report.
I'll go look up "deb [<options>]" (and derivations thereof) to see if I can find anything useful.

@Spearmint2:
I read your post, I'll get back to you there later

Re: synaptic error - won't start

Posted: Sat Sep 14, 2013 4:44 pm
by KoD
[SOLVED]

Finally!

Error:

/etc/apt/sources.list:
More illegal space characters + all the "[" and "]" characters caused trouble (I checked on a different install).

THANKS for the excellent support I received on the forum!!! :D

KoD

P.S.: I'll definitely continue using LinuxMint!

Re: synaptic error - won't start

Posted: Sat Sep 14, 2013 6:11 pm
by Spearmint2
space characters. Firefox uses them too. Gave me a fit on something till I figured how to negate a space in Linux when using commands in terminal. If you have something like

/file/second file/file.txt, and you need to run a command in terminal and can't remove the space because the program needs it you would put a backslash in front of the space, like this;

/file/second\ file/file.txt