[SOLVED] Messed up hard disk!

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
dave_s
Level 1
Level 1
Posts: 11
Joined: Sat Nov 07, 2009 6:37 am

[SOLVED] Messed up hard disk!

Post by dave_s »

Ok, long story short.

Installed Ubuntu 12.04 on my Asus X401A laptop. Ran like a pig.
Installed Linux Mint 15 but got some error messages referring to Ubuntu for some reason.
Decided to wipe the HDD clean using GParted.
Reinstalled Mint from USB pen drive but when it reboots it's not detecting the hdd and so boots from the usb instead.

Tried wiping the hdd again and keep getting the message:
/dev/sdb contains GPT signatures, indicating that it has a GPT table. However, it does not have a valid fake msdos partition table, as it should. Perhaps it was corrupted -- possibly by a program that doesn't understand GPT partition tables. Or perhaps you deleted the GPT table, and are now using an msdos partition table. Is this a GPT partition table?
sda is the hdd.
sdb is the pen drive.

I'm really out my depth here and have no idea what it is I've messed up.

Is there an idiot proof guide to wiping the hdd and starting over?

Thanks for any advice

Dave
Last edited by dave_s on Mon Sep 16, 2013 9:35 am, edited 1 time in total.
User avatar
WharfRat
Level 21
Level 21
Posts: 13906
Joined: Thu Apr 07, 2011 8:15 pm

Re: Messed up hard disk!

Post by WharfRat »

dave_s,

Never saw that before. I'm assuming the USB runs so open the terminal and paste back the following

Code: Select all

udisks --show-info /dev/sda |grep scheme

Code: Select all

udisks --show-info /dev/sdb |grep scheme

Code: Select all

sudo blkid
ImageImage
dave_s
Level 1
Level 1
Posts: 11
Joined: Sat Nov 07, 2009 6:37 am

Re: Messed up hard disk!

Post by dave_s »

Thanks WharfRat,

Here's what terminal reported:

Code: Select all

mint@mint ~ $ udisks --show-info /dev/sda |grep scheme
    scheme:                    gpt

Code: Select all

mint@mint ~ $ udisks --show-info /dev/sdb |grep scheme
    scheme:                    mbr

Code: Select all

mint@mint ~ $ sudo blkid
/dev/loop0: TYPE="squashfs" 
/dev/sda1: UUID="D144-EC65" TYPE="vfat" 
/dev/sda2: UUID="b31079b1-32a5-4efd-8f09-4f5a569bd878" TYPE="ext4" 
/dev/sda3: UUID="f8ab791e-3406-4d54-aa13-96eed7059a03" TYPE="swap" 
/dev/sdb1: LABEL="PENDRIVE" UUID="8D10-7250" TYPE="vfat"
Thanks for the assist, really appreciated.

Dave
dave_s
Level 1
Level 1
Posts: 11
Joined: Sat Nov 07, 2009 6:37 am

Re: Messed up hard disk!

Post by dave_s »

Just to clarify my original post.

The message I referred to is coming up when I use GParted not during boot.
/dev/sdb contains GPT signatures, indicating that it has a GPT table. However, it does not have a valid fake msdos partition table, as it should. Perhaps it was corrupted -- possibly by a program that doesn't understand GPT partition tables. Or perhaps you deleted the GPT table, and are now using an msdos partition table. Is this a GPT partition table?
Thanks
User avatar
WharfRat
Level 21
Level 21
Posts: 13906
Joined: Thu Apr 07, 2011 8:15 pm

Re: Messed up hard disk!

Post by WharfRat »

Dave,

I plan on purchasing or building a new machine before the end of the year so I've been looking into the UEFI/GPT architecture in order to have an uneventful linux installation experience. Unfortunately with conflicting information and claims of still trying to iron out the standards, it's like trying to nail jello to the wall :?

From what I've been able to glean from the research is you have to have UEFI/GPT or BIOS/MBR combination. There's no mixing allowed e.g., UEFI/MBR.

With your sda being GPT you probably have to turn on UEFI in your setup screen or something or format the drive MBR and turn off UEFI. Again I haven't crossed this bridge yet so I can't be of much.

Good luck :wink:
ImageImage
wayne128
Level 10
Level 10
Posts: 3410
Joined: Tue Jul 13, 2010 12:15 am

Re: Messed up hard disk!

Post by wayne128 »

dave_s wrote:Thanks WharfRat,

Here's what terminal reported:

Code: Select all

mint@mint ~ $ udisks --show-info /dev/sda |grep scheme
    scheme:                    gpt

Code: Select all

mint@mint ~ $ udisks --show-info /dev/sdb |grep scheme
    scheme:                    mbr

Code: Select all

mint@mint ~ $ sudo blkid
/dev/loop0: TYPE="squashfs" 
/dev/sda1: UUID="D144-EC65" TYPE="vfat" 
/dev/sda2: UUID="b31079b1-32a5-4efd-8f09-4f5a569bd878" TYPE="ext4" 
/dev/sda3: UUID="f8ab791e-3406-4d54-aa13-96eed7059a03" TYPE="swap" 
/dev/sdb1: LABEL="PENDRIVE" UUID="8D10-7250" TYPE="vfat"
Thanks for the assist, really appreciated.

Dave
The above information seems to say that
1. your USB is /dev/sdb and it is msdos vfat format
2. your HDD is /dev/sda, is GPT format and has vfat on /dev/sda which is usually the bios-boot partition for UEFI.

If my reading is correct... then here are the first method to try ::::
Use the boot-repair.
https://help.ubuntu.com/community/Boot-Repair

It should repair 'automagically' and make your OS bootable..

If that does not work... I would then suggest second method,, which is going back to msdos-format /legacy/mbr method, you can read more detailed instruction how to format to msdos using gparted in my post , link here:
http://forums.linuxmint.com/viewtopic.php?f=46&t=141972&hilit=+msdos#p751297
kwisher
Level 5
Level 5
Posts: 780
Joined: Wed Mar 05, 2008 12:54 pm
Location: Greentown, Indiana USA

Re: Messed up hard disk!

Post by kwisher »

Sounds like you did not choose /dev/sda to install grub to during the install. Grub must have installed to the USB drive.
The instructions suggested Windows XP or better, so I installed Linux :)
dave_s
Level 1
Level 1
Posts: 11
Joined: Sat Nov 07, 2009 6:37 am

Re: Messed up hard disk!

Post by dave_s »

wayne128 wrote:
The above information seems to say that
1. your USB is /dev/sdb and it is msdos vfat format
2. your HDD is /dev/sda, is GPT format and has vfat on /dev/sda which is usually the bios-boot partition for UEFI.

If my reading is correct... then here are the first method to try ::::
Use the boot-repair.
https://help.ubuntu.com/community/Boot-Repair

It should repair 'automagically' and make your OS bootable..

If that does not work... I would then suggest second method,, which is going back to msdos-format /legacy/mbr method, you can read more detailed instruction how to format to msdos using gparted in my post , link here:
http://forums.linuxmint.com/viewtopic.php?f=46&t=141972&hilit=+msdos#p751297
Bingo!

Boot-repair did the trick.

Thanks so much Wayne128, I now have a working computer.

Really appreciate your help.

Dave
Post Reply

Return to “Newbie Questions”