Problem when I shut down, and when I turn on my laptop

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
pinovski
Level 1
Level 1
Posts: 31
Joined: Mon Aug 26, 2013 11:07 am

Problem when I shut down, and when I turn on my laptop

Post by pinovski » Tue Sep 17, 2013 1:07 pm

Hello.

Linux mint 15 Olivia, Cinnamon 32 bit, working in a laptop TOSHIBA.

It's the first time I use linux, I come from windows, and my knowledge is limited. :(

The OS works fine, but when I turn off and turn on my computer, this is loading forever LM logo, and if i type supr my laptop says: ''enabling laptop mode............¡¡, never gets off or turn-on unless I press the power button manually.

What could i do?

Thanks and regards.

User avatar
Spearmint2
Level 15
Level 15
Posts: 5719
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Problem when I shut down, and when I turn on my laptop

Post by Spearmint2 » Tue Sep 17, 2013 1:29 pm

It's a UUID problem with Swap usually. Some of the helpful threads below are more than one page. Try the one with asterick by it first.

http://forums.linuxmint.com/viewtopic.php?f=90&t=137381#p732724

http://forums.linuxmint.com/viewtopic.php?f=90&t=136960

http://forums.linuxmint.com/viewtopic.php?f=90&t=138521

http://forums.linuxmint.com/viewtopic.php?f=90&t=142224

* http://forums.linuxmint.com/viewtopic.php?f=90&t=143909

http://forums.linuxmint.com/viewtopic.php?f=90&t=143011
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

pinovski
Level 1
Level 1
Posts: 31
Joined: Mon Aug 26, 2013 11:07 am

Re: Problem when I shut down, and when I turn on my laptop

Post by pinovski » Fri Sep 20, 2013 9:35 am

Hello Spear, thanks for your help, you are very patient.

I have done all you said in other post:
Spearmint2 wrote:change of UUID on swap can break suspend, sleep, hibernation functions, because that's where it puts the info to bring the system back up. Unfortunately when the UUID changes, it doesn't also get updated everywhere it needs to be. Hopefully they will one day fix that in an upcoming edition. All of these must match for swap's identity, either in UUID, or dev drive designation, or Label.

The swap partition

Code: Select all

    sudo blkid

the resume line for grub

Code: Select all

cat /etc/default/grub |grep GRUB_CMDLINE

resume line for ramdisk

Code: Select all

cat /etc/initramfs-tools/conf.d/resume

mount line for swap file

Code: Select all

cat /etc/fstab |grep swap

However my problem still... :(, sure that i have only type that commands in my terminal? as i said before im a linux beginner, so i dont know a lot...

thanks and regards

User avatar
Spearmint2
Level 15
Level 15
Posts: 5719
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Problem when I shut down, and when I turn on my laptop

Post by Spearmint2 » Fri Sep 20, 2013 1:55 pm

Those commands just let you see what's there. Most then post it in the thread if unsure of what it means or how to correct it. Corrections are made using a text editor like nemo, pluma, gedit, in the files themselves. Here's a few threads on similar or same situation that might help you.

http://forums.linuxmint.com/viewtopic.php?f=90&t=141567

http://forums.linuxmint.com/viewtopic.php?f=90&t=143909
He needed some added help to edit. You can use the examples there.

http://forums.linuxmint.com/viewtopic.php?f=90&t=142224
what encryption can do to mess things up with swap, different needs

http://forums.linuxmint.com/viewtopic.php?f=90&t=136960
when it all matches correctly, but still doesn't work properly.

http://forums.linuxmint.com/viewtopic.php?f=90&t=137623
short and sweet fix for him

for instance, if you needed to change the swap entry in the fstab file you'd do this. Remember, the # at beginning of a line means it's just a comment, not acted on by the system. So, you will see that followed by the device that swap was on when the system was first loaded, and then below will be the UUID line for swap which must be correct.

Code: Select all

sudo pluma /etc/fstab
the following is what the UUID of the swap actually is, it's the other locations mentioned above that may have an old or wrong entry.

Code: Select all

sudo blkid
When you finish that, go to the resume files, and then run the initramfs update too.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
beirapadua
Level 1
Level 1
Posts: 32
Joined: Fri Dec 21, 2012 8:37 am

Re: Problem when I shut down, and when I turn on my laptop

Post by beirapadua » Fri Sep 20, 2013 10:38 pm

or u can try upgrading your kernel
I have the same problem as you.
recently i upgraded from 3.8.0-19 to 3.8.0-30

[url]http://forum.linuxmint.com/viewtopic.php?f=90&t=145575[/url]

And now my laptop shuts down properly.

I upgraded kernel using this:

Code: Select all

sudo apt-get dist-upgrade
though others can advise better and easier ways/solutions
:D

pinovski
Level 1
Level 1
Posts: 31
Joined: Mon Aug 26, 2013 11:07 am

Re: Problem when I shut down, and when I turn on my laptop

Post by pinovski » Tue Oct 08, 2013 10:55 am

hello beirapadua sorry but still not working upgrading :|

spearmint, thanks but ...

i followed your instructions and i have:

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/mint--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=2073b2b6-318f-4366-b648-c1596baecf91 /boot           ext2    defaults        0       2
/dev/mapper/mint--vg-swap_1 none            swap    sw              0       0
using sudo pluma /etc/fstab

gabriel@TOSHIBA ~ $ sudo blkid

Code: Select all

/dev/sda1: UUID="2073b2b6-318f-4366-b648-c1596baecf91" TYPE="ext2" 
/dev/sda5: UUID="s6nJIo-Lcki-nMes-FWj5-yrpE-75uz-c02yUk" TYPE="LVM2_member" 
/dev/mapper/mint--vg-root: UUID="d0aa7b89-2677-41a2-a5cc-002f4c48f86f" TYPE="ext4" 
/dev/mapper/mint--vg-swap_1: UUID="c40fcc0a-cc21-415b-995f-41b0a9152454" TYPE="swap" 
using sudo blkid

Code: Select all

gabriel@TOSHIBA ~ $ cat /etc/initramfs-tools/conf.d/resume
RESUME=UUID=c40fcc0a-cc21-415b-995f-41b0a9152454



Code: Select all

cat /etc/fstab | grep swap

/dev/mapper/mint--vg-swap_1 none            swap    sw              0       0

Code: Select all

gabriel@TOSHIBA ~ $ blkid -o list
device     fs_type label    mount point    UUID
-------------------------------------------------------------------------------
/dev/sda1  ext2             /boot          2073b2b6-318f-4366-b648-c1596baecf91
/dev/sda5  LVM2_member      (not mounted)  s6nJIo-Lcki-nMes-FWj5-yrpE-75uz-c02yUk
/dev/mapper/mint--vg-root
           ext4             /              d0aa7b89-2677-41a2-a5cc-002f4c48f86f
/dev/mapper/mint--vg-swap_1
           swap             <swap>         c40fcc0a-cc21-415b-995f-41b0a9152454

sudo pluma /etc/initramfs-tools/conf.d/resume

Code: Select all

RESUME=UUID=c40fcc0a-cc21-415b-995f-41b0a9152454
but i dont understand what i should do with all this information...... sorry for disturb you maybe linux minx its too difficult for a beginner as me :/

User avatar
Spearmint2
Level 15
Level 15
Posts: 5719
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Problem when I shut down, and when I turn on my laptop

Post by Spearmint2 » Tue Oct 08, 2013 7:44 pm

Everywhere you see the Resume=**************

change it to Resume=/dev/mapper/mint--vg-swap_1

As mentioned before, things have to be done a bit different for Resume with encrypted systems. If your entire system and not just the HOME section is encrypted, then I don't know that you are able to use Sleep nor Hibernation.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

pinovski
Level 1
Level 1
Posts: 31
Joined: Mon Aug 26, 2013 11:07 am

Re: Problem when I shut down, and when I turn on my laptop

Post by pinovski » Wed Oct 09, 2013 1:54 am

Ok thanks, now i have:

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDL[color=#FF0000]INE_LINUX="Resume=/dev/mapper/mint--vg-swap_1"[/color]

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
I hope that now can work, thanks!

EDIT: still not working, my laptop never shut down, always hibernating and sleeping :'(

User avatar
Spearmint2
Level 15
Level 15
Posts: 5719
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Problem when I shut down, and when I turn on my laptop

Post by Spearmint2 » Wed Oct 09, 2013 2:25 pm

what is this?!

Code: Select all

GRUB_CMDL[color=#FF0000]INE_LINUX="Resume=/dev/mapper/mint--vg-swap_1"[/color]
Don't put that color html coding in that line!
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

pinovski
Level 1
Level 1
Posts: 31
Joined: Mon Aug 26, 2013 11:07 am

Re: Problem when I shut down, and when I turn on my laptop

Post by pinovski » Wed Oct 09, 2013 11:31 pm

oh dont worry it was only for help you to locate that important line in the text, obviusly im not so crazy, in the real file i dont have that.

thanks anyway, what do you think could be the problem?

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="Resume=/dev/mapper/mint--vg-swap_1"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

User avatar
WharfRat
Level 20
Level 20
Posts: 11550
Joined: Thu Apr 07, 2011 8:15 pm

Re: Problem when I shut down, and when I turn on my laptop

Post by WharfRat » Thu Oct 10, 2013 12:05 am

pinovski,

Don't use an uppercase 'R' in resume - use GRUB_CMDLINE_LINUX="resume=/dev/mapper/mint--vg-swap_1"

Then run

Code: Select all

sudo /usr/sbin/update-grub
to update grub.cfg with that line
ImageImage

Post Reply

Return to “Newbie Questions”