Could not launch Application

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
velky_pivo
Level 2
Level 2
Posts: 52
Joined: Fri Sep 30, 2011 10:02 pm

Could not launch Application

Post by velky_pivo » Wed Sep 25, 2013 2:24 pm

LM13-64bit-Mate

I installed Python recently but it will not start from the menu. It runs ok manually from mate-terminal.

Popup error says:

Could not launch 'Python (v2.7)'
Failed to execute child process "xterm" (No such file or directory)

I found that somebody fixed this by either
1) setting up "sim link to /usr/bin"
quote: "Just create a sim link with the name xterm in /usr/bin and it is done."
or by
2) installing xterm.

I did not find xterm in my /usr/bin, and system only gives me a choice of mate-terminal or debian terminal emulator. (neither fixed the issue)

What are the steps required to setup this sim link, or how do I install xterm?

User avatar
WharfRat
Level 21
Level 21
Posts: 12942
Joined: Thu Apr 07, 2011 8:15 pm

Re: Could not launch Application

Post by WharfRat » Wed Sep 25, 2013 3:46 pm

velky_pivo,

If you want a symlink to mate-terminal then in the terminal:

Code: Select all

sudo -i

Code: Select all

cd /usr/bin

Code: Select all

ln -s mate-terminal xterm
Then if you

Code: Select all

 ls -l xterm
you will see

Code: Select all

lrwxrwxrwx 1 root root 13 Sep 25 15:44 xterm -> mate-terminal*
Good luck :wink:
ImageImage

velky_pivo
Level 2
Level 2
Posts: 52
Joined: Fri Sep 30, 2011 10:02 pm

Re: Could not launch Application

Post by velky_pivo » Wed Sep 25, 2013 4:01 pm

thanks, worked perfectly
now my python interpreter starts ok, and other apps are also working fine

Is there a backwards process to undo/remove the symbolic link in case I no longer need/want it ?

User avatar
WharfRat
Level 21
Level 21
Posts: 12942
Joined: Thu Apr 07, 2011 8:15 pm

Re: Could not launch Application

Post by WharfRat » Wed Sep 25, 2013 4:20 pm

velky_pivo wrote:thanks, worked perfectly
now my python interpreter starts ok, and other apps are also working fine

Is there a backwards process to undo/remove the symbolic link in case I no longer need/want it ?
Yes, just delete the symlink:

Code: Select all

sudo rm /usr/bin/xterm
ImageImage

Post Reply

Return to “Newbie Questions”