Page 1 of 1

Could not launch Application

Posted: Wed Sep 25, 2013 2:24 pm
by velky_pivo
LM13-64bit-Mate

I installed Python recently but it will not start from the menu. It runs ok manually from mate-terminal.

Popup error says:

Could not launch 'Python (v2.7)'
Failed to execute child process "xterm" (No such file or directory)

I found that somebody fixed this by either
1) setting up "sim link to /usr/bin"
quote: "Just create a sim link with the name xterm in /usr/bin and it is done."
or by
2) installing xterm.

I did not find xterm in my /usr/bin, and system only gives me a choice of mate-terminal or debian terminal emulator. (neither fixed the issue)

What are the steps required to setup this sim link, or how do I install xterm?

Re: Could not launch Application

Posted: Wed Sep 25, 2013 3:46 pm
by WharfRat
velky_pivo,

If you want a symlink to mate-terminal then in the terminal:

Code: Select all

sudo -i

Code: Select all

cd /usr/bin

Code: Select all

ln -s mate-terminal xterm
Then if you

Code: Select all

 ls -l xterm
you will see

Code: Select all

lrwxrwxrwx 1 root root 13 Sep 25 15:44 xterm -> mate-terminal*
Good luck :wink:

Re: Could not launch Application

Posted: Wed Sep 25, 2013 4:01 pm
by velky_pivo
thanks, worked perfectly
now my python interpreter starts ok, and other apps are also working fine

Is there a backwards process to undo/remove the symbolic link in case I no longer need/want it ?

Re: Could not launch Application

Posted: Wed Sep 25, 2013 4:20 pm
by WharfRat
velky_pivo wrote:thanks, worked perfectly
now my python interpreter starts ok, and other apps are also working fine

Is there a backwards process to undo/remove the symbolic link in case I no longer need/want it ?
Yes, just delete the symlink:

Code: Select all

sudo rm /usr/bin/xterm