Any solution to the wireless BCM43142 issue?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
EarlyCuyler
Level 1
Level 1
Posts: 7
Joined: Sat Nov 23, 2013 5:30 pm

Any solution to the wireless BCM43142 issue?

Post by EarlyCuyler »

Hello all, installed a fresh copy of Mint 15 today only to stumble into what seems to be a common problem for us, the dreaded unsupported wireless BCM43142. I've got no wireless and don't see a clear set of instructions or guide on how to fix this issue. If someone can point me in the right direction it will be greatly appreciated. Thank you.
EarlyCuyler
Level 1
Level 1
Posts: 7
Joined: Sat Nov 23, 2013 5:30 pm

Re: Any solution to the wireless BCM43142 issue?

Post by EarlyCuyler »

OK, so I chatted with DuncanNZ on IRC and he was able to point me to System Settings -> Device Drivers and I clicked the option to turn on the driver for the card. Now I have wireless showing up under my network options but no wireless networks are available. I was asked by chattr to do a "ifconfig -a" and there was no wlan0 listed. Not sure where to go from here but again, thanks for any help.
User avatar
WharfRat
Level 21
Level 21
Posts: 13909
Joined: Thu Apr 07, 2011 8:15 pm

Re: Any solution to the wireless BCM43142 issue?

Post by WharfRat »

EarlyCuyler,

According to the kernel help on this card it needs either the b43-fwcutter or the firmware-b43legacy-installer package installed. It also says that both can be installed as the underlying glue layer will automatically load the correct version for your device.

I would start with installing b43-fwcutter, then reboot to see if you get a connection.

Good luck :wink:
ImageImage
EarlyCuyler
Level 1
Level 1
Posts: 7
Joined: Sat Nov 23, 2013 5:30 pm

Re: Any solution to the wireless BCM43142 issue?

Post by EarlyCuyler »

Thank you Mr. Grateful Dead fan, can you point me where you got that information so I can try to understand what it is I'm doing a bit better? Thank you! :D
User avatar
WharfRat
Level 21
Level 21
Posts: 13909
Joined: Thu Apr 07, 2011 8:15 pm

Re: Any solution to the wireless BCM43142 issue?

Post by WharfRat »

EarlyCuyler wrote:Thank you Mr. Grateful Dead fan, can you point me where you got that information so I can try to understand what it is I'm doing a bit better? Thank you! :D
Well, you would have to install the linux source and the required additional packages to compile menuconfig.

I'm sure there are other places to get info on this, but I usually check the help in the kernel configuration.

Good luck :wink:
Attachments
2013-11-23-20-25-52.png
2013-11-23-20-25-10.png
ImageImage
EarlyCuyler
Level 1
Level 1
Posts: 7
Joined: Sat Nov 23, 2013 5:30 pm

Re: Any solution to the wireless BCM43142 issue?

Post by EarlyCuyler »

Man this stuff is way over my head still. I'm still trying to figure out how exactly to install b43-fwcutter on Mint 15. Want to make sure I got it right before I mess something up. :shock:
User avatar
WharfRat
Level 21
Level 21
Posts: 13909
Joined: Thu Apr 07, 2011 8:15 pm

Re: Any solution to the wireless BCM43142 issue?

Post by WharfRat »

EarlyCuyler wrote:Man this stuff is way over my head still. I'm still trying to figure out how exactly to install b43-fwcutter on Mint 15. Want to make sure I got it right before I mess something up. :shock:
To install the driver open the terminal application and enter:

Code: Select all

sudo apt-get install b43-fwcutter
That's it, you're done :wink:
ImageImage
EarlyCuyler
Level 1
Level 1
Posts: 7
Joined: Sat Nov 23, 2013 5:30 pm

Re: Any solution to the wireless BCM43142 issue?

Post by EarlyCuyler »

Got that, but still no results after a reboot. I'm currently chatting with the guys on the IRC channel as well, so I'm sure we're gonna get this. We are moving on to the legacy package now I believe. I will update with results.
EarlyCuyler
Level 1
Level 1
Posts: 7
Joined: Sat Nov 23, 2013 5:30 pm

Re: Any solution to the wireless BCM43142 issue?

Post by EarlyCuyler »

No results from the legacy package, working still in IRC.
EarlyCuyler
Level 1
Level 1
Posts: 7
Joined: Sat Nov 23, 2013 5:30 pm

Re: Any solution to the wireless BCM43142 issue?

Post by EarlyCuyler »

OK, so today I decided to upgrade to Mint 16 Cinnamon 64-Bit, as suggested by those in the IRC channel. I have installed the driver under driver manager. I've ran update manager and made sure everything is up to date. I now have wireless!!! Yay!!! Thanks for your help WharfRat! :mrgreen:
User avatar
WharfRat
Level 21
Level 21
Posts: 13909
Joined: Thu Apr 07, 2011 8:15 pm

Re: Any solution to the wireless BCM43142 issue?

Post by WharfRat »

EarlyCuyler,

It's interesting that it worked with Mint 16 and not Mint 15.

Do you happen to remember the driver package you installed :?: Just curious if it was b43-fwcutter or something else.

In any event enjoy :wink:
ImageImage
rudar
Level 2
Level 2
Posts: 60
Joined: Thu Sep 27, 2012 7:34 am

Re: Any solution to the wireless BCM43142 issue?

Post by rudar »

Hi there! Sorry to intrude, even after such a long period of time, but I believe we have the same trouble, although not under the same circumstances. My problem with this wireless card (BCM43142) came on Lenovo G500, running Debian Testing Xfce. Yes, I know it's Debian, and not Mint (not even LMDE), but I believe we both depend on the same driver.
There were some attempts to fix it, as you can see on this link: http://forums.debian.net/viewtopic.php?f=30&t=109498
It worked for me too, but only with kernel 3.11-2. Unfortunately, I lost the connection after the upgrade. I managed somehow to find a solution with kernel 3.12, but now I reached the dead end with kernel 3.13. People apparently keep reading these posts on Debian forum, according to the number of visits, but nobody replies anything. So, I have decided to try my luck here, as I simply don't believe there are no users who share the same problem. Let us try to find a solution: if I manage by myself, I promise I will also publish it here. Anyone else, please?
LMDE Mate
rudar
Level 2
Level 2
Posts: 60
Joined: Thu Sep 27, 2012 7:34 am

Re: Any solution to the wireless BCM43142 issue?

Post by rudar »

Just for the record: I managed to find a solution. It took me several days, I feel exhausted, but it's working again. There were so many lines I tried before I got the right solution in the Terminal, and, most regrettably, I cannot explain precisely how I reached the end. Perhaps in another post.
LMDE Mate
Post Reply

Return to “Newbie Questions”