Log in window Font Size solved

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
dnmint
Level 4
Level 4
Posts: 393
Joined: Sat Jun 21, 2008 5:00 pm
Location: Hyderabad, India ( mostly travelling)

Log in window Font Size solved

Post by dnmint » Mon Jul 21, 2008 9:06 am

In my Linux Mint log in - Password window, the Font size apparently is set to 'toolarge' - I do not know How it happened. I cannot see what I am typing as only a portion of one font is visible in the window.
However, what I type correctly is accepted.
Can I correct this Login Font Size?
ImageDNMint

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Log in window Font Size

Post by Husse » Wed Jul 23, 2008 7:01 am

You have to set the resolution for gdm which is done in menu.lst
This is a line from some menu.lst that gives 1024x768 before you log in
kernel /boot/vmlinuz-2.6.22-14-generic root=/dev/sda7 ro vga=791 quiet splash
It's the vga=791part that does the trick so you have to add it to your /boot/grub/menu.lst
And the rest is of course just an example
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
dnmint
Level 4
Level 4
Posts: 393
Joined: Sat Jun 21, 2008 5:00 pm
Location: Hyderabad, India ( mostly travelling)

Re: Log in window Font Size

Post by dnmint » Thu Jul 24, 2008 12:41 am

Thanks a lot.
I went into boot/grub/menu.lst. I got the folowing:
What should Ido now ( Dummy type advie pls- I am still learning)


# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-legacy-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default 0

gfxmenu=/etc/grub/message.elyssa

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 10

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/sda6 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,5)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
## lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Linux Mint, kernel 2.6.24-16-generic
root (hd0,5)
kernel /boot/vmlinuz-2.6.24-16-generic root=/dev/sda6 ro quiet splash
initrd /boot/initrd.img-2.6.24-16-generic

title Linux Mint, kernel 2.6.24-16-generic (recovery mode)
root (hd0,5)
kernel /boot/vmlinuz-2.6.24-16-generic root=/dev/sda6 ro single
initrd /boot/initrd.img-2.6.24-16-generic

title Linux Mint, kernel memtest86+
root (hd0,5)
kernel /boot/memtest86+.bin

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Professional
root (hd0,0)
savedefault
makeactive
chainloader +1
ImageDNMint

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Log in window Font Size

Post by Husse » Thu Jul 24, 2008 6:14 am

In this line
kernel /boot/vmlinuz-2.6.24-16-generic root=/dev/sda6 ro quiet splash
you shoul add vga=791 like so
kernel /boot/vmlinuz-2.6.24-16-generic root=/dev/sda6 ro vga=791 quiet splash
you may have to do this for Recovery mode as well
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
dnmint
Level 4
Level 4
Posts: 393
Joined: Sat Jun 21, 2008 5:00 pm
Location: Hyderabad, India ( mostly travelling)

Re: Log in window Font Size

Post by dnmint » Thu Jul 24, 2008 8:49 am

Thanks, I figured so & tried.by cut & paste.
It shows error & says "I have no right to change & save those lines."
It appears I have to login as root to do that.
How dop I deal with thru CLI in Terminal
Thanks for ur patience with me :)
ImageDNMint

lakehousetech
Level 4
Level 4
Posts: 453
Joined: Wed Nov 07, 2007 3:34 pm
Location: Toronto, ON

Re: Log in window Font Size

Post by lakehousetech » Thu Jul 24, 2008 9:35 am

Open terminal and type:

sudo gedit /boot/grub/menu.lst

Enter your password and go to it!

User avatar
dnmint
Level 4
Level 4
Posts: 393
Joined: Sat Jun 21, 2008 5:00 pm
Location: Hyderabad, India ( mostly travelling)

Re: Log in window Font Size

Post by dnmint » Thu Jul 24, 2008 10:14 am

Did that . Got through. Pasted the new line with vga=791 bit ( As I cut pasted - possibly no error).
Restarted & still the font size is as before oversize in login & password window.
:cry:
ImageDNMint

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Log in window Font Size

Post by Husse » Thu Jul 31, 2008 12:18 pm

OK - this is in the border region between pure text and the desktop
I think I have found it
Control Center > Login Window
Select the 'Security' tab
Click the 'Configure X-Server' button
Append '-dpi 96' (without quotes) to the text in the 'Command' field (It's on the right hand side)
Of course other dpi numbers can be used
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
dnmint
Level 4
Level 4
Posts: 393
Joined: Sat Jun 21, 2008 5:00 pm
Location: Hyderabad, India ( mostly travelling)

Re: Log in window Font Size

Post by dnmint » Tue Aug 12, 2008 6:30 am

Thanks Husse
As usual - on the mark
It is ok now in liging window
Thanks again
ImageDNMint

strict
Level 1
Level 1
Posts: 7
Joined: Thu Feb 26, 2009 10:12 am

Re: Log in window Font Size

Post by strict » Wed Mar 04, 2009 12:09 pm

dnmint wrote:Thanks Husse
As usual - on the mark
It is ok now in liging window
Thanks again

Yes thank you, I had a simialar problem where my fonts were too small and adding -dpi 120 fixed me right up. Linux Mint is by far the sweetest distro I've ever come across and the support is top notch!


Cheers!

tzotzolyno
Level 1
Level 1
Posts: 2
Joined: Sat Apr 11, 2009 7:31 pm

Re: Log in window Font Size solved

Post by tzotzolyno » Sat Apr 11, 2009 7:47 pm

dnmint wrote:In my Linux Mint log in - Password window, the Font size apparently is set to 'toolarge' - I do not know How it happened. I cannot see what I am typing as only a portion of one font is visible in the window.
However, what I type correctly is accepted.
Can I correct this Login Font Size?
I have the same problem with a notebook with Elyssa and Via Chrome 9 HC chipset. The splash and desktop resolution are OK (1280x800, with via drivers) but the logon screen is to big. I can see only the left upper corner (no text, no boxes).
Appending „-dpi 96” (without quotes) to the text in the 'Command' field near the text „/usr/bin/X -br -audit 0” doesn't help.
What can I do?

Thanks in advance and please, explain me step-by-step if it is a complicate procedure (I'm a beginner). :)

User avatar
rbanavara
Level 4
Level 4
Posts: 230
Joined: Mon Jun 02, 2008 9:07 am

Re: Log in window Font Size solved

Post by rbanavara » Sun Apr 26, 2009 3:28 am

not sure if this helps, but you can try using some other size like, 94 or 92 (100 / 120 for larger font). I just am guessing here.
Don't fix it if it ain't broken, don't break it if you can't fix it -Husse

tzotzolyno
Level 1
Level 1
Posts: 2
Joined: Sat Apr 11, 2009 7:31 pm

Re: Log in window Font Size solved

Post by tzotzolyno » Sun Apr 26, 2009 3:27 pm

rbanavara wrote:not sure if this helps, but you can try using some other size like, 94 or 92 (100 / 120 for larger font). I just am guessing here.
No, it doesn't help.
My solution (for my Elysa) is here: http://ubuntuforums.org/showthread.php?t=1124185
It was a video driver problem.

Post Reply

Return to “Newbie Questions”