apt-get install libgl1-mesa-dev error

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
mikesart
Level 1
Level 1
Posts: 2
Joined: Fri Nov 29, 2013 8:31 pm

apt-get install libgl1-mesa-dev error

Post by mikesart » Fri Nov 29, 2013 8:41 pm

When I try to apt-get the libgl1-mesa-dev package, I get an error saying it depends on v9.2.0, but I have v9.2.1 installed. This is with Linux Mint 16.

Do others have this problem with Mint 16? Is there a "recommended" way of working around this?

Thanks!
-Mike

mikesart@mikesart-mint ~ $ sudo apt-get install libgl1-mesa-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgl1-mesa-dev : Depends: libgl1-mesa-glx (= 9.2.0~git20131002+9.2.2eb55601-0ubuntu0sarvatt) but 9.2.1-1ubuntu3 is to be installed
E: Unable to correct problems, you have held broken packages.

mikesart@mikesart-mint ~ $ lsb_release -a
No LSB modules are available.
Distributor ID: LinuxMint
Description: Linux Mint 16 Petra
Release: 16
Codename: petra

mikesart@mikesart-mint ~ $ uname -a
Linux mikesart-mint 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

mikesart@mikesart-mint ~ $ aptitude show libgl1-mesa-dev
Package: libgl1-mesa-dev
State: not installed
Version: 9.2.0~git20131002+9.2.2eb55601-0ubuntu0sarvatt
Priority: optional
Section: libdevel
Maintainer: Ubuntu X-SWAT <ubuntu-x@lists.ubuntu.com>
Architecture: amd64
Uncompressed Size: 92.2 k
Depends: mesa-common-dev (= 9.2.0~git20131002+9.2.2eb55601-0ubuntu0sarvatt), libgl1-mesa-glx (=
9.2.0~git20131002+9.2.2eb55601-0ubuntu0sarvatt), libdrm-dev (>= 2.4.45), libX11-dev, libx11-xcb-dev, libxcb-dri2-0-dev,
libxcb-glx0-dev, libxdamage-dev, libxext-dev, libxfixes-dev, libxxf86vm-dev, x11proto-dri2-dev (>= 2.6), x11proto-gl-dev
(>= 1.4.14)
Conflicts: libgl-dev, libgl-dev, libgl1-mesa-dri-dev, libgl1-mesa-dri-dev, libgl1-mesa-dev
Replaces: libgl-dev, libgl-dev, libgl1-mesa-dri-dev, libgl1-mesa-dri-dev
Provides: libgl-dev, libgl1-mesa-dri-dev
Description: free implementation of the OpenGL API -- GLX development files
This version of Mesa provides GLX and DRI capabilities: it is capable of both direct and indirect rendering. For direct
rendering, it can use DRI modules from the libgl1-mesa-dri package to accelerate drawing.

This package includes headers and static libraries for compiling programs with Mesa.

For a complete description of Mesa, please look at the libgl1-mesa-glx package.

mikesart@mikesart-mint ~ $ aptitude show libgl1-mesa-glx
Package: libgl1-mesa-glx
State: installed
Automatically installed: no
Multi-Arch: same
Version: 9.2.1-1ubuntu3
Priority: optional
Section: libs
Maintainer: Ubuntu X-SWAT <ubuntu-x@lists.ubuntu.com>
Architecture: amd64
Uncompressed Size: 486 k
Depends: libc6 (>= 2.14), libdrm2 (>= 2.3.1), libglapi-mesa (= 9.2.1-1ubuntu3),
libx11-6 (>= 2:1.4.99.1), libx11-xcb1, libxcb-dri2-0 (>= 1.8),
libxcb-glx0 (>= 1.8), libxcb1, libxdamage1 (>= 1:1.1), libxext6,
libxfixes3, libxxf86vm1
PreDepends: multiarch-support
Recommends: libgl1-mesa-dri (>= 7.2)
Conflicts: libgl1, libgl1, libgl1-mesa-dri (< 6.4.0), libgl1-mesa-dri (< 6.4.0)
Breaks: fglrx-glx (< 1:11-6-1), fglrx-glx (< 1:11-6-1),
libgl1-nvidia-alternatives (<= 275.09.07-1), libgl1-nvidia-alternatives
(<= 275.09.07-1), libgl1-mesa-glx (!= 9.2.1-1ubuntu3)
Replaces: libgl1, libgl1, libgl1-mesa-dri (< 6.4.0), libgl1-mesa-dri (< 6.4.0),
libgl1-mesa-glx (< 9.2.1-1ubuntu3)
Provides: libgl1
Description: free implementation of the OpenGL API -- GLX runtime
Mesa is a 3-D graphics library with an API which is very similar to that of
OpenGL. To the extent that Mesa utilizes the OpenGL command syntax or state
machine, it is being used with authorization from Silicon Graphics, Inc.
However, the author makes no claim that Mesa is in any way a compatible
replacement for OpenGL or associated with Silicon Graphics, Inc.

This version of Mesa provides GLX and DRI capabilities: it is capable of both
direct and indirect rendering. For direct rendering, it can use DRI modules
from the libgl1-mesa-dri package to accelerate drawing.

This package does not include the modules themselves: these can be found in the
libgl1-mesa-dri package.
Homepage: http://mesa3d.sourceforge.net/

Monsta
Level 10
Level 10
Posts: 3024
Joined: Fri Aug 19, 2011 3:46 am

Re: apt-get install libgl1-mesa-dev error

Post by Monsta » Sat Nov 30, 2013 4:13 am

I can't reproduce it. Please post the output of

Code: Select all

apt-cache policy libgl1-mesa-dev

mikesart
Level 1
Level 1
Posts: 2
Joined: Fri Nov 29, 2013 8:31 pm

Re: apt-get install libgl1-mesa-dev error

Post by mikesart » Sun Dec 01, 2013 2:19 pm

That was it - it was trying to use the one from xorg-edgers. With Ubuntu 12.04 and 13.10, I would use this file to drop the priority down:

# /etc/apt/preferences.d/xorg-edgers-pin-400
Package: *
Pin: release o=LP-PPA-xorg-edgers
Pin-Priority: 400

But that wasn't working here. I tweaked it to get it to really drop the priority down to 400 and now it's good.

Thanks for the reply Monsta.

Post Reply

Return to “Newbie Questions”