Administrative Rights Freeze up

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
Joe Collins
Level 1
Level 1
Posts: 25
Joined: Wed Jun 19, 2013 7:45 pm

Administrative Rights Freeze up

Post by Joe Collins » Sun Dec 22, 2013 8:34 pm

Any time I do something that requires a password prompt (Software manager, Update Manager, installing from .deb, etc) my computer completely freezes up for a long time before finally giving me the prompt, after which everything resumes normally. It doesn't freeze if I use sudo. I'm using Mint 16 Cinnamon 64 bit, with a computer that shouldn't freeze up, ever. Here's the output of inxi -Fxz:

Code: Select all

inxi -Fxz
System:    Host: Apollo Kernel: 3.11.0-12-generic x86_64 (64 bit, gcc: 4.8.1) Desktop: Gnome Distro: Linux Mint 16 Petra
Machine:   Mobo: MSI model: 760GM-P34(FX) (MS-7641) version: 4.0 Bios: American Megatrends version: V17.13 date: 12/14/2012
CPU:       Octa core AMD FX-8320 Eight-Core (-MCP-) cache: 16384 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 56003.8 
           Clock Speeds: 1: 1400.00 MHz 2: 1400.00 MHz 3: 1400.00 MHz 4: 3500.00 MHz 5: 1400.00 MHz 6: 1400.00 MHz 7: 1400.00 MHz 8: 1400.00 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Cape Verde XT [Radeon HD 7770 GHz Edition] bus-ID: 01:00.0 
           X.Org: 1.14.3 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz 
           GLX Renderer: Gallium 0.4 on AMD CAPE VERDE GLX Version: 2.1 Mesa 9.2.1 Direct Rendering: Yes
Audio:     Card-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2
           Card-2: Advanced Micro Devices [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture ver: k3.11.0-12-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
           driver: r8169 ver: 2.3LK-NAPI port: e800 bus-ID: 02:00.0
           IF: eth0 state: down mac: <filter>
           Card-2: Ralink RT5370 Wireless Adapter driver: rt2800usb ver: 2.3.0 usb-ID: 148f:5370
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 2500.5GB (15.7% used) 1: id: /dev/sda model: WDC_WD10EZEX size: 1000.2GB 
           2: USB id: /dev/sdb model: External_USB_3.0 size: 1500.3GB 
Partition: ID: / size: 28G used: 5.1G (20%) fs: ext4 ID: /home size: 459G used: 1.6G (1%) fs: ext4 
           ID: swap-1 size: 4.00GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 35.1C mobo: N/A gpu: 60.0 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 247 Uptime: 51 min Memory: 1033.8/7983.4MB Runlevel: 2 Gcc sys: 4.8.1 Client: Shell inxi: 1.8.4 
So, not too sure what would cause this, but I would really like to fix it.

perlenfischer
Level 1
Level 1
Posts: 5
Joined: Sun Jan 05, 2014 4:47 pm

Re: Administrative Rights Freeze up

Post by perlenfischer » Mon Jan 06, 2014 5:09 pm

I have the same problem occuring on my system. Furthermore I have a problem occuring in LibreOffice Calc (http://forums.linuxmint.com/viewtopic.p ... 8&t=155230) and I think that both problems are interconnected.
I suspect a problem with the graphic card or its driver (I also use the Radeon HD 7700), though switching its driver to fgrlx did not help.
Did you succeed to eliminate the problem?

jakis
Level 1
Level 1
Posts: 1
Joined: Sun Jan 19, 2014 8:58 pm

Re: Administrative Rights Freeze up

Post by jakis » Sun Jan 19, 2014 9:01 pm

I'm having the same problem and I have no idea how to fix it, but it's killing me. This is the only thread I've been able to find about the issue.
Did you find a solution? If not, can I post any logs or anything to help? (I'm relatively new to linux)

pagonisc
Level 1
Level 1
Posts: 1
Joined: Fri Feb 14, 2014 4:17 pm

Re: Administrative Rights Freeze up

Post by pagonisc » Sat Feb 15, 2014 5:03 am

So glad I found this thread, been having this same problem since I installed Mint 16 Petra (MATE 64)! I get both the slow down in attempting to access administrative rights while using the GUI as well as the LibreOffice Calc issue. From what I can gather the problem stems from the xserver-xorg-video-ati driver (v.1:7.2.0) as others have said though when I upgraded my kernel to to 3.12.11-031211 from stock, the problem actually stopped when using either the fglrx and the fglrx-update drivers in the driver manager (I would use those drivers, but they present even more problems for my current setup). I am at a loss on how to fix this problem, but hopefully my data can be used to help someone who can.

If I may ask, is there any way to backport 1:7.1.0 (known working) or attempt to use 1:7.3.0-1 from the 'trusty' repos to see if it alleviates the problem?

Code: Select all

pagonisc@MAGI ~ $ inxi -Fxz
System:    Host: MAGI Kernel: 3.12.11-031211-generic x86_64 (64 bit, gcc: 4.6.3) Desktop: N/A Distro: Linux Mint 16 Petra
Machine:   System: ASUS product: All Series
           Mobo: ASUSTeK model: Z87-PRO version: Rev 1.xx Bios: American Megatrends version: 1707 date: 12/13/2013
CPU:       Quad core Intel Core i5-4670K CPU (-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27184 
           Clock Speeds: 1: 3521.390 MHz 2: 3566.679 MHz 3: 3586.601 MHz 4: 3418.195 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Pitcairn PRO [Radeon HD 7850] bus-ID: 01:00.0 
           X.Org: 1.14.3 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1600x900@60.0hz, 1600x900@60.0hz 
           GLX Renderer: Gallium 0.4 on AMD PITCAIRN GLX Version: 2.1 Mesa 9.2.1 Direct Rendering: Yes
Audio:     Card-1: Intel 8 Series/C220 Series Chipset High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2: Advanced Micro Devices [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture ver: k3.12.11-031211-generic
Network:   Card-1: Qualcomm Atheros AR9462 Wireless Network Adapter driver: ath9k bus-ID: 03:00.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Intel Ethernet Connection I217-V driver: e1000e ver: 2.3.2-k port: f040 bus-ID: 00:19.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 3128.6GB (30.6% used) 1: id: /dev/sda model: TOSHIBA_DT01ACA2 size: 2000.4GB 
           2: id: /dev/sdb model: TOSHIBA_THNSNH12 size: 128.0GB 3: id: /dev/sdc model: Hitachi_HDS72101 size: 1000.2GB 
Partition: ID: / size: 117G used: 5.0G (5%) fs: ext4 ID: /home size: 1.8T used: 889G (52%) fs: ext4 
           ID: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 45.0C mobo: 29.8C gpu: 34.0 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 250 Uptime: 15 min Memory: 3011.8/15987.3MB Runlevel: 2 Gcc sys: 4.8.1 Client: Shell inxi: 1.8.4 

Crystallas
Level 1
Level 1
Posts: 4
Joined: Thu Feb 20, 2014 8:29 pm

Re: Administrative Rights Freeze up

Post by Crystallas » Thu Feb 20, 2014 9:00 pm

Me 5.
Fresh Mint 16 Petra (64). I didn't have this issue on Mint 11,12,13 on the same system.

simiuscerebrum
Level 1
Level 1
Posts: 4
Joined: Wed Feb 19, 2014 10:05 pm

Re: Administrative Rights Freeze up

Post by simiuscerebrum » Fri Feb 21, 2014 8:53 am

Make me number 6. Seems like it must be the AMD video card for some reason. Mine is a R7 250X which is just their new name for the HD7770, I think.

http://forums.linuxmint.com/viewtopic.p ... 7&p=825764

In a nutshell, all the "Manager" (Software, Update, Driver) programs take forever to load and basically lock up the system until they do.

Ian Austin
Level 1
Level 1
Posts: 1
Joined: Sun Feb 23, 2014 6:38 pm

Re: Administrative Rights Freeze up

Post by Ian Austin » Sun Feb 23, 2014 7:05 pm

Make me number 7. I am using a Radeon HD7700 with a dual monitor setup. However, my system hangs for significantly longer, usually a couple of minutes. Once the password is entered, it hangs for a couple of more minutes. Provided I do not need root privileges however, the rest of my install runs flawlessly. Any news on a fix?

Crystallas
Level 1
Level 1
Posts: 4
Joined: Thu Feb 20, 2014 8:29 pm

Re: Administrative Rights Freeze up

Post by Crystallas » Sun Feb 23, 2014 10:13 pm

After switching to the AMD proprietary video card drivers, this issue went away for me. Not sure if that will help others with the same problem, but I thought I would mention it.

echoz28
Level 1
Level 1
Posts: 1
Joined: Sat Jan 19, 2013 8:18 pm

Re: Administrative Rights Freeze up

Post by echoz28 » Thu Mar 06, 2014 8:28 pm

Same problem, dual monitors, HD 7850. I'm running Mint 16 MATE. Will try proprietary drivers after I've updated my system.
EDIT: I installed the proprietary drivers from the driver management GUI. The first thing I noticed was terrible performance on the login screen, but the administrative rights window opens instantly now and performance overall seems okay. However there is one major problem: My screen settings revert to mirroring every time I restart my computer. I will try the drivers from AMD's website hoping those are better.

Futec
Level 1
Level 1
Posts: 4
Joined: Mon Mar 24, 2014 4:28 am

Re: Administrative Rights Freeze up

Post by Futec » Mon Mar 24, 2014 4:54 am

I have the same problem. When I have to enter the password (to open Software, update, install managers,...) the sreen freeze for at least a minute.
the mouse pointer can move ever. I noticed what during this time, the occupation of one of the four CPU core goes to 100 %, the over not. I have this problem only with xserver-xorg-ati driver, not with fglrx propriary driver. I switched back to the fglrx driver but the grafics performance is poor.
I tryed on Mint 16 Cinnamon an Mate : same problem.

inxi -Fxz output :

Code: Select all

inxi -Fxz
System:    Host: GA-880GMA Kernel: 3.11.0-12-generic x86_64 (64 bit, gcc: 4.8.1) Desktop: N/A Distro: Linux Mint 16 Petra
Machine:   Mobo: Gigabyte model: GA-880GMA-UD2H version: x.x Bios: Award version: F4 date: 07/28/2010
CPU:       Quad core AMD Athlon II X4 620 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 20897.3 
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz 3: 800.00 MHz 4: 800.00 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Cape Verde XT [Radeon HD 7770 GHz Edition] bus-ID: 01:00.0 
           X.Org: 1.14.3 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz 
           GLX Renderer: Gallium 0.4 on AMD CAPE VERDE GLX Version: 2.1 Mesa 9.2.1 Direct Rendering: Yes
Audio:     Card-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2
           Card-2: Advanced Micro Devices [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] driver: snd_hda_intel bus-ID: 01:00.1
           Card-3: Logitech driver: USB Audio usb-ID: 046d:0826
           Sound: Advanced Linux Sound Architecture ver: k3.11.0-12-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
           driver: r8169 ver: 2.3LK-NAPI port: ee00 bus-ID: 03:00.0
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Microsoft Xbox 360 Wireless Adapter usb-ID: 045e:0719
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 163.9GB (2.9% used) 1: id: /dev/sda model: Maxtor_6Y160M0 size: 163.9GB 
Partition: ID: / size: 72G used: 4.5G (7%) fs: ext4 ID: swap-1 size: 4.09GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 182 Uptime: 14 min Memory: 898.0/3950.5MB Runlevel: 2 Gcc sys: 4.8.1 Client: Shell inxi: 1.8.4
I hope someone will solve this problem.

Post Reply

Return to “Newbie Questions”