Page 1 of 1

[SOLVED] Bad USB/SD

Posted: Mon Jan 27, 2014 3:43 am
by mzs112000
Ihave done something and now all of my usb cards, sd cards are the wrong sizes, usbs are 837MB(physicaly 8gb and 2gb), and sds, ar 1.4mb(physicaly 8gb and 16gb), nothing i do will return them to normal sizes.

Testdisk, did not work.
Cfdisk did not work
Fdisk did not work
mkfs.XXXX did not work
Gparted did not work
dd did not work

so i need help

EDIT#:
I have got an SD to format as Fat, buts its 8.4M, here is dmesg | tail output:

Code: Select all

[473770.120799] sd 51:0:0:0: [sdb] Assuming drive cache: write through
[473770.120802] sd 51:0:0:0: [sdb] Attached SCSI removable disk
[473770.426671] FAT-fs (loop0): bogus number of reserved sectors
[473770.426678] FAT-fs (loop0): Can't find a valid FAT filesystem
[473770.622867] FAT-fs (loop0): bogus number of reserved sectors
[473770.622873] FAT-fs (loop0): Can't find a valid FAT filesystem
[473771.623879] FAT-fs (loop0): bogus number of reserved sectors
[473771.623885] FAT-fs (loop0): Can't find a valid FAT filesystem
[473772.018721] FAT-fs (loop0): bogus number of reserved sectors
[473772.018727] FAT-fs (loop0): Can't find a valid FAT filesystem
EDIT#:
here is lsblk:

Code: Select all

sdb      8:16   1   7.4G  0 disk 
└─sdb1   8:17   1     8M  0 part 
OK i solved it, see last post for details.

Re: I have done something bad to, some uSD cards, and som US

Posted: Mon Jan 27, 2014 7:19 am
by Reorx
Plug your USB devices into a different computer. What happens? Do the devices work?

Re: I have done something bad to, some uSD cards, and som US

Posted: Mon Jan 27, 2014 9:40 pm
by mzs112000
Reorx wrote:Plug your USB devices into a different computer. What happens? Do the devices work?
It works patially in archlinux

Re: I have done something bad to, some uSD cards, and som US

Posted: Mon Jan 27, 2014 9:56 pm
by daveinuk
Just a thought but it's not hidden files on the USB's taking up the missing space is it? Maybe plug in/ mount and press ctrl+h to check.....

Re: I have done something bad to, some uSD cards, and som US

Posted: Mon Jan 27, 2014 10:20 pm
by nburgin

Code: Select all

sdb      8:16   1   7.4G  0 disk
└─sdb1   8:17   1     8M  0 part
in response to that: there may be something else going on here, but it looks like you somehow made a primary partition in the flash drive that is way smaller than the drive itself.

you listed things that did not work, but you did not say what you did with them, so, I can't tell whether maybe they could have worked and you just did something wrong, or if something else is the matter that they can't fix. Try Gparted again, delete the sdb1 partition, and try to make a new one that fills the drive this time.

If that's not possible I don't know what to say. Maybe the drive is bricked. That sometimes happens with flash drives, especially cheap ones. One time I had a 4GB flash drive that came free with my padded laptop case, it worked for about a month and then broke. My university handed out free 1GB flash drives to freshmen when I first went there, but the one they gave me never worked at all.

when you say it works partially in arch linux, what did you mean by that? that's not very specific.

@daveinuk

due to the partition table listing he gave, i doubt hidden files are the problem.

Re: I have done something bad to, some uSD cards, and som US

Posted: Mon Jan 27, 2014 10:53 pm
by Orbmiser
in response to that: there may be something else going on here, but it looks like you somehow made a primary partition in the flash drive that is way smaller than the drive itself.
Sounds like when I prep SD cards for rooting devices. Like when I put jellybean OS on SD card for my tablet.
It uses non-standard fat or ntfs layouts and makes Filesystem partitions requires a special SD formating utility to get card back to normal.

SDFormatter4 https://www.google.com/search?as_qdr=y&q=SDformater

As once the cards have been modified with special partitions then regular formatting will not take.
.

Re: I have done something bad to, some uSD cards, and som US

Posted: Tue Jan 28, 2014 3:42 am
by mzs112000
nburgin wrote:

Code: Select all

sdb      8:16   1   7.4G  0 disk
└─sdb1   8:17   1     8M  0 part
in response to that: there may be something else going on here, but it looks like you somehow made a primary partition in the flash drive that is way smaller than the drive itself.

you listed things that did not work, but you did not say what you did with them, so, I can't tell whether maybe they could have worked and you just did something wrong, or if something else is the matter that they can't fix. Try Gparted again, delete the sdb1 partition, and try to make a new one that fills the drive this time.

If that's not possible I don't know what to say. Maybe the drive is bricked. That sometimes happens with flash drives, especially cheap ones. One time I had a 4GB flash drive that came free with my padded laptop case, it worked for about a month and then broke. My university handed out free 1GB flash drives to freshmen when I first went there, but the one they gave me never worked at all.

when you say it works partially in arch linux, what did you mean by that? that's not very specific.

@daveinuk

due to the partition table listing he gave, i doubt hidden files are the problem.
Ok a used arch an now they are back to the proper sizes, however they fail to mount in LM, so i will reinstall and see if that helps.
If i fix them i will post back, and thanks guys!

Oh and here is the new partition map:

Code: Select all

sdb      8:16   1   1.9G  0 disk 
└─sdb1   8:17   1   1.9G  0 part 

Re: I have done something bad to, some uSD cards, and som US

Posted: Tue Jan 28, 2014 5:28 pm
by nburgin
Hmm... well I guess now the only two possibilities that I can think of is that the new partition you created doesn't have a valid filesystem on it, or there really is something wrong with the mint install that's not letting it recognize the flash drives. I would check the first one first though. It did mount back on Arch, after you fixed the partition table, right?

Re: I have done something bad to, some uSD cards, and som US

Posted: Fri Feb 07, 2014 3:10 pm
by mzs112000
sorry it took a long time to reply.
I have gotten them working, but i used Archlinux.

Steps:
1. Insert USB/SD
2. lsblk
3. dd if=/dev/zero of=/dev/sdX # X = disk letter EG, sda/sdb/sdc etc....
4. downloaded an iso, LM, Ubuntu, arch or anything else
5. dd if=anything.iso of=/dev/sdb bs=256k
6. mkfs.ext4 /dev/sdXX
7. it should now work!