[SOLVED] Remove or Disable EFI in Mint 16

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
thomas.raines
Level 1
Level 1
Posts: 43
Joined: Mon Feb 11, 2013 12:03 am

[SOLVED] Remove or Disable EFI in Mint 16

Post by thomas.raines »

I recently installed Mint 16 on my Acer Aspire 5560 laptop. Before, I was running Mint 15 with no problems, and did an upgrade to Mint 16. I was having some issues, so I decided to do a fresh install. Now, when I try to boot my system, I get a blank screen and the hard drive stops spinning. I hold the power button to shut it down, then press it again to boot. The grub menu appears, and I select Mint 16, and it boots fine. The only difference, is now that I have done the fresh install, I have an EFI partition.
A little background, my computer natively came with Windows 7, but when Windows 8 was released, Acer made a "hasty" UEFI BIOS to make the laptop compatable. I say hasty because there is NO way to boot into teh UEFI or control/change any settings of any type related to EFI. It is the same BIOS as before the update. Now I have no way of turning off/on the secure boot or anything else.
I'd really like to use Mint 16. But I think, in order to make it work, I need to remove the efi partition and make my main partition the boot partition. But I have no idea of how to accomplish this.

Oh, I also tried enabling commenting out GRUB_HIDDEN_TIMEOUT=0 in grub to force grub to load on every boot, but that didn't change anything.

Any and all help is appreciated. If more info is needed, let me know and I will get it... Thanks in advance...
Last edited by thomas.raines on Sun Feb 16, 2014 3:10 am, edited 1 time in total.
User avatar
austin.texas
Level 20
Level 20
Posts: 12046
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Remove or Disable EFI in Mint 16

Post by austin.texas »

There may be a newer BIOS update available. You could check on that.

Are you wanting to dual-boot with Windows, or just use Mint?
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018
thomas.raines
Level 1
Level 1
Posts: 43
Joined: Mon Feb 11, 2013 12:03 am

Re: Remove or Disable EFI in Mint 16

Post by thomas.raines »

austin.texas wrote:There may be a newer BIOS update available. You could check on that.

Are you wanting to dual-boot with Windows, or just use Mint?
I'm on that latest BIOS update. And no I don't wnat to dual boot with Windows.
User avatar
austin.texas
Level 20
Level 20
Posts: 12046
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Remove or Disable EFI in Mint 16

Post by austin.texas »

I think, in order to make it work, I need to remove the efi partition and make my main partition the boot partition.
Please post the result of the command
sudo fdisk -l
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018
thomas.raines
Level 1
Level 1
Posts: 43
Joined: Mon Feb 11, 2013 12:03 am

Re: Remove or Disable EFI in Mint 16

Post by thomas.raines »

@ austin.texas (greatest city in the worl btw...lol)

Code: Select all

 sudo fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1   976773167   488386583+  ee  GPT

Disk /dev/sdb: 500.1 GB, 500107861504 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773167 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00051997

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048   965292031   482644992   83  Linux
/dev/sdb2       965294078   976771071     5738497    5  Extended
/dev/sdb5       965294080   976771071     5738496   82  Linux swap / Solaris
thomas.raines
Level 1
Level 1
Posts: 43
Joined: Mon Feb 11, 2013 12:03 am

Re: Remove or Disable EFI in Mint 16

Post by thomas.raines »

Because of the warning I got with fdsik, I ran parted as well:

Code: Select all

sudo parted -l
Model: ATA ST9500325AS (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End    Size    File system     Name  Flags
 1      1049kB  512MB  511MB   fat32                 boot
 2      512MB   494GB  494GB   ext4
 3      494GB   500GB  5878MB  linux-swap(v1)


Model: Seagate FreeAgent Go (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size    Type      File system     Flags
 1      1049kB  494GB  494GB   primary   ext4            boot
 2      494GB   500GB  5876MB  extended
 5      494GB   500GB  5876MB  logical   linux-swap(v1)
User avatar
austin.texas
Level 20
Level 20
Posts: 12046
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Remove or Disable EFI in Mint 16

Post by austin.texas »

First, for a GPT drive, the command would be gdisk instead of fdisk. Sorry, I didn't know it was GPT.
It appears that Mint 16 is installed in UEFI mode, so deleting the EFI partition would definitely be the wrong move.
I don't know much about how GRUB works in a UEFI mode. I don't even know if "sudo update-grub" works. I will try to research that.
There are other bootloaders available besides GRUB, also.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018
srs5694
Level 6
Level 6
Posts: 1389
Joined: Mon Feb 27, 2012 1:42 pm

Re: Remove or Disable EFI in Mint 16

Post by srs5694 »

thomas.raines wrote:I recently installed Mint 16 on my Acer Aspire 5560 laptop. Before, I was running Mint 15 with no problems, and did an upgrade to Mint 16. I was having some issues, so I decided to do a fresh install. Now, when I try to boot my system, I get a blank screen and the hard drive stops spinning. I hold the power button to shut it down, then press it again to boot. The grub menu appears, and I select Mint 16, and it boots fine.
Paraphrasing, to be sure I understand: You try to boot and it fails with a blank screen. (What appears before this failure -- do you see a firmware POST display, a GRUB menu, etc.?) You power off and power back up, which results in a GRUB menu followed by a successful boot. If I'm misunderstanding, please clarify.

Those symptoms are rather peculiar. I would expect a cold boot to work identically no matter what; however, one possibility does occur to me: GRUB can be configured to track successful vs. failed boots, and to boot differently when it's launched after a failed boot. Thus, you may be seeing something where the default GRUB configuration is failing, so it only works when GRUB detects that fact and boots in a fallback configuration. I'm only passingly familiar with this GRUB feature, though, and I don't know how Mint sets it up, so I can't offer much more guidance on this. It might be something you could investigate, though. There's a chance that Boot Repair would fix this -- but there's also a chance that it would make it worse (say, by disabling the boot-after-failure pathway that's now your only way to boot).
A little background, my computer natively came with Windows 7, but when Windows 8 was released, Acer made a "hasty" UEFI BIOS to make the laptop compatable. I say hasty because there is NO way to boot into teh UEFI or control/change any settings of any type related to EFI. It is the same BIOS as before the update. Now I have no way of turning off/on the secure boot or anything else.
Windows 8 will work fine on a computer with a traditional BIOS. It's conceivable that Acer released an updated EFI firmware to add Secure Boot support or for some other reason, but it's unlikely that such an update was required for Windows 8 compatibility.

Computers that ship with Windows 8 and that have a Windows 8 sticker are required (by contract with Microsoft) to provide a way to disable Secure Boot. This requirement probably doesn't apply to a firmware update for a computer that shipped with Windows 7, so it's conceivable that such a computer will boot only in Secure Boot mode; however, if you don't see any Secure Boot options, I'd say it's more likely that it doesn't support Secure Boot at all, since a Secure-Boot-only policy would also prevent the computer from booting Windows 7. You could test this by trying to boot a CD-R or USB flash drive version of my rEFInd boot manager. The CD-R and USB flash drive images I provide don't support Secure Boot, so if they boot, your computer is set to boot without Secure Boot (or it doesn't support Secure Boot at all). If the computer refuses to boot my rEFInd media, then it might be set with Secure Boot active (or there could be some other explanation for a failure).
I'd really like to use Mint 16. But I think, in order to make it work, I need to remove the efi partition and make my main partition the boot partition. But I have no idea of how to accomplish this.
As others have said, do not delete your EFI System Partition (ESP)! Your computer relies on that partition to boot, so removing it will remove your only boot path, and you'll need to fix that in one way or another. It is possible to convert to a BIOS/CSM/legacy boot path, but there are moderately common firmware bugs that can crop up with such a conversion, so this approach isn't really likely to be any easier than sticking with EFI and getting it working better than it is now.

I recommend you read my page on Linux EFI-mode installations for important background information and advice on avoiding certain common pitfalls. It sounds like you've run into an uncommon pitfall, though, so my page will be more helpful for the background information, which should give you a better mental model with which to approach the problem.

Beyond that, try reading up on EFI boot loader options for Linux. It's possible that you'll have better luck with another boot loader. The aforementioned rEFInd is likely to be relatively easy to try. Chances are you'll be able to test it from a CD-R or USB flash drive without installing it to your hard disk or adjusting the default configuration, so it's fairly safe to test. ELILO and Fedora's patched GRUB Legacy might also be worth trying. Keep in mind, though, that if my hypothesis about a failing default boot path and a successful fallback boot path is correct, the issue is likely to be one of bad options being passed to the kernel by GRUB (or alternatively, a lack of necessary options being passed by GRUB). The same bad (or good) options can be passed to the kernel by any other boot loader, so the key with any boot loader would be to identify which boot option(s) is/are causing the boot failure.

One more comment: Your fdisk output indicates that your /dev/sda uses GPT but your /dev/sdb uses MBR. This is perfectly legal in both EFI and Linux; however, many manufacturers have released extremely buggy EFIs, and it's conceivable that your EFI is flaking out and causing boot problems because of the MBR hard disk. If so, converting the disk from MBR to GPT will fix the problem. You can do such a conversion with my GPT fdisk (gdisk), which is part of the "gdisk" package in Mint. See the gdisk documentation for details. This possibility strikes me as a long shot, though; it seems more likely that the problem is caused by a bad kernel option. Still, it might be worth investigating, particularly if you can launch rEFInd or some other EFI boot loader but have problems booting from that software. The trouble is that testing this hypothesis will require an MBR-to-GPT conversion. Such a conversion is theoretically easy, but there's always the chance of creating a disastrous problem when doing such a conversion. Thus, I'd hold off on doing it and keep this approach in mind in case others don't pan out.
thomas.raines
Level 1
Level 1
Posts: 43
Joined: Mon Feb 11, 2013 12:03 am

Re: Remove or Disable EFI in Mint 16

Post by thomas.raines »

@srs5694
To clearify, when I boot, I get my BIOS splash screen then it turns blank. My hard drive light flashes 3 times and then nothing. My computer stalls.
Upon force reboot, I get the grub, and at that point, I select my OS and it boots as normal.
Per everything you posted above, I have already tried, except the rEFIND boot manager. Those pages were my first stop before posting this thread. I guess I should have mentioned it in the OP. I apologize. I currently don't have any blank cd's atm to try that. But I can tell you, another thing I should have put in the OP, that when I boot from my installer USB, I get an error saying "Secrue Boot is not enabled". Which forces the grub to load at which time I have to shoose to boot into compatability mode (Normal option yeilds the same blank screen as I am experiencing). Thereofre, I have come to the conclusion that there is an issue regarding secure boot on/off and the lack to control this in BIOS. As for my shotty BIOS, I got that blob from others talking about it in the Acer forums.
As for the boot-repair, I tried every option that was available only to end up with a No Operating System Found error upon reboot.
As for the gdisk, I tried installing a GPT, I was faced with "Warning! This will destroy the currently defined partitions!". In which I ignored and it resulted in that No OS found error as well.
User avatar
Spearmint2
Level 16
Level 16
Posts: 6892
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Remove or Disable EFI in Mint 16

Post by Spearmint2 »

You installed Mint 16 with 64 bit and it detected a GPT formatted disc (instead of MBR) and did what it is supposed to do, which is install using an EFI. Are you then unable to view files in the EFI partition?

This might interest you.
http://ubuntuforums.org/showthread.php?t=1974392
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
thomas.raines
Level 1
Level 1
Posts: 43
Joined: Mon Feb 11, 2013 12:03 am

Re: Remove or Disable EFI in Mint 16

Post by thomas.raines »

Spearmint2 wrote:You installed Mint 16 with 64 bit and it detected a GPT formatted disc (instead of MBR) and did what it is supposed to do, which is install using an EFI. Are you then unable to view files in the EFI partition?

This might interest you.
http://ubuntuforums.org/showthread.php?t=1974392
Thanks, that link and your suggestion fixed it. Here's what I did:
Since the built in image writer in Linux Mint formated my usb drive where it mounts as read only, I installed Deepin Software Centerhttp://www.noobslab.com/2013/07/deepin- ... 0-and.html. From within Deepin, I installed usb-creator-gtk (aka Startup Disk Creator). I then opened gparted deleted the partition on my usband selected Device/Create new partition table... and chose the defautl msdos type to create an MBR partition on my usb drive. I went back to usb-creator-gtk and made a live usb with Linux Mint 16 Cinnamon. Once it was finished, I mounted my usb drive and removed the EFI folder. I rebooted into my new Live USB drive and didn't get a Secure Boot is not Enabled error (YAY! progress...lol). Now, it took a really long time to boot into Mint live, but once it was up and running, I again, used gparted on my hard drive and repeated the steps I performed for my USB drive. I installed Mint 16 as normal and no more EFI crap!

Thanks for everyones help!
srs5694
Level 6
Level 6
Posts: 1389
Joined: Mon Feb 27, 2012 1:42 pm

Re: Remove or Disable EFI in Mint 16

Post by srs5694 »

thomas.raines wrote:when I boot from my installer USB, I get an error saying "Secrue Boot is not enabled". Which forces the grub to load at which time I have to shoose to boot into compatability mode
That's not an error message. That message is displayed by the shim program, and it's purely informational, not an error. It's just telling you precisely what it says: Secure Boot is not enabled on the computer. This is perfectly normal if your computer doesn't support Secure Boot or if you've disabled it. On a computer on which Secure Boot is enabled, shim prints a similar message saying as much.

You've mistakenly concluded that there's a causal connection between this shim message and booting into compatibility mode. It's still not 100% clear to me how you've been booting, but if you see the shim message and then get the system booted to Linux without rebooting, you're not booting in BIOS/CSM/legacy mode. If you boot to Linux without first seeing the shim message, then you might be booting in either EFI/UEFI mode or in BIOS/CSM/legacy mode.
Thereofre, I have come to the conclusion that there is an issue regarding secure boot on/off and the lack to control this in BIOS.
This conclusion is erroneous.
Once it was finished, I mounted my usb drive and removed the EFI folder. I rebooted into my new Live USB drive and didn't get a Secure Boot is not Enabled error (YAY! progress...lol).
Progress? Well, yes and no. Without the EFI directory, you were almost certainly booting in BIOS mode, and I suspect that's how you're now booting. If that works for you, then great; but do not walk away from this thinking that the "Secure Boot not enabled" message was an error or that its disappearance was causally related to fixing your problem -- it wasn't. Your problem may have been related to some type of EFI issue (my guess is display driver problems), but it was not related to shim or its message. (If it sounds like I'm beating a dead horse here, that's just because misinterpretations of all things EFI-related are far too common, and they sometimes spread. Many misinterpretations, like the misidentification of the "Secure Boot not enabled" message as an error, keep cropping up again and again.)
Post Reply

Return to “Newbie Questions”