PLEASE PLEASE help update wont work, Malformed line 1

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Dariens007
Level 1
Level 1
Posts: 5
Joined: Mon Feb 17, 2014 2:12 pm

PLEASE PLEASE help update wont work, Malformed line 1

Post by Dariens007 » Mon Feb 17, 2014 2:28 pm

hello new linux user here
my update manager gui and command line will not work and i can't install skype or any applications. i read a post for answer didn't work so here is what i did and some information i thought would be helpful
i openeded a terminal and typed uname -a; lsb_release -rd; inxi -r here is the output
----------------------------------
Linux x-System-Product-Name 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Description: Linux Mint 16 Petra
Release: 16
Repos: Active apt sources in file: /etc/apt/sources.list.d/additional-repositories.list
deb http://archive.canonical.com/ partner
deb http://archive.canonical.com/petra partner
Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http://packages.linuxmint.com petra main upstream import #id:linuxmint_main
deb http://extra.linuxmint.com petra main #id:linuxmint_extra
deb http://archive.ubuntu.com/ubuntu petra main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu petra-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ petra-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ petra partner
x@x-System-Product-Name:~ >
------------------------------------
i then typed sudo apt-get update here is what i got

i got
----------------------------------
x@x-System-Product-Name:~ > sudo apt-get update
E: Malformed line 1 in source list /etc/apt/sources.list.d/additional-repositories.list (dist parse)
E: The list of sources could not be read.
[100]x@x-System-Product-Name:~ >
------------------------------------------

the GUI update does not work either

i then tried this command sudo rm /var/lib/apt/lists/* -vf it didn't help.... :( sadpanda......

i'm confused and skype nor opera will install it says
-------------------------------------------------------
Software index is broken
This is a major failure of your software management system. Please check for broken packages with synaptic, check the file permissions and correctness of the file '/etc/apt/sources.list' and reload the software information with: 'sudo apt-get update' and 'sudo apt-get install -f'.
----------------------------------------------------------------------------

please help i google and search forums and i dont understand what to do. i want the gui to work it's easier to use but i am willing to do the command line but it's so hard....i'm windows user ^_^*

i forogt let me tell you more of what i did. i have my harddrive partitioned 2 primary 1 extended partition with: Windows 7 ntfs, personal files ntfs, the extended partition has 3 partition, Linux swap formatted as linux swap and 2 ext4 partition called Mint Root and Mint Home. i installed mint there. i noticed that when i installed linux mint there was a slight graphical glitch but it went away. i downloaded linux mint form torrent torrent file cheecked as ok and what not. this help?

sorry to edit more i forgot i also did sudo apt-get install -f here is the message

Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

i dont get it.....

User avatar
jungle_boy
Level 7
Level 7
Posts: 1715
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest Land

Re: PLEASE PLEASE help update wont work, Malformed line 1

Post by jungle_boy » Mon Feb 17, 2014 3:19 pm

Backup your data and reinstall Linux Mint.
Del Inspiron 5480, Quad-core, Core I5 8th Gen, Geforce MX 150,
LM 19.2 Cinnamon

Dariens007
Level 1
Level 1
Posts: 5
Joined: Mon Feb 17, 2014 2:12 pm

Re: PLEASE PLEASE help update wont work, Malformed line 1

Post by Dariens007 » Mon Feb 17, 2014 3:41 pm

awww..... :( ok well i'll do that i guess then and thank you

dagon
Level 7
Level 7
Posts: 1674
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden
Contact:

Re: PLEASE PLEASE help update wont work, Malformed line 1

Post by dagon » Mon Feb 17, 2014 3:42 pm

Dariens007 wrote:Description: Linux Mint 16 Petra
Release: 16
Repos: Active apt sources in file: /etc/apt/sources.list.d/additional-repositories.list
deb http://archive.canonical.com/ partner
deb http://archive.canonical.com/petra partner
Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http://packages.linuxmint.com petra main upstream import #id:linuxmint_main
deb http://extra.linuxmint.com petra main #id:linuxmint_extra
deb http://archive.ubuntu.com/ubuntu petra main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu petra-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ petra-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ petra partner
Error 1. You have links pointing to a release named petra in ubuntu but petra is the name of the linuxmint release that is based on saucy. I think this problem arise mainly when you do an automatic update instead of a fresh install.
Solution: Make all repositories that contains ubuntu and canonical point to saucy and not petra.
You can do this by editing the sources file in a text editor or in a utility like synaptic.

ref.
http://forums.linuxmint.com/viewtopic.p ... 08#p811208

Error 2.
There are incomplete lines in the sources list.
should be

Code: Select all

deb http://archive.canonical.com/ saucy partner
ref. error 2
http://askubuntu.com/questions/78951/ho ... urces-list

dagon
Level 7
Level 7
Posts: 1674
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden
Contact:

Re: PLEASE PLEASE help update wont work, Malformed line 1

Post by dagon » Mon Feb 17, 2014 3:43 pm

Dariens007 wrote:awww..... :( ok well i'll do that i guess then and thank you
No. Try fixing the sources list first.

Dariens007
Level 1
Level 1
Posts: 5
Joined: Mon Feb 17, 2014 2:12 pm

Re: PLEASE PLEASE help update wont work, Malformed line 1

Post by Dariens007 » Mon Feb 17, 2014 5:32 pm

crap now i'm reinstalling mint and everything is all broken, my partitions not working, now i gotta redo it. ok so what i'll do is reinstall since now the partition is messed up. and then i'll try update and if it does it again then i'll try redirecting the link to not petra? ok i'll read it again and try it.

Dariens007
Level 1
Level 1
Posts: 5
Joined: Mon Feb 17, 2014 2:12 pm

Re: PLEASE PLEASE help update wont work, Malformed line 1

Post by Dariens007 » Mon Feb 17, 2014 5:37 pm

ah what you said is interesting about the auto update pointing to the other petra thing because i did not do a fresh install, but i did i downloaded the linux mint petra form the torrent website. well i mean from this website in torrent form, maybe i'll download it again. but i'll try what you said first.

Dariens007
Level 1
Level 1
Posts: 5
Joined: Mon Feb 17, 2014 2:12 pm

Re: PLEASE PLEASE help update wont work, Malformed line 1

Post by Dariens007 » Mon Feb 17, 2014 9:17 pm

*Update* i redid everything partitions, install, redownloaded mint and it all works! thanks for help!

User avatar
jungle_boy
Level 7
Level 7
Posts: 1715
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest Land

Re: PLEASE PLEASE help update wont work, Malformed line 1

Post by jungle_boy » Mon Feb 17, 2014 9:43 pm

You are welcome!

Often this is the best solution, because it may take a day or more to try and fix one line in the installed OS.
Del Inspiron 5480, Quad-core, Core I5 8th Gen, Geforce MX 150,
LM 19.2 Cinnamon

Post Reply

Return to “Newbie Questions”