Page 1 of 1

Default keyboard shortcuts

Posted: Mon Sep 01, 2008 2:35 am
by rothgar
I have been using linux mint for a little while now and even got a friend to switch from Windows for it. I am now on the verge of getting my wife to install linux mint but I have a couple of things that are confusing for me with keyboard shortcuts.

1. I want a keyboard shortcut to open the main menu. I know there has been talk about this in other places on the forum but I find it completely absurd that I cannot open the menu without using the mouse. This is one of the things I like so much about Vista. Just a "super" key press, type in my program/document and away I go. I simply cannot do that in Linux Mint without alt+f2 and launch the program (assuming I know the name/executable). I know alt+f1 brings up a menu too (not sure if that is default) but it isn't as simple to use as the regular mint menu. I am not asking for "super" to be the keypress, but allowing some sort of key combination to open the menu would be very nice.

2. How do I clear keyboard shortcuts? If I accidentally set a keyboard shortcut or want to clear a default one I am not sure how to do that. I tried esc but that just cancels my entry and sets it back to whatever it was.

3. Super+?? keys don't work for me for shortcuts. Every time I push the super key in the control panel -> keyboard shortcuts it just shows Super+L and won't let me set it as anything else. I am not sure if this has to do with the fact that maybe Super+L is the only key command not being used by compiz fusion but it seems annoying that after I set it to Super+L I cannot clear it (see point #2)

4. This is the final thing I am looking for, A list of what the default keyboard shortcuts are. I have a few that are hex values (impossible to find what button/key that is) and when I booted my wife's laptop from a live cd alt+space brought up a nice search application that I can't seem to find on my installation.

Any help in these points is greatly appreciated. I love what you guys have been able to do from ubuntu (mainly the UI improvements) and I plan on using linux mint for a while longer but these are just things that I have noticed that have been bugging me lately.

Thanks

Re: Default keyboard shortcuts

Posted: Mon Sep 01, 2008 1:15 pm
by Husse
1) The problem here is that we are not using the gnome menu and the keyboard shortcuts is a "gnome thing"
You get the gnome menu with Alt+F1. Sadly you can only assign keys to predefined tasks, not assign a task to a key (the other way round) This should work but does not
viewtopic.php?f=76&t=14901&hilit=keyboard+shortcut+menu#p91904
Right now my SuperL stopped doing anything...
I have tried to find an answer but honestly I don't think it's possible - at least that's what the developer of mintMenu states here
viewtopic.php?f=76&t=3158
I found something that may be possible to use, but I have to investigate a little bit more
2) It's clearly stated on the keyboard shortcut "dialogue box" - use backspace
3) SuperL and superR can't be combined with other keys (at least I have not found a way...)
4) Here's an extensive table of default shortcuts not only in gnome
http://en.wikipedia.org/wiki/Table_of_k ... _shortcuts

Re: Default keyboard shortcuts

Posted: Mon Sep 01, 2008 6:45 pm
by MagnusB
OpenSuSE 11 has slab assigned to the super key, only distro I can think of that has this right now.

Re: Default keyboard shortcuts

Posted: Tue Sep 02, 2008 5:39 pm
by routine
Husse wrote:3) SuperL and superR can't be combined with other keys (at least I have not found a way...)


Yes, they can. I don't remember exactly how, but after altering some settings (perhaps it was in gconf-editor) you can indeed use Super-L and Super-R with other keys. However! As soon as you do, you can no longer use it on it's own. In other words the Super-L and Super-R keys behave like CTRL or ALT or SHIFT and when pressed by themselves do nothing.

A Windows Compatibility Mode checkbox would be nice. A setting somewhere that does the following:

1. Opens menu with Super (either SuperL or SuperR).
2. Opens Run command with Super - R.
3. Show desktop with Super - D.
4. Open Nautilus with Super - E (or N, whichever you prefer).
5. Search with Super - F
6. Lock screen with Super - L.
etc...

Heck, I'd settle for a config file that I had to edit to get this feature. This setting does not have to be on by default, but it would go a long way in making Linux more productive.

Re: Default keyboard shortcuts

Posted: Tue Sep 02, 2008 7:04 pm
by MagnusB
You have GNOME DO, I barely use the menu now a days anyway.

Re: Default keyboard shortcuts

Posted: Wed Sep 03, 2008 12:53 am
by rothgar
Thanks Husse for the tips. I bookmarked/delicioused that wikipedia article so I can keep it around for future reference.
And I will have to RTFM/Screen next time before I give up all hope.

routine wrote:A Windows Compatibility Mode checkbox would be nice. A setting somewhere that does the following:

Heck, I'd settle for a config file that I had to edit to get this feature. This setting does not have to be on by default, but it would go a long way in making Linux more productive.


This sounds wonderful! I know Windows is not the best way to do things but for me, at this time, it is the most productive.

Re: Default keyboard shortcuts

Posted: Wed Sep 03, 2008 4:36 am
by MagnusB
TBH, I prefer GNOME DO, activate it by using super+space. It even keep a track of the applications/etc that you open the most, so I only press super+space then F and then enter and Firefox is open. It is so intuitive and brilliant to use, should be advertised more..

Re: Default keyboard shortcuts

Posted: Fri Sep 26, 2008 2:25 am
by azulmarino
MagnusB wrote:TBH, I prefer GNOME DO, activate it by using super+space. It even keep a track of the applications/etc that you open the most, so I only press super+space then F and then enter and Firefox is open. It is so intuitive and brilliant to use, should be advertised more..


Yes! You are right, GenomeDo is a wonderful alternative, even more when Gnome shortcuts are disabled by Compiz and CompizConfig Manager key bindings setup is buggy. Thanks for the tip on the shortcut for GnomeDo :D