(Solved!) PulseAudio Mic Issue - Aspire One + Linux Mint 13

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

(Solved!) PulseAudio Mic Issue - Aspire One + Linux Mint 13

Post by darkstrike »

Hey all,

I've got an Aspire One for a friend (can't remember the exact model as I don't have it with me at present) that I just installed Linux Mint 13 on and everything works perfectly....except the Mic (which she NEEDS for Skype to be able to talk to her ill sister in England). I've checked all the volume sliders for the mic, they're all at max, I've installed the GNOME Alsa Mixer and the Pulseaudio Control Panel thing (again, I forget the exact name of that program as I don't have the comp here with me atm...paucontrol or something?) and everything seems set right there as well, but I still don't hear anything from the mic but static.

When I try Skype with the Echo test service, the mic only records static. A mic icon appears at the bottom-right, it's slider is at full, but that seems to make no difference...

I had read somewhere that switching the machine over completely from PulseAudio to ALSA would probably solve the problem as people with similar issues solved theirs that way.....how would I go about making the switch and completely removing PulseAudio so I could use ALSA instead to get the mic working...?

THANKS for any help, we'd both be greatful! :)
Last edited by darkstrike on Tue Apr 08, 2014 10:56 am, edited 1 time in total.
wyrdoak
Level 6
Level 6
Posts: 1309
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: PulseAudio Mic Issue - Aspire One + Linux Mint 13

Post by wyrdoak »

In terminal:

Code: Select all

sudo apt-get install pavucontrol
then launch

pavucontrol


Then:


Click the "input devices" tab. Click the lock icon to unlock channels. Set the front right channel to silence.
-Dell Mini Inspiron 910 Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
15GB RAM- 1gbs-(LinixMint-19.3: LMDE)
User avatar
The-Wizard
Level 12
Level 12
Posts: 4066
Joined: Fri Jan 28, 2011 3:12 pm
Location: Bedforshire, ENGLAND

Re: PulseAudio Mic Issue - Aspire One + Linux Mint 13

Post by The-Wizard »

I never did get the mic working on my acer one ZG5 so i used a plug in one however I have just changed that machine to Peppermint to save space on the SSD. and now the on board mic works fine
The idea that Bill Gates has appeared like a knight in shining armour to lead all customers out of a mire of technological chaos neatly ignores the fact that it was he who, by peddling second-rate technology, led them into it in the first place.
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: PulseAudio Mic Issue - Aspire One + Linux Mint 13

Post by darkstrike »

wyrdoak wrote:In terminal:

Code: Select all

sudo apt-get install pavucontrol
then launch

pavucontrol


Then:

Click the "input devices" tab. Click the lock icon to unlock channels. Set the front right channel to silence.
Thanks mate, I'll give that a try tomorrow and see how it works - I'll reply either way with the result!
wyrdoak
Level 6
Level 6
Posts: 1309
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: PulseAudio Mic Issue - Aspire One + Linux Mint 13

Post by wyrdoak »

BTW don't let Skype control the mic. or it will override your mic settings, putting you back to were you started.
-Dell Mini Inspiron 910 Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
15GB RAM- 1gbs-(LinixMint-19.3: LMDE)
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: PulseAudio Mic Issue - Aspire One + Linux Mint 13

Post by darkstrike »

You mean the option in Skype for "Allow Skype to adjust microphone settings" ?
wyrdoak
Level 6
Level 6
Posts: 1309
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: PulseAudio Mic Issue - Aspire One + Linux Mint 13

Post by wyrdoak »

yes don't let Skype adjust the mic settings or it will turn on the front right channel you just turned off.
-Dell Mini Inspiron 910 Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
15GB RAM- 1gbs-(LinixMint-19.3: LMDE)
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: PulseAudio Mic Issue - Aspire One + Linux Mint 13

Post by darkstrike »

Thanks for the tip - I don't usually set it to auto-adjust anyway as I find it's really bad at it, haha! I didn't get a chance to try it today as my friend wasn't home, but I am hoping to drop in tomorrow!
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: PulseAudio Mic Issue - Aspire One + Linux Mint 13

Post by darkstrike »

Sorry for the late reply, but just wanted to let everybody know that this:
wyrdoak wrote:In terminal:

Code: Select all

sudo apt-get install pavucontrol
then launch

pavucontrol


Then:


Click the "input devices" tab. Click the lock icon to unlock channels. Set the front right channel to silence.
Solved my problem! :) Thanks all!
Post Reply

Return to “Newbie Questions”