SOLVED System Clock cant keep time

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Locked
special_k_423
Level 1
Level 1
Posts: 7
Joined: Sat Apr 19, 2014 10:23 pm

SOLVED System Clock cant keep time

Post by special_k_423 »

The system clock loses time quick. It apparently has something to do with my chipset not being so compatible with Linx Mint 16 petra to the best of my knowledge. Win Vista has no trouble keeping time. How can I auto update my time every hour or something to keep decent time. I tried researching a solution but all of that stuff is WAY above my head and I have failed epically. Spoon feed me please :-p
Last edited by special_k_423 on Mon May 19, 2014 10:04 pm, edited 1 time in total.
User avatar
kyphi
Level 9
Level 9
Posts: 2703
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter Valley, Australia

Re: System Clock cant keep time

Post by kyphi »

Since you have not specified which version of Linux Mint you are using nor the desktop environment, I have provided here the procedure for Linux Mint 16 Cinnamon:

Open "System Settings" from the main menu. Go to "Date & Time" make sure that your Region and City are set correctly as well as the time. Place a tick into the square next to "Use network time". Then close the screen.

If the time is still erratic, you may have to replace the CMOS battery since your system is rather old (Win Vista).
Linux Mint 20.0 Cinnamon - 64bit
turtlebay777

Re: System Clock cant keep time

Post by turtlebay777 »

special_k_423 wrote: chipset not being so compatible with Linux Mint 16 petra
I've never heard that before.

The usual reason is that the small 'watch battery' on the motherboard needs replacing, a job that is quick to do and shouldn't cost more than about £5, if that.
Mute Ant
Level 14
Level 14
Posts: 5130
Joined: Tue Sep 03, 2013 7:45 pm
Location: Norfolk UK

Re: System Clock cant keep time

Post by Mute Ant »

Yup the RealTimeClock only eats 3V from the coin-cell on the motherboard. It is considered impolite to liberate a parent's blood-sugar-monitor spare as a replacement. :roll:
While you're waiting, read the free novel we sent you. It's a Spanish story about a guy named "manual".
User avatar
I2k4
Level 5
Level 5
Posts: 679
Joined: Thu Feb 02, 2012 8:33 pm

Re: System Clock cant keep time

Post by I2k4 »

special_k_423 wrote:The system clock loses time quick. It apparently has something to do with my chipset not being so compatible with Linx Mint 16 petra to the best of my knowledge. Win Vista has no trouble keeping time. How can I auto update my time every hour or something to keep decent time. I tried researching a solution but all of that stuff is WAY above my head and I have failed epically. Spoon feed me please :-p
I have no hardware problem and until I do these things Mint 16 will keep reverting to Greenwich time.

1. Go to Synaptic or the software manager and install "NTP" to replace "NTPData" - that's the full service internet timekeeper. I don't know why it isn't installed by default.

2. You can use the Mint settings to find and reset the time zone but I use the Terminal:

sudo dpkg-reconfigure tzdata

Enter your system password and follow directions in the terminal session.
TRUST BUT VERIFY any advice from anybody, including me. Mint/Ubuntu user since 10.04 LTS. LM20 64 bit XFCE (Dell 1520). Dual booting LM20 XFCE / Win7 (Lenovo desktop and Acer netbook).
User avatar
leejosepho
Level 2
Level 2
Posts: 61
Joined: Tue Mar 23, 2010 9:45 pm
Location: 200 miles south of Little Rock
Contact:

Re: System Clock cant keep time

Post by leejosepho »

kyphi wrote:...Place a tick into the square next to "Use network time".
If you do that and you are multibooting with Vista, you will likely have to switch Vista also. So, maybe first replace the CMOS battery and check the other settings mentioned above. In my own case, tomorrow I plan to change my Linux (LMDE) to use local (machine) time rather than having to change all the other OSs in my machine...and that is why Mint has the option for which way to go during installation. Just a few years ago, Debian had the option during installation (and now it does not) and Mint did not!
User avatar
kyphi
Level 9
Level 9
Posts: 2703
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter Valley, Australia

Re: System Clock cant keep time

Post by kyphi »

I cannot quite follow the "logic" here. How can a time configuration in Linux Mint affect the time configuration in Windows Vista?
If someone can provide a logical answer ... I am all ears.
Linux Mint 20.0 Cinnamon - 64bit
User avatar
I2k4
Level 5
Level 5
Posts: 679
Joined: Thu Feb 02, 2012 8:33 pm

Re: System Clock cant keep time

Post by I2k4 »

kyphi wrote:I cannot quite follow the "logic" here. How can a time configuration in Linux Mint affect the time configuration in Windows Vista?
If someone can provide a logical answer ... I am all ears.
It's why I'm skeptical of the "battery" advice - if it boots in Vista it means the BIOS time is running. My oldest "backup" laptop has all dead batteries and I have to go into BIOS to manually set the time before it will even boot up - once plugged in the internet keeps it current. If Vista is keeping time correctly between boots, I suspect the issue I wrote about above that has affected the last several versions of Mint on my machines - Mint keeps changing to UTC / Greenwich time until I install NTP and set the time zone.
TRUST BUT VERIFY any advice from anybody, including me. Mint/Ubuntu user since 10.04 LTS. LM20 64 bit XFCE (Dell 1520). Dual booting LM20 XFCE / Win7 (Lenovo desktop and Acer netbook).
Ceilidh2
Level 4
Level 4
Posts: 282
Joined: Thu Apr 17, 2014 10:29 pm
Location: Thames, New Zealand

Re: System Clock cant keep time

Post by Ceilidh2 »

Sorry, I posted this in the wrong place and now I can't find the Delete Post button.
Last edited by Ceilidh2 on Wed Apr 30, 2014 6:07 am, edited 1 time in total.
"Take it easy, but take it." Woody Guthrie
User avatar
leejosepho
Level 2
Level 2
Posts: 61
Joined: Tue Mar 23, 2010 9:45 pm
Location: 200 miles south of Little Rock
Contact:

Re: System Clock cant keep time

Post by leejosepho »

I am also skeptical of the CMOS battery being your problem, but I have occasionally been known to be wrong about one thing or another!
kyphi wrote:I cannot quite follow the "logic" here. How can a time configuration in Linux Mint affect the time configuration in Windows Vista?
I am making an assumption there in relation to Vista since it is similar to Win7, and every time I boot my LMDE installation the time setting in my BIOS gets changed (5 hours added) by Linux (and that change later shows up in XP and Win7 unless I first go back into my BIOS at system start and put my time setting back to where it should be). However, I have yet to see that happen in a different (newer) machine where Mint 16 Cinnamon is installed alongside Vista...so possibly my own problem has to do with my BIOS in one machine being more vulnerable than the other.
Mute Ant
Level 14
Level 14
Posts: 5130
Joined: Tue Sep 03, 2013 7:45 pm
Location: Norfolk UK

Re: System Clock cant keep time

Post by Mute Ant »

Locale time zones only change in whole hour increments, the minutes stay the same. "loses time real quick" to me means "only runs 55 minutes per hour" which would be the hardware clock going limp. Changing whole hour chunks in a single jump often happens between Mint [BIOS=UTC] and Windows [BIOS=LOCAL] and the running OS might change the BIOS clock, which upsets the inactive OS next time it starts.
While you're waiting, read the free novel we sent you. It's a Spanish story about a guy named "manual".
User avatar
kyphi
Level 9
Level 9
Posts: 2703
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter Valley, Australia

Re: System Clock cant keep time

Post by kyphi »

"ntp" and "ntpdata" are not installed by default but "ntpdate" is. When you look at what these programs do (description is in synaptic), you will find that ntp and ntpdate appear to do the same thing.
All my installed operating systems report the time accurately and have always done so. They all have had country and city specified during installation, in other words, the time zone has been set.

None of this is of any help to the original poster until he/she provides more information.
Linux Mint 20.0 Cinnamon - 64bit
User avatar
nerdtron
Level 5
Level 5
Posts: 625
Joined: Sun Jan 31, 2010 10:46 am
Location: Pilipinas kong mahal!

Re: System Clock cant keep time

Post by nerdtron »

How many hours is the discrepancy between the time when you boot in Vista and then boot in Mint?
I think this has something to do with the timezones and the way the internal (BIOS) clock is interpreted.
For example:
BIOS time 10:00am
Vista time: 10:00am
Mint time: 2:00pm

Does this happen?
"I learned a lot from repeatedly breaking my system and then reinstalling. Oh, and a lot of GOOGLE searches too!"
kurotsugi
Level 6
Level 6
Posts: 1026
Joined: Fri Jan 25, 2013 3:54 am

Re: System Clock cant keep time

Post by kurotsugi »

the discussion is a lil bit far from the problem :3
can I see the content of /etc/adjtime?
if your file is like this

Code: Select all

0.058918 1394537379 0.000000
1394537379
UTC
replace UTC with LOCAL then reboot. you'll also need to make sure that your timezone is correct
special_k_423
Level 1
Level 1
Posts: 7
Joined: Sat Apr 19, 2014 10:23 pm

Re: System Clock cant keep time

Post by special_k_423 »

Ok so I've done my due diligence and have found that replacing my cmos battery is a risky operation. This is a laptop and the cmos battery is underneath the keyboard. I've looked into taking the laptop apart but quite frankly I've had no luck doing so in the past on another laptop I had. This laptop isnt worth paying someone to fix either. I did some more research and seen that maybe i could set crontab to sync the time for me? I've tried to do that but I can't figure out the programming. Again I did lots of research and have tried and tried on my own and have had no luck. Below is a picture of what my crontab file looks like. And no I dont want it to sync the time every minute, I was just trying to make sure I had gotten the code right. I know I could manually do sudo update every time but I use this laptop as an alarm clock as it is very loud and i have the screen flash and everything lol. If I forget to update the time before I go to sleep I might oversleep! Many thanks in advance.
Attachments
crontab.jpeg
User avatar
nerdtron
Level 5
Level 5
Posts: 625
Joined: Sun Jan 31, 2010 10:46 am
Location: Pilipinas kong mahal!

Re: System Clock cant keep time

Post by nerdtron »

If you're talking about the crontab syntax, yours is correct. You don't have to use sudo on the ntpdate command if you added it on the root crontab.

Code: Select all

sudo crontab -e
Sync the correct time once every minute.

Code: Select all

* * * * * ntpdate pool.ntp.org
Sync the correct time once every hour.

Code: Select all

0 * * * * ntpdate pool.ntp.org
"I learned a lot from repeatedly breaking my system and then reinstalling. Oh, and a lot of GOOGLE searches too!"
special_k_423
Level 1
Level 1
Posts: 7
Joined: Sat Apr 19, 2014 10:23 pm

Re: System Clock cant keep time

Post by special_k_423 »

Thank you SO MUCH! My problem was I was just typing crontab -e and not sudo crontab -e. My computer has been keeping time now for 24 hours! I never read anywhere about the sudo crontab deal.
User avatar
usbtux
Level 5
Level 5
Posts: 974
Joined: Tue Dec 28, 2010 10:37 am

Re: System Clock cant keep time

Post by usbtux »

nerdtron wrote:
Sync the correct time once every hour.

Code: Select all

0 * * * * ntpdate pool.ntp.org
Wont this continually pole the time server

I'd use

Code: Select all

*/10 * * * * ntpdate pool.ntp.org


Which will run every ten mins
http://goo.gl/DXKgM LinuxMint tutorials.
Running LinuxMint 17.3 Mate. Pepermint 6 & Manjaro 15.12 Capella XFCE
http://goo.gl/WFu0u Installing Mint - the screen cast videos.
linuxcounter #368850
electroken
Level 1
Level 1
Posts: 21
Joined: Sat Feb 09, 2013 8:57 pm
Location: Minnesota
Contact:

Re: SOLVED System Clock cant keep time

Post by electroken »

My problem seems to be different than those described.
I have my time in 24 hr mode. I am running linux mint 17.3 with latest updates. I have selected to get time from internet and I am in the correct time zone. \
My time varies daily. I set it today and probably by later on today it will be fast by several minutes or sometimes a lot more.
I am on a desktop computer with power on continuously; but the computer does go into sleep mode after an hour.
I bring it out of sleep mode every time by hitting the space bar.
I see no way in the help given previously to change the server for where the time is correlated.
It is very annoying to have to constantly go in and change my system time so I will have the correct time locally for emails and using Skype.
I have searched around the forum for an answer to this to no avail.
User avatar
Moem
Level 20
Level 20
Posts: 11838
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: SOLVED System Clock cant keep time

Post by Moem »

electroken wrote:My problem seems to be different than those described.
Then please start a new thread. This one is years old and as per the guidelines, it should not be resurrected.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
Locked

Return to “Newbie Questions”