Nemo file browser returns to Home after being idle

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Box293
Level 1
Level 1
Posts: 10
Joined: Mon May 12, 2014 5:39 pm

Nemo file browser returns to Home after being idle

Post by Box293 » Mon May 12, 2014 5:53 pm

I've tried searching for an answer to this however no luck so I've posted here.

I am using Mint 16 with Cinnamon. I have a mounted drive to a Windows server and this is set to auto mount at logon. This all works well.

When I have Nemo open on this mounted drive, after xxx time being idle the window returns to home.
  • I open Nemo
    I Browse to my network mount into sub directories
    The contents are displayed in the main window
    I leave Nemo open on my second monitor
    I go an do other stuff on my first monitor (web browsing, coding etc)
    After a period of time (about 3-5 minutes), I notice the Nemo window refresh and now it is displaying the Home contents, like I just opened it fresh (Home is selected on the right pane)
    I can click the back button on Nemo and I am returned the the same folder in my network drive almost instantly
I don't think this is a Nemo problem, this is just how I know to reproduce the issue.

I suspect there is some sort of timeout on mounted network drives that is occurring, not sure if there is a way to stop the behaviour happening.

The entry in /etc/fstab to automount the drive is:

Code: Select all

//Server/Share /media/MountFolder cifs username=myname,password=mypassword,_netdev 0 0

Box293
Level 1
Level 1
Posts: 10
Joined: Mon May 12, 2014 5:39 pm

Re: Nemo file browser returns to Home after being idle

Post by Box293 » Sat Nov 22, 2014 11:25 pm

I recently upgraded to Mint 17 with Cinnamon. After some annoying problems I had, I installed Mint 17 with Cinnamon from scratch. My annoying (unrelated) problems still existed in Mint 17 so I installed Mint 17 MATE and I've been using it since.

After using it for a week or so I realised the file browser problem I had with Nemo no longer exists with Caja. Caja will stay open on my mounted windows server location and never returns to my home folder.

Yay

Post Reply

Return to “Newbie Questions”