Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
dcovnton
Level 1
Level 1
Posts: 18
Joined: Sat Aug 13, 2011 1:01 pm

Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by dcovnton »

Linuxmint 17 .64 bit Cinnamon vs. 2.2.10 - Linux-Kernel 3.13.0-24-generic
Processor: Intel core i7-2820qm @2.30GHz x4
Ram:15.6Gib
HDD: 229.5 SSD & Second-bay HDD 750Gib- (just sitting there can't get it to mount (nothing), was gonna use it for backup of big files, videos, photos... projects) any ideas welcomed
GraphicCard: NVIDIA Corp. GF106M [GeForce GT 555M]


Okay, here is my problem:

After installing Netflix Desktop without any complaints it loads I hear sound of the video, but the video image itself freezes (audio plays without issue)
I do not get an error message to report here, and this is very frustrating as at this point. Any viable suggestions?

Device Driver: I am using the nvidia-331(recommended) version-331.38-oubunt7

Installation steps I took:

Code: Select all

sudo apt-add-repository ppa:ehoover/compholio
sudo apt-get update
sudo apt-get install netflix-desktop
Attachments
Driver options
Driver options
iowabeakster
Level 3
Level 3
Posts: 138
Joined: Wed Oct 31, 2012 1:00 pm

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by iowabeakster »

This is a laptop, right?

What video card is in operation, the integrated intel or the nvidia?
dcovnton
Level 1
Level 1
Posts: 18
Joined: Sat Aug 13, 2011 1:01 pm

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by dcovnton »

It's the nvidia card.
dcovnton
Level 1
Level 1
Posts: 18
Joined: Sat Aug 13, 2011 1:01 pm

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by dcovnton »

Yes, Nvidia card and a laptop.
User avatar
Spearmint2
Level 16
Level 16
Posts: 6892
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by Spearmint2 »

Code: Select all

inxi && inxi -G
Doesn't Netflix require Microsoft's silverlight program? Linux has a deprecated program called "moonlight" that was a takeoff on silverlight. I don't know if it works for running Netflix.

This video purports to get netflix running properly.
https://www.youtube.com/watch?v=znCPmmYjPqA

Looks like you may need to add the PPA for wine (http://www.winehq.org) and install the version 1.7

http://www.winehq.org/download/ubuntu

This seems to be the latest method used, called "pipelight".
http://fds-team.de/cms/articles/2013-08 ... wsers.html
http://fds-team.de/cms/pipelight-installation.html

here's a video based on the above site.
https://www.youtube.com/watch?v=Fx7X79Arvlc
Set to view full screen and need to kick it up to 720 HD to see the text well. I
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
dcovnton
Level 1
Level 1
Posts: 18
Joined: Sat Aug 13, 2011 1:01 pm

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by dcovnton »

Results from inxi && inxi -G

CPU~Quad core Intel Core i7-2820QM CPU (-HT-MCP-) clocked at Min:800.000Mhz Max:2301.000Mhz Kernel~3.13.0-24-generic x86_64 Up~1 min Mem~646.5/16009.3MB HDD~1006.2GB(0.6% used) Procs~223 Client~Shell inxi~1.8.4
Graphics: Card: NVIDIA GF106M [GeForce GT 555M]
X.Org: 1.15.1 drivers: (unloaded: fbdev,vesa) FAILED: nouveau Resolution: 1920x1080@60.0hz, 1680x1050@60.0hz
GLX Renderer: Gallium 0.4 on NVC3 GLX Version: 3.0 Mesa 10.1.0


Thank you for your help,
User avatar
Spearmint2
Level 16
Level 16
Posts: 6892
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by Spearmint2 »

welcome. Keep thread updated on how well you accomplish it. If you don't already have it, should install nvidia-settings.

Code: Select all

sudo apt-get install nvidia-settings
That is a graphical front end for doing some things with Nvidia based graphics. Looks like you are not running a nvidia specific driver, but a general vesa type. You can open Package Manager and search for other geforce and/or nvidia-x drivers that might work with your graphics chip.

midnight here, I'm off to sleep.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
dcovnton
Level 1
Level 1
Posts: 18
Joined: Sat Aug 13, 2011 1:01 pm

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by dcovnton »

Tried your latest suggestion and still it get the same error?

Also error with:

sudo apt-add-repository ppa:ehoover/compholio

ou are about to add the following PPA to your system:
Traceback (most recent call last):
File "/usr/lib/linuxmint/mintSources/mintSources.py", line 1251, in <module>
add_repository_via_cli(ppa_line, codename, options.forceYes)
File "/usr/lib/linuxmint/mintSources/mintSources.py", line 45, in add_repository_via_cli
print(" %s" % (ppa_info["description"].encode("utf-8") or ""))
AttributeError: 'NoneType' object has no attribute 'encode'

??? this is insane and I am tired - seems like there is fix.
User avatar
Spearmint2
Level 16
Level 16
Posts: 6892
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by Spearmint2 »

manually add the PPA in the Package Manager then.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
dcovnton
Level 1
Level 1
Posts: 18
Joined: Sat Aug 13, 2011 1:01 pm

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by dcovnton »

Spearmint2 I thank you for your help, but please note that I am a newbie and I mean newbie.

I just reinstalled my OS cause I have tried some many steps and damn am i lost and think I may have screwed things up by now.

In any case, I dont know what to add ? Please be specific.
dcovnton
Level 1
Level 1
Posts: 18
Joined: Sat Aug 13, 2011 1:01 pm

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by dcovnton »

Okay, I got to run successfully: sudo apt-add-repository ppa:ehoover/compholio

now what do you recommend
User avatar
Spearmint2
Level 16
Level 16
Posts: 6892
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by Spearmint2 »

dcovnton wrote:Okay, I got to run successfully: sudo apt-add-repository ppa:ehoover/compholio

now what do you recommend
Just follow those instructions in the video and on the page.
Last edited by Spearmint2 on Mon May 26, 2014 7:16 am, edited 1 time in total.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
dcovnton
Level 1
Level 1
Posts: 18
Joined: Sat Aug 13, 2011 1:01 pm

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by dcovnton »

Hey spearment2, I found a temparary work-around for this issue.
It does not 100% resolve the issue but it allow me to view video (good quality) & audio is in synch.

Here is what I had to do after much to-do and many hours of trying various steps recommended its come down to:

netflix-desktop --disable-hw-acceleration

YES, DISABLE hardware acceleration!

I only feel a bit at odds that I must go to terminal enter:

Code: Select all

netflix-desktop --disable-hw-acceleration
and keep it running in termal while watching Netflix Desktop.

If I close terminal Netflix desktop closes, but as I open thermal and enter the code:

Code: Select all

netflix-desktop --disable-hw-acceleration
SO IF YOU HAVE AN ISSUE WITH FREEZING VIDEO TRY:

Code: Select all

 netflix-desktop --disable-hw-acceleration
[/b]
Thanks spearmint2
User avatar
Spearmint2
Level 16
Level 16
Posts: 6892
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by Spearmint2 »

Good deal. You can create a Launcher for that and avoid the Terminal. However if in Terminal you can launch it this way and drop the terminal.

Code: Select all

netflix-desktop --disable-hw-acceleration& disown& exit
You can right clk on desktop and create a Launcher, set it to Run but not in terminal, enter the command you have discovered, and if you don't get the icon you want, then download one from Netflix or use their picture to create your own and use that.
==============================

EDIT:

Here's some Netflix icons you can use, or resize and use.
http://www.iconarchive.com/tag/netflix

Copy to any folder, probably your Pictures is easiest. Open in GIMP (I prefer LViewPro in WINE) and resize the image to whatever size you need, probably 50x50 for desktop. When you create the Launcher for Netflix as above, you right clk on the icon area in the Launcher properties and set your new Netflix icon to replace the standard Launcher icon.

You can also resize icons right on the desktop by right clk on the launcher and choose Resize Icon.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
iowabeakster
Level 3
Level 3
Posts: 138
Joined: Wed Oct 31, 2012 1:00 pm

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by iowabeakster »

I think you've got it working, and so I should probably not add this (to avoid confusion). And if you are happy with things, it's best not to try to fix what isn't broken.

I don't think you are using the nvidia card. I think you are running on integrated (intel) graphics card.

But could you please run this in a terminal?

Code: Select all

lspci -vnnn | perl -lne 'print if /^\d+\:.+(\[\S+\:\S+\])/' | grep VGA
It should list your video cards.

The one that is "in use" will have [VGA controller] at the end.
The one that is not in use will not have [VGA controller] at the end.

I only add this because if we can get your nvidia card to be the active card, you will be able to launch the Netflix-desktop application in the normal way (and use hardware acceleration). That would also probably mean your computer will consume battery at a faster rate though.
dcovnton
Level 1
Level 1
Posts: 18
Joined: Sat Aug 13, 2011 1:01 pm

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by dcovnton »

Here is the output of your suggeston:


code:

Code: Select all

 lspci -vnnn | perl -lne 'print if /^\d+\:.+(\[\S+\:\S+\])/' | grep VGA
OutPut:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF106M [GeForce GT 555M] [10de:0dcd] (rev a1) (prog-if 00 [VGA controller])

what does this mean?
dcovnton
Level 1
Level 1
Posts: 18
Joined: Sat Aug 13, 2011 1:01 pm

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by dcovnton »

spearment2 I'll igve your suggestion a try a bit later today - Memorial Day and need to spend some time with family

Happy Memorial Day and God Bless our Men & Women who lost their lives in protecting my country USA.
iowabeakster
Level 3
Level 3
Posts: 138
Joined: Wed Oct 31, 2012 1:00 pm

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by iowabeakster »

what does this mean?
It means that you've got an Nvidia GT 555 in PCI slot 1, and it is active!

So that's good! (I was wrong in thinking that you were running on the intel graphics)

But I that makes me wonder why you aren't able to use hardware acceleration. But that is an issue that can wait....Happy memorial day,
mr_raider
Level 7
Level 7
Posts: 1889
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by mr_raider »

dcovnton wrote:Tried your latest suggestion and still it get the same error?

Also error with:

sudo apt-add-repository ppa:ehoover/compholio

ou are about to add the following PPA to your system:
Traceback (most recent call last):
File "/usr/lib/linuxmint/mintSources/mintSources.py", line 1251, in <module>
add_repository_via_cli(ppa_line, codename, options.forceYes)
File "/usr/lib/linuxmint/mintSources/mintSources.py", line 45, in add_repository_via_cli
print(" %s" % (ppa_info["description"].encode("utf-8") or ""))
AttributeError: 'NoneType' object has no attribute 'encode'

??? this is insane and I am tired - seems like there is fix.
this method is deprecated. The currently supported method is using pipelight.

sudo add-apt-repository ppa:pipelight/stable

http://fds-team.de/cms/pipelight-installation.html


Secondly, there is a serious problem with your graphics driver install. Your driver manager shows the nvidia driver installed, but you are not using it according to the command line output.

Try deleting your xorg.conf (if any) and typing the following:

sudo nvidia-xconfig
Image
iowabeakster
Level 3
Level 3
Posts: 138
Joined: Wed Oct 31, 2012 1:00 pm

Re: Netflix desktop freezes on LinuxMint 17 - Cinnamon .64

Post by iowabeakster »

Secondly, there is a serious problem with your graphics driver install. Your driver manager shows the nvidia driver installed, but you are not using it according to the command line output.

Try deleting your xorg.conf (if any) and typing the following:

sudo nvidia-xconfig
Yes, there is.

The problem is that he's going to have to shutdown the xserver, blacklist nouveau, etc, in order for nvidia config to work correctly, and then load the right driver on the next boot (essentially a manual install, which has the potential of scaring him away from Linux permanently... :lol: ) . I believe that should have been done by the driver manager when installing the driver, and finished on the subsequent reboot. Since that didn't happen, that presents a few more questions.
Post Reply

Return to “Newbie Questions”