Linux Cinnamon 17 - VLC won't disable screensaver

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
redb4umint
Level 1
Level 1
Posts: 1
Joined: Fri May 23, 2014 3:21 pm

Linux Cinnamon 17 - VLC won't disable screensaver

Post by redb4umint » Thu May 29, 2014 11:33 am

Hello Linux users,

Please be kind, I'm new and have been using Linux Mint for about a month now. This is my first post. I've searched the forum but have yet to solve this problem.

My problem is whenever I watch a full screen video using VLC the screensaver kicks in on my Dell netbook after 10min. I want to be able to temporary disable the screen saver when watching videos in a full screen format. Originally I installed Mint 16 xfce but then realized that Mint 17 was being released shortly with long term support. I decided to upgrade from Mint 16 xfce to Mint 17 Cinnamon 32bit by downloading the OS and installing it from USB stick. I then used the built-in Backup/Restore utility to restore my software and files. Originally, I installed Wine and PlayonLinux (not sure if that's the same product) and xscreensaver applications.

I like xscreensaver because it seems to have a better screensaver selection. I renamed the screensaver-cinnamon folder to "-OLD" and replaced it with the xscreensaver folder now renamed to screensaver-cinnamon as per instructions on this forum. It's also been added as a startup application. The xscreensaver works great. It activates after 10min as it should and I see the splash screen come up when I bootup.

After searching the forum, I found that Caffeine may fix my problem. Using the Software Manager tool, I installed Caffeine with hopes that it would disable the screensaver when VLC was playing in full screen mode. Unfortunately, it did not and my screensaver kicked in after 10min. From what I've read there's no settings to change in the new version of Caffeine and I checked Task Manager to show that it is in fact running in the background.

I removed the newer version, downloaded the .deb file from the https://launchpad.net/caffeine site and installed an older version which I was able to add VLC to the applications list. That also did not work.

How does one temporary disable the screensaver when watching videos in full screen in Mint Cinnamon 17? Any suggestions?

Gannet
Level 1
Level 1
Posts: 12
Joined: Mon Aug 25, 2014 2:21 pm

Re: Linux Cinnamon 17 - VLC won't disable screensaver

Post by Gannet » Tue Mar 24, 2015 4:37 pm

I'm running Linux Mint 17.1 with xfce (Ubuntu 14.04) and had a problem with XScreenSaver interrupting my videos. I tried Caffiene from the developers and it worked straight away:

Code: Select all

sudo add-apt-repository ppa:caffeine-developers/ppa
sudo apt-get update
sudo apt-get install caffeine
After that, you just need to run caffeine or stick it in autostart. The current version doesn't have a graphical interface, it now runs invisibly in the background and inhibits the screensaver WHENEVER THE MACHINE IS IN FULL SCREEN MODE. There don't seem to be any options but it certainly does what I want!

User avatar
Ginsu543
Level 4
Level 4
Posts: 450
Joined: Thu Nov 24, 2011 3:15 am
Location: Los Angeles, CA, USA

Re: Linux Cinnamon 17 - VLC won't disable screensaver

Post by Ginsu543 » Wed Mar 25, 2015 1:57 am

redb4umint wrote: How does one temporary disable the screensaver when watching videos in full screen in Mint Cinnamon 17? Any suggestions?
This is not possible to do apart from a third-party program like Caffeine because Cinnamon (like all other DE's) is based on X.org. Because X.org is older technology, it does not register video playback as a registerable event such as a mouse movement or a keyboard click. So, when you play video in fullscreen mode, even though the video is playing, X.org thinks nothing is happening. That's why it kicks on the screensaver. Newer technologies like Wayland or Ubuntu's Mir is supposed to fix this problem inherent in X.org.
Main: Intel Core i7 920 D0 @ 4.0 GHz | Asus P6X58D Premium | 12 GB Mushkin Redline PC3-12800 7-8-7-24 | EVGA GeForce GTX 560 Ti | Mint 17.2 Cinnamon 64 / OS X 10.7.3
Portables: Toshiba Portege R200 | Mint 17.2 Cinnamon 32 / Dell Mini 9 | OS X 10.6.7

niclasc
Level 1
Level 1
Posts: 42
Joined: Tue Jan 26, 2010 8:22 am

Re: Linux Cinnamon 17 - VLC won't disable screensaver

Post by niclasc » Wed Mar 25, 2015 2:58 am

Ginsu543 wrote:
redb4umint wrote: How does one temporary disable the screensaver when watching videos in full screen in Mint Cinnamon 17? Any suggestions?
This is not possible to do apart from a third-party program like Caffeine because Cinnamon (like all other DE's) is based on X.org. Because X.org is older technology, it does not register video playback as a registerable event such as a mouse movement or a keyboard click. So, when you play video in fullscreen mode, even though the video is playing, X.org thinks nothing is happening. That's why it kicks on the screensaver. Newer technologies like Wayland or Ubuntu's Mir is supposed to fix this problem inherent in X.org.
Its crazy that a simple problem like this exists i Linux i 2015. In OSX and Windows this has been working for over 15years or more.
Linux Mint 18.1 x64 Cinnamon, Kernel 4.4.0-53-generic

User avatar
Ginsu543
Level 4
Level 4
Posts: 450
Joined: Thu Nov 24, 2011 3:15 am
Location: Los Angeles, CA, USA

Re: Linux Cinnamon 17 - VLC won't disable screensaver

Post by Ginsu543 » Wed Mar 25, 2015 7:03 pm

niclasc wrote: Its crazy that a simple problem like this exists i Linux i 2015. In OSX and Windows this has been working for over 15years or more.
It's true that X.org is old and having a problem such as this is kinda silly. But X.org is also stable, ubiquitous, and works with all kinds of hardware. That's why I think the urgency hasn't been there to move away from X.org. At the same time, it's not worth overhauling X.org itself to fix the problem because that effort would be better invested in developing new technologies like Wayland or Mir. So, for the sake of stability, we accept the quirks and use a patch like Caffeine to get the functionality we want.
Main: Intel Core i7 920 D0 @ 4.0 GHz | Asus P6X58D Premium | 12 GB Mushkin Redline PC3-12800 7-8-7-24 | EVGA GeForce GTX 560 Ti | Mint 17.2 Cinnamon 64 / OS X 10.7.3
Portables: Toshiba Portege R200 | Mint 17.2 Cinnamon 32 / Dell Mini 9 | OS X 10.6.7

Ceilidh2
Level 4
Level 4
Posts: 281
Joined: Thu Apr 17, 2014 10:29 pm
Location: Thames, New Zealand

Re: Linux Cinnamon 17 - VLC won't disable screensaver

Post by Ceilidh2 » Fri Mar 27, 2015 4:13 pm

Install SMPlayer. Open it. Click Options > Preferences > Video. Tick the box "Disable Screensaver". "Apply".

The feature will function regardless of which player you use, including VLC.

VLC is a cross-platform player that is indifferent to the OS it is running on, and does not care about this kink in Linux. SMPlayer is specificly written for Linux.
"Take it easy, but take it." Woody Guthrie

Post Reply

Return to “Newbie Questions”