Sleep problem after installing Nvidia driver

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
pappfer
Level 2
Level 2
Posts: 72
Joined: Tue Jan 19, 2010 8:35 pm
Contact:

Sleep problem after installing Nvidia driver

Post by pappfer » Fri Jun 06, 2014 3:52 am

Hi,
I'm using Linux Mint 17 and sleep was working fine with the default Nouveau driver, however after I installed the recommended proprietary driver (nvidia-331) I experienced the following after my Thinkpad W530 goes on sleep: when I try to wake up (open up the lid) the screen appears and suddenly disappears again (black screen, the power button blinks) and I have to press the power button to wake it up. So far it was working fine even only after opening the lid.
So it seems like now it has to be waken up twice. :) Why is it happening, and is there a solution for this?

User avatar
Kalyk
Level 5
Level 5
Posts: 771
Joined: Wed Mar 12, 2014 5:29 pm
Location: The Netherlands

Re: Sleep problem after installing Nvidia driver

Post by Kalyk » Mon Jun 09, 2014 3:51 pm

It might be that there is a problem going into sleep modus and the screen was only black because of power settings.
So you open it up and only then it really goes into sleep modus.
You should probably be looking in the logfiles in \var\log to see what for example the pm-powersave log says.
Add (Solved) to the topic-title of the first post when appropriate so others know they might find a solution here.

pappfer
Level 2
Level 2
Posts: 72
Joined: Tue Jan 19, 2010 8:35 pm
Contact:

Re: Sleep problem after installing Nvidia driver

Post by pappfer » Thu Jun 12, 2014 11:17 am

No, that's not the case.
When I close the lid I hear all the hardwer switching off, so it goes to sleep mode indeed.

I just did a sleep / wake up and the same happened: woke up for a second after opening the lid then went to sleep mode again and I had to press the power on button to wake it up.
Here are the last lines of my pm-powersave log:

Code: Select all

/dev/sda:
 setting Advanced Power Management level to 0xfe (254)
 APM_level      = 254
/usr/lib/pm-utils/power.d/95hdparm-apm false: success.

Running hook /usr/lib/pm-utils/power.d/anacron false:
/usr/lib/pm-utils/power.d/anacron false: success.

Running hook /usr/lib/pm-utils/power.d/disable_wol false:
/usr/lib/pm-utils/power.d/disable_wol false: not applicable.

Running hook /usr/lib/pm-utils/power.d/intel-audio-powersave false:
Setting power savings for snd_hda_intel to 0...Done.
/usr/lib/pm-utils/power.d/intel-audio-powersave false: success.

Running hook /usr/lib/pm-utils/power.d/laptop-mode false:
Laptop mode disabled.
/usr/lib/pm-utils/power.d/laptop-mode false: success.

Running hook /usr/lib/pm-utils/power.d/pci_devices false:
Setting Host Bridge 0000:00:00.0 to on
Setting Ethernet device 0000:00:19.0 to on
Setting Audio device 0000:00:1b.0 to on
Setting card reader device 0000:02:00.0 to on
Setting FireWire device 0000:02:00.3 to on
Setting Wireless device 0000:03:00.0 to on
/usr/lib/pm-utils/power.d/pci_devices false: success.

Running hook /usr/lib/pm-utils/power.d/pcie_aspm false:
sh: echo: I/O error
/usr/lib/pm-utils/power.d/pcie_aspm false: success.

Running hook /usr/lib/pm-utils/power.d/sata_alpm false:
Setting SATA ALPM on host0 to max_performance...Done.
Setting SATA ALPM on host1 to max_performance...Done.
Setting SATA ALPM on host2 to max_performance...Done.
Setting SATA ALPM on host3 to max_performance...Done.
Setting SATA ALPM on host4 to max_performance...Done.
Setting SATA ALPM on host5 to max_performance...Done.
/usr/lib/pm-utils/power.d/sata_alpm false: success.

Running hook /usr/lib/pm-utils/power.d/sched-powersave false:
**sched policy powersave OFF
/usr/lib/pm-utils/power.d/sched-powersave false: success.

Running hook /usr/lib/pm-utils/power.d/usb_bluetooth false:
/usr/lib/pm-utils/power.d/usb_bluetooth false: success.

Running hook /usr/lib/pm-utils/power.d/wireless false:
cat: /sys/class/net/wlan0/device/enable: No such file or directory
/usr/lib/pm-utils/power.d/wireless false: success.

Running hook /usr/lib/pm-utils/power.d/xfs_buffer false:
/usr/lib/pm-utils/power.d/xfs_buffer false: not applicable.

Post Reply

Return to “Newbie Questions”