can't download software.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 2
Level 2
Posts: 85
Joined: Thu Jun 05, 2014 2:24 am

can't download software.

Post by whichonespink? »

i can no longer download anything from the software manager. whenever i try i get the message, 'another application is using APT..........................synaptic.
what is APT?

could this have something to do with me downloading mint-meta-mate, as it was fine previously?
Level 3
Level 3
Posts: 100
Joined: Wed Jan 16, 2013 7:49 pm
Location: Zagreb, Croatia

Re: can't download software.

Post by ninomrki »

Did you try restarting?

Also, info on APT:
Home is where the Wi-Fi is.

Registered Linux user #562302
Mute Ant
Level 14
Level 14
Posts: 5130
Joined: Tue Sep 03, 2013 7:45 pm
Location: Norfolk UK

Re: can't download software.

Post by Mute Ant »

APT is one of the programs that fetches and installs software, and only one copy can run. The usual culprit is Update Manager doing an automatic scan of the repository, which blocks Software Manager from using the washroom. Restart is a bit harsh, you can try to find who is using APT, or wait for them to finish, or just log out and back in again.
While you're waiting, read the free novel we sent you. It's a Spanish story about a guy named "manual".
User avatar
Level 18
Level 18
Posts: 8652
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: can't download software.

Post by Flemur »

<I> 'another application is using APT..........................synaptic.</I>

Is that the message - that synaptic is using apt - or is that a message from synaptic?

In a terminal:
$ ps -ef | grep synaptic
$ ps -ef | grep apt
$ ps -ef | grep whatever_the_updater_executable_is_called
should show you if synaptic / apt / the_updater are running.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Post Reply

Return to “Newbie Questions”