Bluetooth issue with Mint 17 MATE?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Bluetooth issue with Mint 17 MATE?

Post by darkstrike »

Hey all,

I've noticed that Bluetooth isn't working properly in Mint 17 for me. It used to work fine in Mint 14.

EDIT - To clarify, Bluetooth DOESN'T work properly in the sense that I CAN pair with devices, but they won't function properly after pairing. My other issue is that when I right-click and turn the Bluetooth adapter off to save battery life, almost all of the right-click menu then becomes grayed out and I am unable to turn the adapter back on until I restart the machine. As mentioned before, it did work fine in Mint 14.

I know Blueman was not installed in Mint 17 by default and I installed it from the Software Manager. Was there something else I missed that I should've also installed...?

Thanks for any help!
Last edited by darkstrike on Mon Jul 14, 2014 9:15 pm, edited 2 times in total.
JeremyB
Level 20
Level 20
Posts: 11771
Joined: Fri Feb 21, 2014 8:17 am

Re: Bluetooth issue with Mint 17 MATE?

Post by JeremyB »

Have you tried this to turn bluetooth on

Code: Select all

rfkill unblock all
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Bluetooth issue with Mint 17 MATE?

Post by darkstrike »

That command makes no difference, sadly. Bluetooth still won't turn back on if I turn it off from the right-click menu until I restart. All the menu options are still grayed out.
Attachments
Workspace 1_001.png
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Bluetooth issue with Mint 17 MATE?

Post by darkstrike »

Just thought I would update this thread...sorry for bringing an older one back and sorry for the double-post, but I now have noticed a new issue for me.

Even if I have Bluetooth turned ON, if I put my computer into Suspend, when I wake it, Bluetooth is disabled as described in my previous posts and I can only get it back once I do a full restart...?

Still not sure what is wrong here. I installed Blueman after I first installed Mint 17 as suggested and Bluetooth hasn't worked properly in this regard ever. It always used to work flawlessly in Mint 14...what's changed?

Also, I've noticed that I had mentioned things pair fine...they do, yes, but nothing will FUNCTION properly once paired!
JeremyB
Level 20
Level 20
Posts: 11771
Joined: Fri Feb 21, 2014 8:17 am

Re: Bluetooth issue with Mint 17 MATE?

Post by JeremyB »

Time to find out what bluetooth device

Code: Select all

lsusb
and what modules are loaded

Code: Select all

lsmod | grep bluetooth
check dmesg for errors

Code: Select all

dmesg | grep -i bluetooth
Should have a look at the host device

Code: Select all

lspci -nnk
I just hope it isn't the Intel 7260 dual band AC as my Toshiba doesn't find the bluetooth in LM at all and Windows can't even load a driver for the wifi
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Bluetooth issue with Mint 17 MATE?

Post by darkstrike »

Well, it's a small Bluetooth v2 adapter I purchased from DealExtreme...the results of those commands are as follows:

lsusb =

Code: Select all

Bus 002 Device 005: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
lsmod | grep bluetooth =

Code: Select all

bluetooth             342263  22 bnep,btusb,rfcomm
dmesg | grep -i bluetooth =
Well, this command literally showed me nothing, so I guess no messages?

lspci -nnk =
I took a glance and I didn't see anything about Bluetooth here....I could be blind and missed it, but there is all the code that was displayed:

Code: Select all

00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GSE Express Memory Controller Hub [8086:27ac] (rev 03)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:0110]
	Kernel driver in use: agpgart-intel
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller [8086:27ae] (rev 03)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:0110]
	Kernel driver in use: i915
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:0110]
00:1b.0 Audio device [0403]: Intel Corporation NM10/ICH7 Family High Definition Audio Controller [8086:27d8] (rev 02)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:0110]
	Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation NM10/ICH7 Family PCI Express Port 1 [8086:27d0] (rev 02)
	Kernel driver in use: pcieport
00:1c.1 PCI bridge [0604]: Intel Corporation NM10/ICH7 Family PCI Express Port 2 [8086:27d2] (rev 02)
	Kernel driver in use: pcieport
00:1d.0 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 [8086:27c8] (rev 02)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:0110]
	Kernel driver in use: uhci_hcd
00:1d.1 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 [8086:27c9] (rev 02)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:0110]
	Kernel driver in use: uhci_hcd
00:1d.2 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 [8086:27ca] (rev 02)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:0110]
	Kernel driver in use: uhci_hcd
00:1d.3 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 [8086:27cb] (rev 02)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:0110]
	Kernel driver in use: uhci_hcd
00:1d.7 USB controller [0c03]: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller [8086:27cc] (rev 02)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:0110]
	Kernel driver in use: ehci-pci
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:0110]
	Kernel driver in use: lpc_ich
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [IDE mode] [8086:27c4] (rev 02)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:0110]
	Kernel driver in use: ata_piix
00:1f.3 SMBus [0c05]: Intel Corporation NM10/ICH7 Family SMBus Controller [8086:27da] (rev 02)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:0110]
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:0110]
	Kernel driver in use: r8169
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8187SE Wireless LAN Controller [10ec:8199] (rev 22)
	Subsystem: Micro-Star International Co., Ltd. [MSI] MN54G2 / MS-6894 Wireless Mini PCIe Card [1462:6894]
	Kernel driver in use: r8180
User avatar
WharfRat
Level 21
Level 21
Posts: 13909
Joined: Thu Apr 07, 2011 8:15 pm

Re: Bluetooth issue with Mint 17 MATE?

Post by WharfRat »

darkstrike,

I've never bothered with bluetooth, but I stumbled upon this http://linuxmint.com/rel_qiana_mate.php

It mentions that bluetooth support is not installed by default. You have to add it.

Good luck :wink:
ImageImage
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Bluetooth issue with Mint 17 MATE?

Post by darkstrike »

Hi WharfRat, yes, I'm aware of that, and followed those instructions when I first installed Mint 17....clearly it hasn't helped though as it doesn't work properly! :(
JeremyB
Level 20
Level 20
Posts: 11771
Joined: Fri Feb 21, 2014 8:17 am

Re: Bluetooth issue with Mint 17 MATE?

Post by JeremyB »

Nothing in dmesg is strange as I usually have some bluetooth results even on laptops without bluetooth, however there is a bug report on your bluetooth chipset
https://bugs.launchpad.net/ubuntu/+sour ... ug/1245150
And it appears that kernel 3.14 should fix the issue

Code: Select all

uname -a
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Bluetooth issue with Mint 17 MATE?

Post by darkstrike »

Yes, I have kernel 3.13.0-24-generic...

Pardon my ignorance, but if I need to update the kernel, doesn't that I mean I will have to completely reinstall Mint? :(

I've never done it before, so I don't know the commands or anything to do so and I just synchronized 80gbs of stuff to this machine over the network (unfortunately to the same partition the OS is on), so having to format again would be a bit of pain...
User avatar
PatH57
Level 13
Level 13
Posts: 4572
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Bluetooth issue with Mint 17 MATE?

Post by PatH57 »

Hi,

in fact you replace the kernel (the old one is still there and if you need to you can revert back)

Here is an easy tuto to do this. It uses the latest 3.14 kernel, just make sure you select the right one (32 or 64 bit)
http://www.yourownlinux.com/2014/07/how ... linux.html
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Bluetooth issue with Mint 17 MATE?

Post by darkstrike »

Thanks for the info PatH57! I will definitely be trying this once I get home - however, I found very similar instructions to yours that show how to update to the latest stable kernel. I'm sure 3.14.12 is fine, but I am going to try updating to 3.14.5 as explained here:

http://www.sysads.co.uk/2014/06/install ... x-mint-17/

I will update this thread tonight to let you know how I make out and whether or not it sorts out my Bluetooth issue! :)

Out of random curiosity - Is there any way to have Mint install Kernel updates in a way that is akin to installing software / package updates? I.E. notify me when Stable updates are available and let me choose whether to install them - that sort of thing?
User avatar
PatH57
Level 13
Level 13
Posts: 4572
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Bluetooth issue with Mint 17 MATE?

Post by PatH57 »

Hi,

hope it will work.
Mintupdate will give you the recommended update but not the latest. It does however work for 90% of the people.
If you want the latest you can subscribe to an rss feed
https://www.kernel.org/feeds/kdist.xml

word of advice don't get under the hood to often, once it works don't touch it :wink:
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Bluetooth issue with Mint 17 MATE?

Post by darkstrike »

I try not to have to do things like this unless I have to....just got home and restarted, booted fine and uname -a is showing the right kernel version......except now my WiFi doesn't work and Bluetooth is still doing the exact same thing it was before! :(

WiFi IS turned on...but wlan0 isn't showing up in the list of interfaces anymore? :?
User avatar
PatH57
Level 13
Level 13
Posts: 4572
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Bluetooth issue with Mint 17 MATE?

Post by PatH57 »

Hi,

well we had to try it.
Could you give the output of

Code: Select all

inxi -Fxz
lspci
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Bluetooth issue with Mint 17 MATE?

Post by darkstrike »

That command does list my WiFi card, it just seems that it's not loading somehow maybe?

Output as follows:

Code: Select all

System:    Host: Mini-Darkstrike Kernel: 3.14.5-031405-generic i686 (32 bit, gcc: 4.6.3) 
           Desktop: N/A Distro: Linux Mint 17 Qiana
Machine:   Mobo: MICRO-STAR model: U90/U100 version: Ver.001 Bios: American Megatrends version: 4.6.3 date: 12/01/2009
CPU:       Single core Intel Atom CPU N270 (-HT-) cache: 512 KB flags: (nx sse sse2 sse3 ssse3) bmips: 3199.72 
           Clock Speeds: 1: 1066.00 MHz 2: 799.00 MHz
Graphics:  Card: Intel Mobile 945GSE Express Integrated Graphics Controller bus-ID: 00:02.0 
           X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x600@60.0hz 
           GLX Renderer: Mesa DRI Intel 945GME x86/MMX/SSE2 GLX Version: 1.4 Mesa 10.1.0 Direct Rendering: Yes
Audio:     Card: Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture ver: k3.14.5-031405-generic
Network:   Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller 
           driver: r8169 ver: 2.3LK-NAPI port: c000 bus-ID: 01:00.0
           IF: eth0 state: down mac: <filter>
           Card-2: Realtek RTL8187SE Wireless LAN Controller port: b000 bus-ID: 02:00.0
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 160.0GB (25.7% used) 1: id: /dev/sda model: WDC_WD1600BEVT size: 160.0GB 
Partition: ID: / size: 145G used: 39G (28%) fs: ext4 ID: swap-1 size: 2.13GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 150 Uptime: 23 min Memory: 302.8/2009.1MB Runlevel: 2 Gcc sys: 4.8.2 Client: Shell inxi: 1.8.4 
User avatar
PatH57
Level 13
Level 13
Posts: 4572
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Bluetooth issue with Mint 17 MATE?

Post by PatH57 »

do you see anything in the driver manager (control center)
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Bluetooth issue with Mint 17 MATE?

Post by darkstrike »

The Driver Manager is empty - nothing there?
User avatar
PatH57
Level 13
Level 13
Posts: 4572
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Bluetooth issue with Mint 17 MATE?

Post by PatH57 »

ok try this

Code: Select all

sudo modprobe r8187se
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
User avatar
darkstrike
Level 5
Level 5
Posts: 578
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Bluetooth issue with Mint 17 MATE?

Post by darkstrike »

Results of sudo modprobe r8187se:

Code: Select all

modprobe: FATAL: Module r8187se not found.
Post Reply

Return to “Newbie Questions”