Page 1 of 2

Hard Drive not recognized

Posted: Sun Jul 20, 2014 3:59 pm
by Polar Bear
Yes.... I'm a total newb to Linux. After years of saying "I'm fed up with YOU KNOW WHO, i finally installed Linux on my PC. What a treat, or so I thought. I downloaded, Burned a DVD and installed Linux Mint 17 Mate 64-bit. Yeaaa... it's different, but the basic use of the Linux window is similar. the question I have is this morning when i logged in, my second hard drive was not showing up on my computer. When I re-booted I was asked for the password and was notified that it mounted. But nothing appears on "Computer", "File system" or "Devices". Any insight would be appreciated.

Re: Hard Drive not recognized

Posted: Sun Jul 20, 2014 5:03 pm
by WharfRat
Look in /media/yourname/

Also try opening a terminal and entering

Code: Select all

findmnt
or simply

Code: Select all

mount
Good luck :wink:

Re: Hard Drive not recognized

Posted: Sun Jul 20, 2014 10:39 pm
by Polar Bear
Thanks WharfRat. I ran findmnt and mount... I don't understand output. I don't see anything that pertains to either of my drives.
Nothing shown in media/yourname/.

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 12:23 am
by WharfRat
Unless you explicitly mount the disk's partition it will not show with mount or findmnt. However if you opened it in the file manager then it will show.

Can you paste back the output of

Code: Select all

sudo blkid
and

Code: Select all

mount
to have a look at what you're working with :?:

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 7:16 pm
by Polar Bear
Output of sudo blkid

/dev/sda1: UUID="e431761d-8189-480b-a85b-8333cbab5a8a" TYPE="ext2"
/dev/sda5: UUID="9b2eb647-817e-4920-829d-dc607b74ef13" TYPE="crypto_LUKS"
/dev/mapper/sda5_crypt: UUID="qaxTNx-cokF-Ibig-G9Ab-DdcQ-Fsxh-Y5ZWl5" TYPE="LVM2_member"
/dev/mapper/mint--vg-root: UUID="a3c4f73d-e175-4687-a9a8-7ba7e6f0a9bf" TYPE="ext4"
/dev/mapper/mint--vg-swap_1: UUID="47f7ff7d-9ba0-495c-95cf-2adad6f4e97f" TYPE="swap"

Output of mount

/dev/mapper/mint--vg-root on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
none on /sys/fs/pstore type pstore (rw)
/dev/sda1 on /boot type ext2 (rw)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=merritt)

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 7:27 pm
by Spearmint2
Polar Bear wrote:Yes.... I'm a total newb to Linux. After years of saying "I'm fed up with YOU KNOW WHO, i finally installed Linux on my PC. What a treat, or so I thought. I downloaded, Burned a DVD and installed Linux Mint 17 Mate 64-bit. Yeaaa... it's different, but the basic use of the Linux window is similar. the question I have is this morning when i logged in, my second hard drive was not showing up on my computer. When I re-booted I was asked for the password and was notified that it mounted. But nothing appears on "Computer", "File system" or "Devices". Any insight would be appreciated.
Why do you think you have two hard drives? Was it because you saw two of them when using windows? How large was each "drive"? Maybe instead you had one drive that was divided into two partitions to which hard drive letters were assigned?

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 7:31 pm
by Polar Bear
I have two physical hard drives; a Samsung SSD 840 EVO 500GB is used for OS and programs. The second hard drive is a Western Digital 1TB used for files only.

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 7:32 pm
by PatH57
crypto will be hard to explain :lol: no offense meant was about to go to bed but will stay a while for the next episode

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 7:35 pm
by WharfRat
Polar Bear,

I think I have to tell you some bad news. You don't have a second hard drive and I don't think you ever did. If in windows the disk manager showed a D: then it was a partition on your single hard drive. It's a mistake other users have made.

For a quick explanation, linux looks at block devices much differently, Your first hard drive will be a device called /dev/sda as you can see with the output of blkid and mount. The first partition, which windows depicts as C:, will be /dev/sda1 in linux. Subsequent partitions on the drive would be /dev/sda2, /dev/sda3 etc. Linux's sda2 would be the D: in windows. The second physical hard drive would be /dev/sdb.

Also you chose the encrypted installation which utilizes the logical volume manager and uses the entire disk. If you did have another disk it would not have been touched and you would see /deb/sdb partitions sb1 etc.

I hope you didn't have anything important on that partition or, if you did, you have a backup of it :(

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 7:39 pm
by WharfRat
Polar Bear wrote:I have two physical hard drives; a Samsung SSD 840 EVO 500GB is used for OS and programs. The second hard drive is a Western Digital 1TB used for files only.
Well then, what I just answered is totally incorrect if you do have two physical drives.

Was the second drive partitioned and formatted :?: Is so what filesystem :?:

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 7:45 pm
by Spearmint2

Code: Select all

df; cat /etc/fstab;
run and post

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 7:54 pm
by PatH57
just to list all drives please provide the output of

Code: Select all

sudo lshw -class disk

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 7:59 pm
by Polar Bear
It was originally formatted but not partitioned with Windows Vista 64-bit. It is only used for data storage. I used Truecrypt for security and password protection.

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 8:01 pm
by PatH57
and you installed truecrypt on Mint?

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 8:03 pm
by Polar Bear
Output for sudo lshw -class disk

*-disk
description: ATA Disk
product: Samsung SSD 840
physical id: 0.0.0
bus info: scsi@1:0.0.0
logical name: /dev/sda
version: EXT0
serial: S1DHNSAF545775X
size: 465GiB (500GB)
capabilities: partitioned partitioned:dos
configuration: ansiversion=5 sectorsize=512 signature=00090793
*-cdrom
description: DVD-RAM writer
product: DVDR PX-806SA
vendor: PLEXTOR
physical id: 0.1.0
bus info: scsi@1:0.1.0
logical name: /dev/cdrom
logical name: /dev/sr0
version: 1.06
capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
configuration: ansiversion=5 status=nodisc
*-disk:0
description: SCSI Disk
product: CF PRO Reader
vendor: PRO-55U
physical id: 0.0.0
bus info: scsi@6:0.0.0
logical name: /dev/sdb
version: 9745
capabilities: removable
configuration: sectorsize=512
*-medium
physical id: 0
logical name: /dev/sdb
*-disk:1
description: SCSI Disk
product: SD PRO Reader
vendor: PRO-55U
physical id: 0.0.1
bus info: scsi@6:0.0.1
logical name: /dev/sdc
version: 9745
capabilities: removable
configuration: sectorsize=512
*-medium
physical id: 0
logical name: /dev/sdc
*-disk:2
description: SCSI Disk
product: XD PRO Reader
vendor: PRO-55U
physical id: 0.0.2
bus info: scsi@6:0.0.2
logical name: /dev/sdd
version: 9745
capabilities: removable
configuration: sectorsize=512
*-medium
physical id: 0
logical name: /dev/sdd
*-disk:3
description: SCSI Disk
product: MS PRO Reader
vendor: PRO-55U
physical id: 0.0.3
bus info: scsi@6:0.0.3
logical name: /dev/sde
version: 9745
capabilities: removable
configuration: sectorsize=512
*-medium
physical id: 0
logical name: /dev/sde
*-disk:4
description: SCSI Disk
product: mSD PRO Reader
vendor: PRO-55U
physical id: 0.0.4
bus info: scsi@6:0.0.4
logical name: /dev/sdf
version: 9745
capabilities: removable
configuration: sectorsize=512
*-medium
physical id: 0
logical name: /dev/sdf

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 8:09 pm
by Polar Bear
I did not install Truecrypt on Mint. When I installed Mint 17 i disconnected the WD 1TB HHD. I connected it about a week after installing Mint and the crypt program for mint asked for a passphrase... so I entered a passphrase and the drive functioned properly for 2-3 weeks.

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 8:10 pm
by PatH57
well the drive is not recognized as onboard, it would not be an external drive or a caddie drive?

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 8:13 pm
by Spearmint2
Polar Bear wrote:It was originally formatted but not partitioned with Windows Vista 64-bit. It is only used for data storage. I used Truecrypt for security and password protection.
Partitions come before formats. What do you format other than a partition? Did you use the windows or linux truecrypt version?

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 8:15 pm
by Polar Bear
output for df; cat /etc/fstab;

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/mapper/mint--vg-root 474109104 6572180 443430532 2% /
none 4 0 4 0% /sys/fs/cgroup
udev 3035508 8 3035500 1% /dev
tmpfs 610244 1696 608548 1% /run
none 5120 0 5120 0% /run/lock
none 3051216 360 3050856 1% /run/shm
none 102400 28 102372 1% /run/user
/dev/sda1 240972 45973 182558 21% /boot
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/mapper/mint--vg-root / ext4 errors=remount-ro 0 1
# /boot was on /dev/sda1 during installation
UUID=e431761d-8189-480b-a85b-8333cbab5a8a /boot ext2 defaults 0 2
/dev/mapper/mint--vg-swap_1 none swap sw 0 0

Re: Hard Drive not recognized

Posted: Mon Jul 21, 2014 8:22 pm
by WharfRat
Polar Bear,

paste back the output of:

Code: Select all

udevadm trigger --action=change --verbose --dry-run --subsystem-match=block|grep sd[a-c]