how to stop desktop icons from auto-arranging<solved>

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
crassius
Level 2
Level 2
Posts: 80
Joined: Sun Jul 27, 2014 10:35 pm

how to stop desktop icons from auto-arranging<solved>

Post by crassius » Mon Jul 28, 2014 3:02 pm

I've got an updated ver of xfce - seems there are no settings for many things here.
Tried dconf changes in nautilus, but they have no effect on desktop fonts or arrangement.
Tried making my own copy of the theme and its gtkrc and could change scroll-bar size, but nothing there for desktop.

Is it me, or are there no settings for any of these things?
Last edited by crassius on Sun Jun 21, 2015 11:23 am, edited 1 time in total.

User avatar
gtsfer
Level 7
Level 7
Posts: 1925
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: how to stop desktop icons from auto-arranging

Post by gtsfer » Mon Jul 28, 2014 4:57 pm

Unless I'm completely off base here (I'm not running XFCE) you should be able to right-click on your desktop and uncheck "keep aligned". What version of XFCE are you running?
"There is no gravity, the earth sucks." - Issac Newton @ 75
KDE & Cinnamon 18.1 & Win 10 - ASUS M5A99FX PRO MB, AMD FX-8370 Octo-Core CPU, 16GB RAM, AMD Radeon R7 240

crassius
Level 2
Level 2
Posts: 80
Joined: Sun Jul 27, 2014 10:35 pm

Re: how to stop desktop icons from auto-arranging

Post by crassius » Mon Jul 28, 2014 5:03 pm

it's 17 & I had it update everything 2 days ago

right-clicking desktop does not give that option

EDIT: also no options for any grid settings either

ajgreeny
Level 4
Level 4
Posts: 314
Joined: Mon Nov 19, 2007 3:27 pm

Re: how to stop desktop icons from auto-arranging

Post by ajgreeny » Mon Jul 28, 2014 5:14 pm

I think this is a problem that has been around for some time; it occasionally happens on my Xubuntu 12.04 with an updated xfce 4.10, but it also happened on xfce 4.8.

I have never been able to figure out what it is that makes it happen; is it an update of some specific package? I don't think so, but I may be wrong. Whatever causes it I just sigh loudly and re-arrange things as I want, made easier by keeping a screenshot to show me where evrything should be.

User avatar
DrHu
Level 17
Level 17
Posts: 7541
Joined: Wed Jun 17, 2009 8:20 pm

Re: how to stop desktop icons from auto-arranging

Post by DrHu » Mon Jul 28, 2014 5:42 pm

http://forum.xfce.org/viewtopic.php?id=6637
--user post 3 and 4..screen resolution problem and a few ideas + bug for work-around to issue..

crassius
Level 2
Level 2
Posts: 80
Joined: Sun Jul 27, 2014 10:35 pm

Re: how to stop desktop icons from auto-arranging

Post by crassius » Mon Jul 28, 2014 5:43 pm

don't really have time to reset every boot

not familiar with what the screen icons mean & can't read the screen font, so really need them to stay where I put them

crassius
Level 2
Level 2
Posts: 80
Joined: Sun Jul 27, 2014 10:35 pm

Re: how to stop desktop icons from auto-arranging

Post by crassius » Mon Jul 28, 2014 5:54 pm

looks like our posts crossed at same time

went to that link (after several tries because this board thinks my seamonkey on winME is somehow related to spam & refused to display the link & I had to use a diff machine to get back in)

not sure if screen res changes on startup as it is always just a cold boot

seems if it were that bug, I'd still have settings for grid and auto - align, but I have nothing that even looks like that in the settings tools or the gtkrc or thru dconf

User avatar
gtsfer
Level 7
Level 7
Posts: 1925
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: how to stop desktop icons from auto-arranging

Post by gtsfer » Mon Jul 28, 2014 7:09 pm

I may be onto something, or this could be a wild goose chase. I booted Xfce from DVD and played around a bit. From Settings -> Settings Editor there is a desktop-icons entry. If I can figure out exactly what item to add here it may do what you are looking for. I'll have to look at the Xconf options documentation now and see if there is an option that will work. Seems like there has to be a way, so I'll get back to you on this if I find it.
XfceSettingsEditor.png
"There is no gravity, the earth sucks." - Issac Newton @ 75
KDE & Cinnamon 18.1 & Win 10 - ASUS M5A99FX PRO MB, AMD FX-8370 Octo-Core CPU, 16GB RAM, AMD Radeon R7 240

crassius
Level 2
Level 2
Posts: 80
Joined: Sun Jul 27, 2014 10:35 pm

Re: how to stop desktop icons from auto-arranging

Post by crassius » Mon Jul 28, 2014 7:53 pm

thanx, I'll have to look to see if I have xconf editor & get it if not

crassius
Level 2
Level 2
Posts: 80
Joined: Sun Jul 27, 2014 10:35 pm

Re: how to stop desktop icons from auto-arranging

Post by crassius » Mon Jul 28, 2014 8:22 pm

some hope with that editor - was able to increase size of desktop font, but still need to find a way to use a more readable font

User avatar
palo
Level 4
Level 4
Posts: 459
Joined: Mon Jun 25, 2012 7:28 am
Location: Walking on sunshine

Re: how to stop desktop icons from auto-arranging

Post by palo » Mon Jul 28, 2014 11:45 pm

crassius> I would be very surprised if you can find a way to take control away from that menacing grid. I tried in vain following every suggestion Google had to offer. What will work however is installing pcmanfm (I used Synaptic) and have it take control of the desktop thereby letting you have control. It is run with the command

Code: Select all

pcmanfm --desktop
and it is easy to set up to run at startup by default so your icons stay where you tell them. There is a shot of my Qiana Xfce with it running here.

You can easily set font and size (I set mine to 0 so it would be invisible), you can switch to a grid if you like, dang you can even have a different wallpaper for each desktop if you like - try doing that with xfdestop. Anyway these dialogs might pique your interest.

http://i.minus.com/iGq5M4MiJ5fQM.png

ajgreeny
Level 4
Level 4
Posts: 314
Joined: Mon Nov 19, 2007 3:27 pm

Re: how to stop desktop icons from auto-arranging

Post by ajgreeny » Tue Jul 29, 2014 10:55 am

I hasve had a good look and search but I can find no way to stick the desktop icons to the same spot with xconf-editor, and all the changes it can make are also changable in other ways, eg by using Settings-manager->Appearance and making changes there.

I found the icons to move most often were the system icons for home, filesystem and wastebasket which you can choose from the options in the Icons tab of desktop-settings, so I no longer use those three in that way but have set my own launchers with the commands
thunar /home/username/ for my home
thunar / for the filesystem and
thunar Trash:/// for the wastebasket
and those three now seem to stay put much better.

Go figure; I can't.

User avatar
gtsfer
Level 7
Level 7
Posts: 1925
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: how to stop desktop icons from auto-arranging

Post by gtsfer » Tue Jul 29, 2014 11:20 am

I looked at my Xorg settings in LMDE (via dconf, it's like "Settings Editor" in Xfce) and haven't found the entries for how the icons are managed yet. This may be tied in to the mintX theme that LMDE is using. Xfce uses it's own themes of course and it's just completely different in this respect. I'm still looking for Xorg settings that might accomplish not auto-arranging these icons. It seems like there should be a way, via settings or via command line to toggle this on of off.

In some other desktop environments it's so easy, just right-click and toggle "keep aligned" item.
"There is no gravity, the earth sucks." - Issac Newton @ 75
KDE & Cinnamon 18.1 & Win 10 - ASUS M5A99FX PRO MB, AMD FX-8370 Octo-Core CPU, 16GB RAM, AMD Radeon R7 240

User avatar
gold_finger
Level 9
Level 9
Posts: 2886
Joined: Mon Mar 11, 2013 11:39 pm

Re: how to stop desktop icons from auto-arranging

Post by gold_finger » Tue Jul 29, 2014 11:46 am

Have bookmarked this thread because I too have tried in vain solve this. So far, no luck.
palo wrote:What will work however is installing pcmanfm.... There is a shot of my Qiana Xfce with it running here.
That is very cool desktop!

palo wrote:dang you can even have a different wallpaper for each desktop if you like - try doing that with xfdestop.
That's easy to do now in latest Xfce.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.

crassius
Level 2
Level 2
Posts: 80
Joined: Sun Jul 27, 2014 10:35 pm

Re: how to stop desktop icons from auto-arranging

Post by crassius » Tue Jul 29, 2014 11:51 am

palo> thanx, pcmanfm may be just what is needed - will try that as soon as RL & sink-plumbing probs are out of the way :)

will mark this solved if it works

User avatar
palo
Level 4
Level 4
Posts: 459
Joined: Mon Jun 25, 2012 7:28 am
Location: Walking on sunshine

Re: how to stop desktop icons from auto-arranging

Post by palo » Tue Jul 29, 2014 2:44 pm

gold_finger wrote: That is very cool desktop!

palo wrote:dang you can even have a different wallpaper for each desktop if you like - try doing that with xfdestop.
That's easy to do now in latest Xfce.
Tks.

I was unaware that this could be done with the latest Xfce. Can you elaborate? I'm sure some would be interested.

User avatar
gtsfer
Level 7
Level 7
Posts: 1925
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: how to stop desktop icons from auto-arranging

Post by gtsfer » Tue Jul 29, 2014 4:02 pm

I wish I could do this different backgrounds thing in LMDE. There's actually a post on different desktop backgrounds that Spearmint2 started. http://forums.linuxmint.com/viewtopic.php?f=90&t=172564. Some distros/DEs make it easy. But not all of them can do it.
"There is no gravity, the earth sucks." - Issac Newton @ 75
KDE & Cinnamon 18.1 & Win 10 - ASUS M5A99FX PRO MB, AMD FX-8370 Octo-Core CPU, 16GB RAM, AMD Radeon R7 240

User avatar
gold_finger
Level 9
Level 9
Posts: 2886
Joined: Mon Mar 11, 2013 11:39 pm

Re: how to stop desktop icons from auto-arranging

Post by gold_finger » Tue Jul 29, 2014 5:37 pm

palo wrote:I was unaware that this could be done with the latest Xfce. Can you elaborate? I'm sure some would be interested.
This is what is shown on Mint Xfce 17 now when you open Desktop Settings:

http://ibin.co/1V1ql6IJ1IS5

Just uncheck the box next to "Apply to all workspaces"; then move the window to a workspace and select picture you want. Move to next workspace, pick another one, etc.

Another change in new Xfce is easy setup for dual-monitors. See here if you want more in-depth explanation with screenshots (different distro, same Xfce).


P.s. I installed those Sphere icons you have on your desktop screenshot Palo -- very nice! If you remember, where did you find that wallpaper in the screenshot?
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.

User avatar
palo
Level 4
Level 4
Posts: 459
Joined: Mon Jun 25, 2012 7:28 am
Location: Walking on sunshine

Re: how to stop desktop icons from auto-arranging

Post by palo » Tue Jul 29, 2014 6:04 pm

Thanks for the heads-up gold_finger-I will check it out. Not to sure which wall I grabbed (adjusted perspective a bit in GIMP) but I followed the tip given here by RytronII.

crassius
Level 2
Level 2
Posts: 80
Joined: Sun Jul 27, 2014 10:35 pm

Re: how to stop desktop icons from auto-arranging

Post by crassius » Sun Aug 03, 2014 3:08 pm

well, plumbing probs fixed, but I'm too old to ever do that again : (

tried installing pcmanfm - got following:

Code: Select all

** (pcmanfm:2373): WARNING **: terminal x-terminal-emulator isn't known, consider report it to LibFM developers

** (pcmanfm:2373): WARNING **: modules directory is not accessible

** (pcmanfm:2373): WARNING **: modules directory is not accessible
ex
will look into this and see what I can do

Post Reply

Return to “Newbie Questions”