How can I use my Canon P-215 scanner on Linux Mint?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
VanessaTL
Level 4
Level 4
Posts: 222
Joined: Sat Oct 13, 2012 1:56 pm

Re: How can I use my Canon P-215 scanner on Linux Mint?

Post by VanessaTL »

Spearmint2 wrote:If you can find the network IP address for the printer from your router, or the printer test page should have it on there, use the Printers program to set one up pointing to that IP address and then try.

You can open a browser and put in this loopback address.
http://127.0.0.1:631/help/options.html#PRINTER

Instructions there say to put this in terminal and run, should find the printer. lpstat -p -d
I ran "lpstat -p -d" in terminal. It listed my Brother monochrome printer (whIch I have been using without problem), but it still does not show my Canon SCANNER.
User avatar
Spearmint2
Level 16
Level 16
Posts: 6892
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: How can I use my Canon P-215 scanner on Linux Mint?

Post by Spearmint2 »

VanessaTL wrote:
Spearmint2 wrote:If you can find the network IP address for the printer from your router, or the printer test page should have it on there, use the Printers program to set one up pointing to that IP address and then try.

You can open a browser and put in this loopback address.
http://127.0.0.1:631/help/options.html#PRINTER

Instructions there say to put this in terminal and run, should find the printer. lpstat -p -d
I ran "lpstat -p -d" in terminal. It listed my Brother monochrome printer (whIch I have been using without problem), but it still does not show my Canon SCANNER.

A scanner is not a printer, even if it's attached to the printer. You need to run xsane.

Code: Select all

xsane
or use simple scan

Code: Select all

simple-scan
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
VanessaTL
Level 4
Level 4
Posts: 222
Joined: Sat Oct 13, 2012 1:56 pm

Re: How can I use my Canon P-215 scanner on Linux Mint?

Post by VanessaTL »

Spearmint2 wrote:A scanner is not a printer, even if it's attached to the printer. You need to run xsane.
i was simply following your instructions.
Spearmint2 wrote:

Code: Select all

xsane
or use simple scan

Code: Select all

simple-scan
I've tried both xsane and simple-scan. Neither detects my scanner.
User avatar
Spearmint2
Level 16
Level 16
Posts: 6892
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: How can I use my Canon P-215 scanner on Linux Mint?

Post by Spearmint2 »

Are you using 64 bit Mint? There may be only 32 bit drivers for it. I thought this was already included in the libsane package.

One person's adventure with a Canon.
http://lowerstrata.blogspot.com/2010/07 ... linux.html

A list of supported scanners and the package you need.

http://www.sane-project.org/lists/sane- ... l#SCANNERS
http://www.sane-project.org/lists/sane- ... ml#Z-CANON
http://www.sane-project.org/man/sane-canon_dr.5.html

Can obtain what is likely the 32 bit files needed here.
http://manpages.ubuntu.com/manpages/luc ... _dr.5.html

NAME

sane-canon_dr - SANE backend for Canon DR-series scanners

DESCRIPTION

The sane-canon_dr library implements a SANE (Scanner Access Now Easy)
backend which provides access to some Canon DR-series scanners.

This document describes backend version 26, which shipped with SANE
1.0.20.

SUPPORTED HARDWARE

This version has only been tested with a few scanner models. Please see
http://www.sane-project.org/sane-supported-devices.html for a more
recent list.

This backend may support other Canon scanners. The best way to
determine level of support is to test the scanner directly, or to
collect a trace of the windows driver in action. Please contact the
author for help or with test results.



Included in this package, check it's file list.
https://www.archlinux.org/packages/extr ... ane/files/
https://www.archlinux.org/packages/extra/x86_64/sane/

order just the one you need? Probably needs to be compiled.
http://www.filewatcher.com/m/sane-canon ... 075-0.html

can put this in URL of browser and read.

Code: Select all

file:///usr/share/sane/xsane/doc/sane-xsane-doc.html
You can search Debian for a deb file to download, that's what you'd want, all the others I saw were for Redhat, the rpm packages.

https://packages.debian.org/sid/libsane
https://packages.debian.org/sid/i386/libsane/download for AMD64 (64 bit)
https://packages.debian.org/sid/i386/libsane/download for x86 (32 bit)

The way that works is you download the package needed, and then open the Package Manager program, go to File, then to Add Downloaded Package. It seems this should have the backend you are looking for, but it's only a bit newer than the libsane package already offered in the Package Manager.

These are the ones included for canon in that package.

Code: Select all

/usr/lib/x86_64-linux-gnu/sane/libsane-canon.la
/usr/lib/x86_64-linux-gnu/sane/libsane-canon.so.1
/usr/lib/x86_64-linux-gnu/sane/libsane-canon.so.1.0.24
/usr/lib/x86_64-linux-gnu/sane/libsane-canon630u.la
/usr/lib/x86_64-linux-gnu/sane/libsane-canon630u.so.1
/usr/lib/x86_64-linux-gnu/sane/libsane-canon630u.so.1.0.24
/usr/lib/x86_64-linux-gnu/sane/libsane-canon_dr.la
/usr/lib/x86_64-linux-gnu/sane/libsane-canon_dr.so.1
/usr/lib/x86_64-linux-gnu/sane/libsane-canon_dr.so.1.0.24
/usr/lib/x86_64-linux-gnu/sane/libsane-canon_pp.la
/usr/lib/x86_64-linux-gnu/sane/libsane-canon_pp.so.1
/usr/lib/x86_64-linux-gnu/sane/libsane-canon_pp.so.1.0.24
You can read about the libsane by running this in terminal

Code: Select all

aptitude show libsane
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
User avatar
Spearmint2
Level 16
Level 16
Posts: 6892
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: How can I use my Canon P-215 scanner on Linux Mint?

Post by Spearmint2 »

I looked at Canon. They have a zip file there.

http://www.usa.canon.com/cusa/support/c ... ndSoftware

searched on P-215 and found it easy enough. Detected my Linux and offered the file 215LINUX_V10.ZIP for download. I downloaded, extracted the readme file.

http://glenburniemd.net/Linux/Canon_P-215.pdf

Noticed this part, you are required to remove all other canon drivers for this to work.

The SANE driver for the P-215, and other
SANE drivers which we have released,
CANNOT co-exist on the same PC


You will want to install the .deb package that's in it.

another possible solution. Make sure your user is part of the necessary groups
http://www.linuxquestions.org/questions ... 175516289/
Last edited by Spearmint2 on Wed May 06, 2015 11:57 pm, edited 1 time in total.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: How can I use my Canon P-215 scanner on Linux Mint?

Post by GregE »

Try the free demo of this program and see what happens. VueScan uses it's own drivers. I have issues with my Canon scanner (different one) on machines with Intel USB3 chips. I ended up just buying VueScan as I need my scanner.

http://www.hamrick.com/

I would also un-install all the drivers you have tried already and start again
VanessaTL
Level 4
Level 4
Posts: 222
Joined: Sat Oct 13, 2012 1:56 pm

Re: How can I use my Canon P-215 scanner on Linux Mint?

Post by VanessaTL »

Hi, GregE.
My Canon P-215 scanner is not in the list of Canon scanners that Vuescan works with (http://www.hamrick.com/vuescan/canon.html).

Hmmmm... I should probably just give up on this scanner and get a Brother one. A Google search for [linux compatible scanners] has Brother very high on the list of results.
GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: How can I use my Canon P-215 scanner on Linux Mint?

Post by GregE »

VanessaTL wrote:Hi, GregE.
My Canon P-215 scanner is not in the list of Canon scanners that Vuescan works with (http://www.hamrick.com/vuescan/canon.html).

Hmmmm... I should probably just give up on this scanner and get a Brother one. A Google search for [linux compatible scanners] has Brother very high on the list of results.
Did you just try it anyway? It is a free download and it might just recognise it as one of the others.

HP have great Linux support through HPLIP, so worth a look as well.
VanessaTL
Level 4
Level 4
Posts: 222
Joined: Sat Oct 13, 2012 1:56 pm

Re: How can I use my Canon P-215 scanner on Linux Mint?

Post by VanessaTL »

GregE wrote:
VanessaTL wrote:Hi, GregE.
My Canon P-215 scanner is not in the list of Canon scanners that Vuescan works with (http://www.hamrick.com/vuescan/canon.html).

Hmmmm... I should probably just give up on this scanner and get a Brother one. A Google search for [linux compatible scanners] has Brother very high on the list of results.
Did you just try it anyway? It is a free download and it might just recognise it as one of the others.

HP have great Linux support through HPLIP, so worth a look as well.
Yes, I did try vuescan. It doesn't work.
VanessaTL
Level 4
Level 4
Posts: 222
Joined: Sat Oct 13, 2012 1:56 pm

Re: How can I use my Canon P-215 scanner on Linux Mint?

Post by VanessaTL »

Hello everybody.
Just a quick update from OP. :)

I think I'll just go buy some Brother ADS series document scanner. From what I've read online, Linux users have a pain-free time with Brother scanners. I don't want to spend much time getting things to work. I just want them to work. I love you, Brother! :D :D
VanessaTL
Level 4
Level 4
Posts: 222
Joined: Sat Oct 13, 2012 1:56 pm

UPDATE: I've sold my Canon P-215

Post by VanessaTL »

Hello everyone. Just a quick update. I sold my Canon P-215. I and buyer are both happy.
User avatar
Spearmint2
Level 16
Level 16
Posts: 6892
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: UPDATE: I've sold my Canon P-215

Post by Spearmint2 »

VanessaTL wrote:Hello everyone. Just a quick update. I sold my Canon P-215. I and buyer are both happy.
Got something that's working now?
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
VanessaTL
Level 4
Level 4
Posts: 222
Joined: Sat Oct 13, 2012 1:56 pm

Re: UPDATE: I've sold my Canon P-215

Post by VanessaTL »

Spearmint2 wrote:
VanessaTL wrote:Hello everyone. Just a quick update. I sold my Canon P-215. I and buyer are both happy.
Got something that's working now?
Hi, Spearmint2.
Nice to hear from you again.

Not yet. I plan to buy Brother ADS-2000, as a Ubuntu user says it works for them. But first I want to hear from a Mint user whether it's compatible.
Post Reply

Return to “Newbie Questions”