[SOLVED] System freezing after hibernation

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
krow7
Level 3
Level 3
Posts: 102
Joined: Thu Apr 17, 2014 7:08 am

[SOLVED] System freezing after hibernation

Post by krow7 » Fri Nov 28, 2014 4:38 am

Hi everyone! (and please keep in mind that I am quite new to the Linux scene)

I am having a problem with hibernation on Linux Mint 17 x64 MATE. After I boot my laptop from hibernation it works for about 2-5 min and then the whole system hangs (cant move the mouse or do Ctrl+Alt+1...). So I have to do a hard reset of the system. Then everything works fine.
This problem started after I updated the kernel via LM Update Manager -> Linux kernels utility. I have tried about 5-8 different kernels from the list and had the same problem with all of them. The problem goes away when I go back to the LM default kernel: 3.13.0.24. I updated the kernel for security reasons (suggested by an article).

Current kernel:

Code: Select all

Linux 3.16.0-25-generic #33-Ubuntu SMP x86_64
I am assuming it might be a graphics issue. So here is my GPU info:

Code: Select all

Graphics:  Card: Advanced Micro Devices [AMD/ATI] Madison [Mobility Radeon HD 5650/5750 / 6530M/6550M]
           Display Server: X.Org 1.15.1 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.0hz
           GLX Renderer: Gallium 0.4 on AMD REDWOOD
           GLX Version: 3.0 Mesa 10.1.3
Is there a way to fix this without going back to the original kernel? Any suggestions are welcome! :)

Edit: This is a quick reference of the solutions that worked for me. I am using the 2nd solution because the 1st made my system laggy (might not be the case for you).

Solution 1 Solution 2
  • Install kernel 3.19 or higher. This solution will also keep your kernel up to date with the Ubuntu Vivid latest version. Run the following:

    Code: Select all

    sudo apt-get apt-get install linux-headers-generic-lts-vivid linux-image-generic-lts-vivid
    sudo update-grub
    Reboot your system.
    To check if you are running the new kernel:

    Code: Select all

    uname -r
Last edited by krow7 on Fri May 22, 2015 3:20 am, edited 4 times in total.

LindseyD.
Level 4
Level 4
Posts: 331
Joined: Fri Mar 26, 2010 12:35 pm

Re: System freezing after hibernation

Post by LindseyD. » Sat Nov 29, 2014 3:08 pm

My problem was a little different: it wouldn't wake at all from suspend (sleep). I also have an ATI card. I fixed the problem by switching to the flgrx-updates driver, rather than the default. If it doesn't work, you can always switch back again.
Mint17 KDE

krow7
Level 3
Level 3
Posts: 102
Joined: Thu Apr 17, 2014 7:08 am

Re: System freezing after hibernation

Post by krow7 » Tue Dec 02, 2014 6:07 am

Thanks for the reply Lindsey!

Yep, this solves my problem, but the fglrx and fglrx-updates make MATE somewhat slugish on my laptop :( Which is strange, since MATE is very light.
I'll give the latest ATI driver a go, and see how that goes. Or just wait for the Mint-Debian-Jessie spin, hibernation worked on Jessie like a charm. :)

User avatar
Spearmint2
Level 15
Level 15
Posts: 5719
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: System freezing after hibernation

Post by Spearmint2 » Tue Dec 02, 2014 7:17 am

this is what I used with AMD processor, Radeon video, and MATE. No problems.

Code: Select all

~ $ inxi -G
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS780 [Radeon HD 3200] 
           X.Org: 1.15.1 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1024x768@70.1hz 
           GLX Renderer: Gallium 0.4 on AMD RS780 GLX Version: 3.0 Mesa 10.1.0
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

krow7
Level 3
Level 3
Posts: 102
Joined: Thu Apr 17, 2014 7:08 am

Re: System freezing after hibernation

Post by krow7 » Tue Dec 02, 2014 7:33 am

Thanks for the reply Spearmint!

Have you also updated the kernel?

From what I can gather you have a lower version of GLX? Should I downgrade? Do you think this will help with hibernation?

User avatar
Spearmint2
Level 15
Level 15
Posts: 5719
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: System freezing after hibernation

Post by Spearmint2 » Tue Dec 02, 2014 9:03 am

Code: Select all

~ $ uname -a
Linux mint16 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:08:14 UTC 2014 i686 athlon i686 GNU/Linux


Hibernation problems happen when all the following aren't synced properly.

Large enough SWAP file to match RAM size
The "resume" isn't set correctly in several areas.
The UUID for swap changed

You can consult these threads about that.

http://forums.linuxmint.com/viewtopic.php?f=90&t=145337
http://forums.linuxmint.com/viewtopic.php?f=90&t=143909
http://forums.linuxmint.com/viewtopic.p ... 68#p796868

Since this seems kernel related, check the grub.cfg file for resume= in the menuentry for the kernel that's working and add that to the lines in the menuentry for the kernel that's not hibernating properly. If that was the cause, then go to the /etc/default/grub and change this line

GRUB_CMDLINE_LINUX="resume=UUID=??????????????????????????

replacing the question marks with the proper UUID for the swap file. If uncertain, then

Code: Select all

sudo blkid
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

krow7
Level 3
Level 3
Posts: 102
Joined: Thu Apr 17, 2014 7:08 am

Re: System freezing after hibernation

Post by krow7 » Tue Dec 02, 2014 11:13 am

Large enough SWAP file to match RAM size
The "resume" isn't set correctly in several areas.
The UUID for swap changed
Ram = 6 GB Swap = 8.5GB
"resume=" is set correctly in /etc/initramfs-tools/conf.d/resume
The UUID of the swap didnt change after install.

I have checked the grub.cfg and resume was missing there.

Here is the menuentry for the current kernel before change:

Code: Select all

menuentry 'Linux Mint 17 MATE 64-bit, 3.16.0-25-generic (/dev/sda2)' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	gfxmode $linux_gfx_mode
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos2'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  41d20089-7224-438d-96c0-5627edf90ceb
	else
	  search --no-floppy --fs-uuid --set=root 41d20089-7224-438d-96c0-5627edf90ceb
	fi
	linux	/boot/vmlinuz-3.16.0-25-generic root=UUID=41d20089-7224-438d-96c0-5627edf90ceb ro   quiet splash $vt_handoff
	initrd	/boot/initrd.img-3.16.0-25-generic
}
And this is the line after change:

Code: Select all

linux	/boot/vmlinuz-3.16.0-25-generic root=UUID=41d20089-7224-438d-96c0-5627edf90ceb ro recovery nomodeset resume=UUID=51306a95-255a-4908-9119-b84b5f25bc1a
I have rebooted the system after changing grub and hibernated the laptop. After hibernation same problem - after 5 min the system hanged... cant switch to another tty... the only difference is that I could move the mouse around.

I guess this is the graphics driver? (If it is, this is my second issue with the opensource ATI driver since LM 17 :()

LindseyD.
Level 4
Level 4
Posts: 331
Joined: Fri Mar 26, 2010 12:35 pm

Re: System freezing after hibernation

Post by LindseyD. » Tue Dec 02, 2014 11:32 am

krow7 wrote:Thanks for the reply Lindsey!

Yep, this solves my problem, but the fglrx and fglrx-updates make MATE somewhat slugish on my laptop :( Which is strange, since MATE is very light.
I'll give the latest ATI driver a go, and see how that goes. Or just wait for the Mint-Debian-Jessie spin, hibernation worked on Jessie like a charm. :)
What I found is that the sound became very faint. I was very difficult to hear some videos, especially on YouTube. But, somehow, the problem resolved itself after a few days. Then another one showed up :( All of a sudden, vlc began using up all my CPU. I've googled around and discovered that updating the driver will cure that, but I've yet to figure out exactly how to do it. You need to download from the AMD site.
Mint17 KDE

User avatar
Spearmint2
Level 15
Level 15
Posts: 5719
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: System freezing after hibernation

Post by Spearmint2 » Tue Dec 02, 2014 5:40 pm

I guess this is the graphics driver? (If it is, this is my second issue with the opensource ATI driver since LM 17 :()
Don't know. Once in awhile everything seems set right but hibernate won't work on a particular model of computer. Sometimes changing the BIOS setting for "sleep" from S3 to S1 solves the problem. Might be video driver, especially if a discrete card instead of onboard, and also if the onboard wasn't turned off in the BIOS.

You could try putting nomodeset after the quiet splash in the grub.cfg file. Adding the nomodeset parameter instructs the kernel to not load video drivers and use BIOS modes instead until X is loaded.

You can research and try to ferret it out. Note links to the "related articles" too. Sometimes it's easy, sometimes damned impossible.

http://distro.ibiblio.org/fatdog/web/fa ... tions.html
nomodeset

This is a kernel boot option that tells the kernel not to enable kernel mode setting (KMS). Video support is usually a combination of a drm kernel driver and a Xorg driver working together. KMS is used with Intel, Nouveau, and Radeon kernel modules. KMS is required for Intel and Nouveau, and optional for Radeon (although, with different features).

If you want to use the vesa Xorg driver, and you have hardware that uses the Intel, Nouveau, or Radeon kernel modules, you may need to boot with nomodeset, or blacklist the matching module, or just delete the module. The modules will be found in /lib/modules/<kernel-version>/kernel/drivers/gpu/drm/.
https://wiki.archlinux.org/index.php/Hibernate

when you updated the kernel, did you also run the update manager to see if anything else needed to be updated at that time?
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

krow7
Level 3
Level 3
Posts: 102
Joined: Thu Apr 17, 2014 7:08 am

Re: System freezing after hibernation

Post by krow7 » Thu Dec 11, 2014 6:23 am

LindseyD. wrote:What I found is that the sound became very faint. I was very difficult to hear some videos, especially on YouTube. But, somehow, the problem resolved itself after a few days. Then another one showed up :( All of a sudden, vlc began using up all my CPU. I've googled around and discovered that updating the driver will cure that, but I've yet to figure out exactly how to do it. You need to download from the AMD site.
Thanks for the reply. I will try to solve the issue with with open source driver and if all fails (which seems like it will at the moment) I will give a newer AMD driver a go, hopefully that will improve some performance issues...
By the way a lot of people seem to be facing similar issues with the AMD driver on Ubuntu 14.04. Found this reddit thread about it (and there are some solutions there as well) - https://www.reddit.com/r/Ubuntu/comment ... he_radeon/
Spearmint2 wrote:Don't know. Once in awhile everything seems set right but hibernate won't work on a particular model of computer. Sometimes changing the BIOS setting for "sleep" from S3 to S1 solves the problem. Might be video driver, especially if a discrete card instead of onboard, and also if the onboard wasn't turned off in the BIOS.

You could try putting nomodeset after the quiet splash in the grub.cfg file. Adding the nomodeset parameter instructs the kernel to not load video drivers and use BIOS modes instead until X is loaded.

You can research and try to ferret it out. Note links to the "related articles" too. Sometimes it's easy, sometimes damned impossible.

http://distro.ibiblio.org/fatdog/web/fa ... tions.html

https://wiki.archlinux.org/index.php/Hibernate

when you updated the kernel, did you also run the update manager to see if anything else needed to be updated at that time?
Thanks for all the suggestions Spearmint! (I hope that I understood everything correctly)

Unfortunately I do not have any power settings in the BIOS on my laptop. And this is the latest version of the BIOS...

I tried nomodeset but after the OS booted my system ran at low resolution. I suppose it didn't load the driver at all. Do I have to do something to get the driver to load after that?

I didn't run updater after updating the kernel but I did do it later on and rebooted the system (which I guess is the same thing?).

I tried all the links you gave me but was not able to find a solution there. Out of desperation I installed a fresh copy of LM 17.1 Mate x64. And the hibernation problem persists... EXCEPT (which is exciting! :D) I can now change the tty. And now that I am running compiz, it (e.i. compiz) keeps freezing and restarting. I could even reload the Xorg (Ctrl+Alt+Backspace), but that didnt help. Compiz would continue to do its freeze-restart dance.
Marco (def Mate window manager) just freezes 2-3min after hibernation, cant even change tty.

LindseyD.
Level 4
Level 4
Posts: 331
Joined: Fri Mar 26, 2010 12:35 pm

Re: System freezing after hibernation

Post by LindseyD. » Thu Dec 11, 2014 8:01 am

In my experience, once something in the kernel isn't working for you--and that's what's happening here--it'll be a long time, if ever, that the problem gets solved.

You had a working kernel--the original. Did you find out what the security issue is? It may not even apply in your case. Don't assume "security" = "your system getting hacked." It could be a stability issue, and you weren't having problems.

Another alternative is to not run compiz. I'm a KDE user from way back, so I don't know what advantage there is with Gnome to run compiz. In my experience, it has nothing to do with getting any work done.
Mint17 KDE

krow7
Level 3
Level 3
Posts: 102
Joined: Thu Apr 17, 2014 7:08 am

Re: System freezing after hibernation

Post by krow7 » Thu Dec 11, 2014 10:03 am

It might be a kernel issue, but hibernation worked perfectly when I tested Debian Jessie. And, if I am not mistaken, Debian uses "systemd-hibernation" and/or uswsusp/swsusp instead of pm-utils (i wonder if this is the issue). Of course there is an updated kernel as well.
I might try running a one of the above interfaces for hibernation, if I find a decent guide to do that. And hope that I won't completely break my system (again)! :lol:

Yeah I might ignore the security thingy. And go back to the original kernel since usability is my priority at the moment.

I only enabled compiz because its one of the new features in LM 17.1 Mate.
Unfortunately I haven't used KDE since the days when it was slow and buggy. I'll definitely give it a go some time.

LindseyD.
Level 4
Level 4
Posts: 331
Joined: Fri Mar 26, 2010 12:35 pm

Re: System freezing after hibernation

Post by LindseyD. » Thu Dec 11, 2014 10:33 am

krow7 wrote:I only enabled compiz because its one of the new features in LM 17.1 Mate.
Unfortunately I haven't used KDE since the days when it was slow and buggy.
It still is. :wink:
Mint17 KDE

krow7
Level 3
Level 3
Posts: 102
Joined: Thu Apr 17, 2014 7:08 am

Re: System freezing after hibernation

Post by krow7 » Tue Dec 16, 2014 8:40 am

LindseyD. wrote:
krow7 wrote:I only enabled compiz because its one of the new features in LM 17.1 Mate.
Unfortunately I haven't used KDE since the days when it was slow and buggy.
It still is. :wink:
How come you are using it then? :P

LindseyD.
Level 4
Level 4
Posts: 331
Joined: Fri Mar 26, 2010 12:35 pm

Re: System freezing after hibernation

Post by LindseyD. » Tue Dec 16, 2014 9:36 am

krow7 wrote:How come you are using it then? :P
Every now and then I give Gnome or one of its variants a try, then switch back. I'm used to KDE, and there are some built-in conveniences I've come to rely on.
Mint17 KDE

krow7
Level 3
Level 3
Posts: 102
Joined: Thu Apr 17, 2014 7:08 am

Re: System freezing after hibernation

Post by krow7 » Tue Dec 16, 2014 10:38 am

LindseyD. wrote:
krow7 wrote:How come you are using it then? :P
Every now and then I give Gnome or one of its variants a try, then switch back. I'm used to KDE, and there are some built-in conveniences I've come to rely on.
Makes sense. I prefer light desktops - Mate, XFCE. I like when GUI feels really snappy. :)
Thanks again for all the help.

I forced myself to install ATI drivers and now hibernation works properly. The performance is not as good as on the opensource driver, but it will have to do for now.

LindseyD.
Level 4
Level 4
Posts: 331
Joined: Fri Mar 26, 2010 12:35 pm

Re: System freezing after hibernation

Post by LindseyD. » Tue Dec 16, 2014 11:03 am

krow7 wrote:I forced myself to install ATI drivers and now hibernation works properly. The performance is not as good as on the opensource driver, but it will have to do for now.
Well, now I have a question :)

Did you install from their website? Because I notice the driver there is almost a year old, but it's still way newer than the one that comes with Mint.
Mint17 KDE

krow7
Level 3
Level 3
Posts: 102
Joined: Thu Apr 17, 2014 7:08 am

Re: System freezing after hibernation

Post by krow7 » Thu Dec 18, 2014 6:52 am

LindseyD. wrote:
krow7 wrote:I forced myself to install ATI drivers and now hibernation works properly. The performance is not as good as on the opensource driver, but it will have to do for now.
Well, now I have a question :)

Did you install from their website? Because I notice the driver there is almost a year old, but it's still way newer than the one that comes with Mint.
Here is the guide that I used - http://wiki.cchtml.com/index.php/Ubuntu ... .29_STABLE

I installed the stable version. There was hiccup with the dependencies - http://wiki.cchtml.com/index.php/Ubuntu ... _you_start
When installing linux-headers-generic it asked to install the headers for kernel 3.13.0-43-generic. Instead of installing headers for the kernel I was running, I just installed the 3.13.0-43-generic kernel. :lol:

Also don't forget to generate the .conf file after installing the driver - http://wiki.cchtml.com/index.php/Ubuntu ... .conf_file

A bit lower down in the guide you can find how to enable Tear Free desktop or you can do it via Control Center GUI.

Lastly the Control Center with admin rights doesn't work from Mint menu. But I edited the menu entry of AMD Catalyst Control Center (Administrative) and changed the command to

Code: Select all

gksu amdcccle
Hope this works for you! :)
P.S. All the links are from the same guide :P
Last edited by krow7 on Fri Dec 19, 2014 8:02 am, edited 1 time in total.

LindseyD.
Level 4
Level 4
Posts: 331
Joined: Fri Mar 26, 2010 12:35 pm

Re: [SOLVED] System freezing after hibernation

Post by LindseyD. » Thu Dec 18, 2014 7:37 am

Terrific stuff. Thank you!
Mint17 KDE

krow7
Level 3
Level 3
Posts: 102
Joined: Thu Apr 17, 2014 7:08 am

Re: [SOLVED] System freezing after hibernation

Post by krow7 » Mon Mar 16, 2015 7:37 am

I finally found the solution to use the AMD opensource driver in Mint 17/17.1!! 8)

It turns out that this problem occurs in kernels 3.13 though 3.16. I have not checked 3.17 and 3.18 went straight to 3.19.
There is no need to do anything except install the kernel. The side effect of this is that you will have to keep on updating the kernel manually from now on.

The kernels are available from Ubuntu mainline - http://kernel.ubuntu.com/~kernel-ppa/mainline/
To install a mainline kernel just google it :P (some thing like - install kernel_version linuxmint). There are a lot of guides. Make sure to choose correct architecture - 32-bit (i386) or 64-bit (amd64).
Be careful and check that the guide downloads the kernels from the official repository (link above).
(These guides also provide a way to remove the kernel in case something goes wrong).

WARNING installing a mainline kernel may (or may not) break something.
If something goes wrong:
  • restart your system;
  • boot into grub (hold shift before the system begins booting);
  • and in the grub menu choose the previous kernel version under Previous linux versions.
Then remove the previously installed kernel.
Last edited by krow7 on Thu Apr 23, 2015 3:20 am, edited 1 time in total.

Post Reply

Return to “Newbie Questions”