(SOLVED)Swap Partition fails to mount at startup

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
Incentive I.C
Level 4
Level 4
Posts: 334
Joined: Mon Aug 27, 2012 9:20 pm

(SOLVED)Swap Partition fails to mount at startup

Post by Incentive I.C »

I have been trying to get the Swap to mount at startup. I have put the UUID in the /etc/fstab but it still fails to boot.

Here is the fstab and blkid

Code: Select all

sudo blkid
/dev/sda1: LABEL="System Reserved" UUID="2AE8F58CE8F55693" TYPE="ntfs" 
/dev/sda2: UUID="6A30F80830F7D951" TYPE="ntfs" 
/dev/sda5: UUID="a58dba5f-aec2-4a2d-95fe-c6900445c6fb" TYPE="ext4" 
/dev/sda6: UUID="b43ec073-95b9-48ed-b6da-8fefa06cebce" TYPE="swap" 
/dev/zram0: UUID="73677013-0c9b-480f-b6e2-5fd50c43d4cf" TYPE="swap" 
/dev/zram1: UUID="ca70866c-241b-4f74-a629-a3d1ad002bf1" TYPE="swap" 

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=a58dba5f-aec2-4a2d-95fe-c6900445c6fb /               ext4    errors=remoun$
/dev/sda6: UUID="b43ec073-95b9-48ed-b6da-8fefa06cebce" TYPE="swap"


Last edited by Incentive I.C on Mon Dec 08, 2014 6:31 pm, edited 1 time in total.
The best way to learn from it is break it OS's (is there a plural for OS?) included.

User avatar
nerdtron
Level 5
Level 5
Posts: 626
Joined: Sun Jan 31, 2010 10:46 am
Location: Pilipinas kong mahal!

Re: Swap Partition fails to mount at startup

Post by nerdtron »

Wrong syntax in the fstab entry.
Replace your entry with this:

Code: Select all

UUID=b43ec073-95b9-48ed-b6da-8fefa06cebce   swap   swap defaults    0    0
Or if that doesn't work, try revising it again:

Code: Select all

UUID=b43ec073-95b9-48ed-b6da-8fefa06cebce   none   swap  sw   0    0
"I learned a lot from repeatedly breaking my system and then reinstalling. Oh, and a lot of GOOGLE searches too!"

User avatar
Incentive I.C
Level 4
Level 4
Posts: 334
Joined: Mon Aug 27, 2012 9:20 pm

Re: Swap Partition fails to mount at startup

Post by Incentive I.C »

nerdtron wrote:Wrong syntax in the fstab entry.
Replace your entry with this:

Code: Select all

UUID=b43ec073-95b9-48ed-b6da-8fefa06cebce   swap   swap defaults    0    0
Or if that doesn't work, try revising it again:

Code: Select all

UUID=b43ec073-95b9-48ed-b6da-8fefa06cebce   none   swap  sw   0    0

The first one worked thank you! :D
The best way to learn from it is break it OS's (is there a plural for OS?) included.

User avatar
Incentive I.C
Level 4
Level 4
Posts: 334
Joined: Mon Aug 27, 2012 9:20 pm

Re: Swap Partition fails to mount at startup

Post by Incentive I.C »

nerdtron wrote:Wrong syntax in the fstab entry.
Replace your entry with this:

Code: Select all

UUID=b43ec073-95b9-48ed-b6da-8fefa06cebce   swap   swap defaults    0    0
Or if that doesn't work, try revising it again:

Code: Select all

UUID=b43ec073-95b9-48ed-b6da-8fefa06cebce   none   swap  sw   0    0

The first one worked thank you! :D
The best way to learn from it is break it OS's (is there a plural for OS?) included.

Post Reply

Return to “Newbie Questions”