Can't boot to Linux Mint 17.1 64bit [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
linuxwannabe
Level 2
Level 2
Posts: 51
Joined: Thu Nov 06, 2014 9:59 pm

Can't boot to Linux Mint 17.1 64bit [SOLVED]

Post by linuxwannabe »

I have a relatively new Asus that was given to me (maybe year and half old). It doesn't have a model number on it. It has windows 8 on it.

I have tried to change the bios to load a cd but can't figure it out. It has American Megatrends Aptio on it. Bios vender 208 Version 3.014.1015 EC 2300000F13.

I turned off the security boot, fast boot, and Intel setup. I can't find legacy in there. I do not know the correct settings to make it boot from cd drive.

Any help?? Thanks much!!!
Last edited by linuxwannabe on Fri Dec 12, 2014 1:30 pm, edited 1 time in total.

User avatar
Reorx
Level 11
Level 11
Posts: 3936
Joined: Tue Jul 07, 2009 7:14 pm
Location: SE Florida, USA

Re: Can't boot to Linux Mint 17.1 64bit

Post by Reorx »

If you are trying to install Mint, changing to "legacy" is not essential/important. Mint can do a GPT/uEFI installation. The partition architecture is a little different but it is do-able... If you do a GPT installation, the 4 primary partition rule (for legacy / MBR disks) goes out the window... I think the primary partition number limit is something like 128 with GPT disks...

In terms of booting from a live medium, there is usually an F-key option during the POST to get a boot option menu... on my laptop it is F12 but this varies by manufacturer. Watch your screen during the POST for clues.
Full time Linux Mint user since 2011 - Currently running LM19 Cinnamon.

Image Image

User avatar
gold_finger
Level 9
Level 9
Posts: 2886
Joined: Mon Mar 11, 2013 11:39 pm

Re: Can't boot to Linux Mint 17.1 64bit

Post by gold_finger »

linuxwannabe wrote:I have a relatively new Asus that was given to me (maybe year and half old). It doesn't have a model number on it. It has windows 8 on it.
Isn't there a sticker on underneath side of laptop?
linuxwannabe wrote: I can't find legacy in there. I do not know the correct settings to make it boot from cd drive.
It might not be called "legacy" -- probably called "CSM" (Compatibility Support Module).

If can't change device boot order in main settings menu to look to DVD drive ahead of hard drive, try accessing the per session Boot Menu. Usually you need to hit a different key on startup to get into that then the one you use to get into main UEFI/(Bios) settings menu. Not sure what key it is for your computer, but if you used <F2> or <ESC> to get to main settings, try using <ESC> or <DEL> key and see if that brings up a Boot Menu. (Have your DVD in the tray before you start computer, otherwise you won't see a choice for it.)

You need to determine which mode Windows 8 was installed in; then make sure you boot the Mint DVD in the same mode. Otherwise the install won't work properly. They both need to be installed in the same mode for dual-booting to work right.

If you find that you need to install in UEFI mode, use this tutorial: http://forums.linuxmint.com/viewtopic.php?f=42&t=163126.

If you find that you need to do a Legacy/CSM mode install, then do the following:
  • * Boot into Windows and use disk management to:
    • -- defragment main "C:" drive
      -- then, shrink "C:" drive to make room for Mint installation (give at least 20-30GB for Mint)
      -- do not create any new partitions out of the free, unused space that results from shrinking. Just leave it as is.
      -- make note of how many partitions Windows has on disk. If there are more than three, take a screenshot of disk management window and post back to forums for help before trying to install Mint -- you will need to make changes that might not be easy without help. (NOTE: This is only the case on Legacy mode installations. Don't worry about number of partitions if doing UEFI mode install.)
    * Reboot into Windows after making partition changes to let it make any necessary adjustments.
    * Make a Win 8 recovery USB.
    * Make backup copies of anything important on computer.
    * Boot computer with Mint DVD.
    * Run installer.
    * For a standard installation, just choose "Along side Windows" from the "Installation Type" screen.
    * If you want to setup your own partitions, follow this tutorial: http://forums.linuxmint.com/viewtopic.php?f=42&t=122276.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.

linuxwannabe
Level 2
Level 2
Posts: 51
Joined: Thu Nov 06, 2014 9:59 pm

Re: Can't boot to Linux Mint 17.1 64bit

Post by linuxwannabe »

Thanks very much!! With these answers, I was able to figure out my mistakes and I got to the Install screen. BUT, no matter which option I choose, ..alongside Windows 8, erase Win 8, or even something else, the "Continue" button is greyed out I can't continue.

I have not idea what to do now.

thanks,

linuxwannabe
Level 2
Level 2
Posts: 51
Joined: Thu Nov 06, 2014 9:59 pm

Re: Can't boot to Linux Mint 17.1 64bit

Post by linuxwannabe »

I got it to continue by backing up. Now it seems stuck on time zone, but I will wait it out.

thanks

linuxwannabe
Level 2
Level 2
Posts: 51
Joined: Thu Nov 06, 2014 9:59 pm

Re: Can't boot to Linux Mint 17.1 64bit

Post by linuxwannabe »

It installed but now I can't get the Asus to boot to Linux. It boots to Windows 8. Maybe i will reinstall and erase windows 8.????

I must have left something in the Bios set to boot from either cd or windows 8. I really do not like this bios version. I just can't seem to figure it out.

User avatar
gold_finger
Level 9
Level 9
Posts: 2886
Joined: Mon Mar 11, 2013 11:39 pm

Re: Can't boot to Linux Mint 17.1 64bit

Post by gold_finger »

Boot the live Mint DVD again. Then open a terminal and enter this command:

Code: Select all

sudo parted -l
(Command ends with a lowercase letter "L", not the number 1.)

Copy the output and paste it back here for us to see.


P.s. Meanwhile, check out the link posted here: http://forums.linuxmint.com/viewtopic.p ... 75#p956702. Not sure if anything in it will help, but have a read through because it might clear up some confusion.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.

linuxwannabe
Level 2
Level 2
Posts: 51
Joined: Thu Nov 06, 2014 9:59 pm

Re: Can't boot to Linux Mint 17.1 64bit

Post by linuxwannabe »

Obviously, something went wrong with the install.

mint@mint ~ $ sudo parted -l
Model: ATA HGST HTS541075A9 (scsi)
Disk /dev/sda: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number Start End Size File system Name Flags
1 1049kB 316MB 315MB fat32 EFI system partition boot
2 316MB 1259MB 944MB ntfs Basic data partition hidden, diag
3 1259MB 1394MB 134MB Microsoft reserved partition msftres
4 1394MB 321GB 319GB ntfs Basic data partition msftdata
7 321GB 321GB 1049kB bios_grub
8 321GB 722GB 401GB ext4
9 722GB 728GB 6325MB linux-swap(v1)
5 728GB 729GB 367MB ntfs hidden, diag
6 729GB 750GB 21.5GB ntfs Basic data partition hidden, diag


Warning: Unable to open /dev/sr0 read-write (Read-only file system). /dev/sr0
has been opened read-only.
Error: Can't have a partition outside the disk!

User avatar
gold_finger
Level 9
Level 9
Posts: 2886
Joined: Mon Mar 11, 2013 11:39 pm

Re: Can't boot to Linux Mint 17.1 64bit

Post by gold_finger »

The presence of this partition means that you installed Mint in Legacy/CSM mode instead of UEFI mode.
7 321GB 321GB 1049kB bios_grub
The presence of this partition indicates that Windows is installed in UEFI mode.
1 1049kB 316MB 315MB fat32 EFI system partition boot
You need to boot the Mint DVD in UEFI mode and do a UEFI mode installation. Before you do that, you might be able to convert the current installation to UEFI mode by following directions on this page: https://help.ubuntu.com/community/UEFI# ... egacy_mode. You'll need to boot the Mint DVD in UEFI mode, then install Boot-Repair to the live environment first, but don't run the "recommended repair". Instead, follow directions in above link to convert the installation. You'll want to set the "Separate /boot/efi partition" to /dev/sda1.

If that doesn't work, then use GParted to delete the /dev/sda7 and sda8 partitions. You can keep the Swap partition as it is. Then make two new partitions in the resulting free space:
-- one 25GB; formatted as Ext4. (You'll set this one as the Root partition when you install.)
-- one using the rest of the space; formatted as Ext4. (You'll set this one as your Home partition when you install.

Hit the "Apply" button when done making partition changes (or go to Edit -> Apply All Operations). Then close GParted and you can start the installation. Follow directions in the tutorial I linked to before for UEFI installations with Windows.
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.

linuxwannabe
Level 2
Level 2
Posts: 51
Joined: Thu Nov 06, 2014 9:59 pm

Re: Can't boot to Linux Mint 17.1 64bit

Post by linuxwannabe »

I think I would rather just install Linux on the entire drive erasing windows 8. I did something wrong the first time.
In the setup, I gather I should not enable CMS. What other options should I set which way??

thanks so much!! I cannot do this without you.

User avatar
gold_finger
Level 9
Level 9
Posts: 2886
Joined: Mon Mar 11, 2013 11:39 pm

Re: Can't boot to Linux Mint 17.1 64bit

Post by gold_finger »

Do yourself a favor -- make a Win 8 recovery USB for the system before wiping it off the drive. That way you'll be able to reinstall it if you ever want to for yourself, or if you want to resell the computer.

Did you try converting the installation to UEFI as recommended in my last post? There is a good chance that will work. Your computer should have a way to pull up a per session boot menu that will give you a choice to boot the DVD in either UEFI or Legacy/CSM mode. This usually accessed immediately after starting computer by hitting a special key -- a different key than the one you use to get into the general UEFI/(Bios) settings menu. EG. If you hit <F2> for general settings, <F12> might be key to press for session boot menu. The key varies by manufacturer, but common ones are <F12>, <Esc> and <Del>. Try each of those; or do a search for your computer's user manual to find that out.

If you really want to wipe-out Windows and start over with fresh Mint installation:

Boot your Mint DVD any way you can.

Open a terminal and enter this command to find out what mode the DVD booted in:

Code: Select all

ls /sys/firmware
If "efi" is listed = booted in UEFI mode.
If "efi" not listed = booted in Legacy/CSM mode.

Then open GParted (in Menu under either Administration or System category) and delete all partitions on the disk. You will probably have to right-click on the Swap partition and choose "Swapoff" before being able to delete that one. Hit the "Apply" button along top of interface, or go to Edit -> Apply All Operations to finalize the deletions. The next steps will depend on which mode you found out the DVD got booted in.

If booted in Legacy/CSM mode:
  • * Along top of GParted, go to Device -> Create Partition Table -> "msdos" -> Apply.
    * Close GParted.
    * Start the installation.
    * If you want a standard installation with just a Root and Swap partition, just pick the option that says it will use the whole disk and erase what's on it.
    * If you want to make your own partitions, choose the "Something else" install option, then follow directions on this tutorial to make your partitions: http://forums.linuxmint.com/viewtopic.php?f=42&t=122276.

If booted in UEFI mode:
  • * Along top of GParted, go to Device -> Create Partition Table -> "gpt" -> Apply.
    * Next you'll make necessary new partitions for the installation:
    • -- size=500MB; formatted as FAT32 (this will later be the EFI System Partition)
      -- size=25GB; formatted as Ext4 (this will later be your Root partition
      -- size=1-2 times RAM; formatted as "linux-swap" (this will be your Swap partition)
      -- size=rest of drive space; formatted as Ext4 (this will later be your Home partition)
      -- hit "Apply" button to finalize creation of partitions.
      -- close GParted
    * Start installation and choose "Something else" install option.
    * Follow directions on this tutorial to install (ignore references to dual-booting with Windows).
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.

linuxwannabe
Level 2
Level 2
Posts: 51
Joined: Thu Nov 06, 2014 9:59 pm

Re: Can't boot to Linux Mint 17.1 64bit

Post by linuxwannabe »

With all of your help, I figured it out and have it working perfectly.

thanks so much!!!!

User avatar
gold_finger
Level 9
Level 9
Posts: 2886
Joined: Mon Mar 11, 2013 11:39 pm

Re: Can't boot to Linux Mint 17.1 64bit [SOLVED]

Post by gold_finger »

Glad it worked out.

Just out of curiosity:
  • * Did you end up wiping out Windows, or keeping it?
    * What mode did you end up having to install in?
Please add [SOLVED] to your thread if a solution is found. Go to your first post in the thread, hit "Edit" button and add [SOLVED] to the title of the post.

How To Format Your Forum Posts.

Try Linux Beginner Search Engine for Linux questions.

Post Reply

Return to “Newbie Questions”