Samba and Mate minor issues

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
matthekc
Level 2
Level 2
Posts: 61
Joined: Mon Jan 15, 2007 5:13 am

Samba and Mate minor issues

Post by matthekc » Thu Jan 15, 2015 1:38 am

I have noticed that when running the Mate edition Samba share browsing seems to crash occasionally. Also office files don't open from the share drive. I have tried the cinnamon edition and it does not seem to have the same issues... (but I still can't make it look like my current install). Is this a known issue with the Mate desktop? Does anyone know when there might be a fix?

mctom
Level 2
Level 2
Posts: 72
Joined: Wed Jan 07, 2015 2:37 pm
Location: Gdańsk, Poland

Re: Samba and Mate minor issues

Post by mctom » Thu Jan 15, 2015 6:27 am

Yes, I noticed exactly the same behavior in Cinnamon, especially while unmounting (pressing the "eject"-like button). In most cases, all Nemo windows disappear along with desktop icons. Once you launch any sort of file explorer, everything goes back to normal.
I haven't found time to investigate it yet, but I thought it might be because of server misconfiguration of some sort. It happened after a while, playing with "homes" dir configuration.

Samba server is on Raspberry Pi, I don't know if it makes any difference.

Perhaps your setup has something in common, so we could narrow down possibilities of the cause?
I am an inexperienced linux user, so please don't hesitate to correct me if I am wrong. Thank you!

Punk ain't no religious cult, Punk means thinking for yourself!

altair4
Level 19
Level 19
Posts: 9715
Joined: Tue Feb 03, 2009 10:27 am

Re: Samba and Mate minor issues

Post by altair4 » Thu Jan 15, 2015 9:21 am

I've never experienced this with mate but I'm not in it for any length of time.

You might want to post the output of this command just to see if the client components of Samba are messed up somewhere:

Code: Select all

testparm -s
Also, what makes up your network? Is this an all Linux network or a Linux / OSX network? Or do you have Windows in the mix?

Samba in an all Linux / OSX network is far easier to set up.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

matthekc
Level 2
Level 2
Posts: 61
Joined: Mon Jan 15, 2007 5:13 am

Re: Samba and Mate minor issues

Post by matthekc » Sat Jan 17, 2015 3:53 am

Its and old 2003 server where I am currently working... I am not doing IT right now, I am working as an ESL teacher in China. So I could probably get the config but I am not the admin.

I was hoping someone would say that it had been fixed upstream in a newer version... oh well it's workable. :roll:
I don't think it's a config issue because it mostly works but just incase here it is.

Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[printers]"
Processing section "[print$]"
Loaded services file OK.
Server role: ROLE_STANDALONE
[global]
server string = %h server (Samba, Linux Mint)
server role = standalone server
map to guest = Bad User
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
unix password sync = Yes
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
dns proxy = No
usershare allow guests = Yes
panic action = /usr/share/samba/panic-action %d
idmap config * : backend = tdb

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
printable = Yes
print ok = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers

mctom
Level 2
Level 2
Posts: 72
Joined: Wed Jan 07, 2015 2:37 pm
Location: Gdańsk, Poland

Re: Samba and Mate minor issues

Post by mctom » Sat Jan 17, 2015 7:57 am

Well, this config file does not have any browsable shares. How do you encounter our problem, then? ;)
I am an inexperienced linux user, so please don't hesitate to correct me if I am wrong. Thank you!

Punk ain't no religious cult, Punk means thinking for yourself!

altair4
Level 19
Level 19
Posts: 9715
Joined: Tue Feb 03, 2009 10:27 am

Re: Samba and Mate minor issues

Post by altair4 » Sat Jan 17, 2015 8:12 am

The only reason I asked for the output of testparm was to see if any of the client components of samba were mis-configured and everything looks as it should.
I have tried the cinnamon edition and it does not seem to have the same issues
I realize that these use different file managers but the samba back ends of both including gvfs should be the same so this is an interesting issue.

Have you tried to connect to the 2003 server by ip address to see if you experience this same "crash". For example:

Code: Select all

caja smb://192.168.0.100/share-name
You might be in luck and the server has a static ip address anyway.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

matthekc
Level 2
Level 2
Posts: 61
Joined: Mon Jan 15, 2007 5:13 am

Re: Samba and Mate minor issues

Post by matthekc » Sat Jan 17, 2015 8:35 am

I have two separate things that are a little annoying.
1) Libre Office cannot open files from the share. Other files open fine. I installed the Cinnamon edition a month or two ago to see how things are going and noticed I did not have the issue with the Libre Office files there which is strange. I figure that when I am ready to upgrade again to the next LTS or the stable Debian Edition I will just move to Cinnamon if the issue persists in the Mate edition. I read somewhere this is a know issue in *buntu and I tried one of the "fixes but no dice... So I just copy the files locally to use them and then copy them back if needed.

2) File browsing is a little slow. It could be the server it's pretty old and fairly slow like any old XP workstation... Occasionally,maybe a few times a week, the file browser hangs and even crashes (Could a slow server cause this?). Is this highly unusual behavior for Samba share browsing? It seemed to work better in Cinnamon but I didn't test Cinnamon for very long. That's another story related to me doing bad things to the install with non-approved Nvidia drivers :~ )

To be honest at this point I'm not that concerned about the issue, but I can try to give more information if it will help the project.

altair4
Level 19
Level 19
Posts: 9715
Joined: Tue Feb 03, 2009 10:27 am

Re: Samba and Mate minor issues

Post by altair4 » Sat Jan 17, 2015 8:51 am

It depends on how dynamic the network is. If you have machines entering and leaving the network sporadically the network resets itself as it starts the election process for the Master Browser again.

But again this would happen regardless of what desktop environment you use - Cinnamon, XFCE, MATE, .... That's why I suggested going to the server by ip address. It may be the name resolution process that's the problem and that would be bypassed if you connect by ip address.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

matthekc
Level 2
Level 2
Posts: 61
Joined: Mon Jan 15, 2007 5:13 am

Re: Samba and Mate minor issues

Post by matthekc » Tue Jan 20, 2015 1:54 am

This is the bookmark to the server...
So I am already using the IP.

smb://10.0.0.31/

Post Reply

Return to “Newbie Questions”