WiFi problem -- Elyssa sort of solved

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 41
Joined: Sun Nov 16, 2008 6:49 pm

WiFi problem -- Elyssa sort of solved

Postby hatrack » Thu Nov 20, 2008 2:11 pm

Hi All !

I am a newbie to Linux and have for the past couple of months been
experimenting with this (Ubuntu 8.04 and recently, Mint "Elyssa").

I have set up a dual-boot system with Win XP/Linux and this has worked
just fine until I swapped to Mint a few days ago. I have the standard
USB Wifi dongle and router system. Naturally, I have followed all the
correct procedures to set this up. Unfortunately, I just cannot get a
connection to the Web, using Mint. When, however, I boot into Win XP,
everything works perfectly. Connections are positive and quick and I
can swap sites ... no problems.

I have tried re-booting the computer, the router, un-plugging the dongle,
etc. ... all the usual tests ... but without result. Under Mint, the
system just cannot see the router. I have tried "pinging" this but get no

The "Failed to connect" response message seen under FireFox suggests the
possiblity that a firewall is interfering with the connection but I am
using the default configuration. Is there some conf file that I can edit
to fix this problem ?

Many thanks for any advice and my best regards to all ...

Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: WiFi problem -- Elyssaa

Postby Husse » Fri Nov 21, 2008 8:12 am

More info please
Which edition of Elyssa (they are not quite similar when it comes to networking)
I have the standard USB Wifi dongle

There is no such thing - but it would be nice :)
With the dongle connected run lsusb in a terminal and post the result (right click to copy)
You may have to add a driver like you did in Windows...
Don't fix it if it ain't broken, don't break it if you can't fix it

Level 1
Level 1
Posts: 41
Joined: Sun Nov 16, 2008 6:49 pm

Re: WiFi problem -- Elyssaa

Postby hatrack » Fri Nov 21, 2008 5:54 pm

Hi there Husse !

Thank you for replying to my post. I apologise for not answering you sooner but I have spent all today on further experiments and have to reach the forum via Win XP.

OK ... now to deal with your query --

The reason that I referred to my wifi dongle as "Standard" is a matter of loose terminology -- "common" would have been a better adjective. When I began this whole project about two months ago, I looked into the question of drivers for it and found that this particular chip-set is one of the commonest used and, the Linux sites that I visited confirmed that it is indeed supported. I can't remember the exact designation now but the dongle itself carries the code "WL-172 --" and that was part of the data listed in the tables of information that I consulted.

With all of that said, I have run the command "lsusb" (as you request) and get the following output --

Code: Select all

Bus 008 Device 001: ID 0000:0000 
Bus 007 Device 005: ID 0df6:90ac Sitecom Europe B.V.
Bus 007 Device 001: ID 0000:0000 
Bus 006 Device 001: ID 0000:0000 
Bus 005 Device 001: ID 0000:0000 
Bus 004 Device 002: ID 056a:0011 Wacom Co., Ltd Graphire 2
Bus 004 Device 001: ID 0000:0000 
Bus 003 Device 001: ID 0000:0000 
Bus 002 Device 001: ID 0000:0000 
Bus 001 Device 004: ID 413c:2005 Dell Computer Corp. RT7D50 Keyboard
Bus 001 Device 003: ID 046d:c016 Logitech, Inc. M-UV69a Optical Wheel Mouse
Bus 001 Device 001: ID 0000:0000

As you can see, the dongle is listed on Bus 007, Device 005. Interestingly, I have found during my many reboots today (!) that the dongle seems to be listed with equal frequency on Bus 005 and 007 but ... it is always called "Device 005" and always has the same ID code of "0df6:90ac". I don't know if this detail is relevant or not but, we are apparently getting into pretty deep technical water here with this problem !

Turning now to your question as the version of "Elyssa" that I am running, I am afraid that I cannot answer this right now because, at this precise minute, I am running Ubuntu 8.04 ("Hardy"). In my ignorance, I thought that saying "Elyssa" was sufficient identification. I know that I am now on the wrong forum but, I understood that "Hardy" and "Elyssa" were the same thing with a different GUI ... please pardon my ignorance if this is wrong. I don't think that this actually matters, since I have exactly the same problem in "Hardy" but, if you want to deal with a particular distro, I'll happily convert back to Elyssa ... please advise if this is necessary.

In my previous post, I indicated that I have been experimenting with this system for a couple of months so I feel that some backgound explanation is necessay. For a number of years now, I have been doing my photo-processing on a machine running Win 2000 and using the same dongle/router combination to connect to the Net. However, I finally got fed up with the steady Windows "bloat" and the consquent degradation of performance ... the machine took 11 minutes just to boot !

So, I bought a more powerful second-hand office machine at a good price and have been setting this up to dual boot (Win XP/Ubuntu) so as to maintain compatibility with old s/w and peripherals whilst at the same time enjoying the security benefits of Linux. Most of the past two months have gone into resolving the problem of compatibility with graphics cards to run dual monitors and I have just now reached a conclusion on this matter. However, during the whole of this time, I have had good connection to the Net. That is the important point.

Then, about a week ago, I lost connection to the Net from inside Hardy, although this has always remained possible when running Win XP.

Naturally, I have tried to recover but completely without success. Finally, in desperation,I installed Elyssa. I purchased this on DVD from an apparently reputable source here in the UK. In an attempt to simplify the experiments, I have effectively stripped the system down to its bare bones so that now all that is connected is keyboard, mouse, graphics tablet and monitor, plus a USB hub with the four extra ports which will be needed later by my photo-peripherals. This latter has been present all of the past months but I mention it now to explain the apparently large number of USB ports. Since I was actually running Mint when I reached a virtual end to my experiments, I posted to this forum.

Now, I view of the fact that I have had satisfactory Net access for about two months, I decided today to finally completely go back to "Square 1" ... so I formatted C:, re-installed Win XP, and then partitioned the drive and installed Mint. This didn't improve matters so, I formatted again, partitioned and then installed Hardy from the original DVD that I used some two months ago. Still no success as of 2100 hrs tonight !

At each step in this lengthy process I have booted into Win XP without problems and confirmed that I have Net access. Naturally, I can boot to the router and can see there my 128-bit encrypted password displayed "in clear" so that I can confirm this is correct. In Mint or Hardy, however, I cannot boot to the router. The screen icon shows "no network connection". I have tried pinging the router but get no response. The one clue that I am getting is that when an attempted connection fails under FireFox, the screen message suggests (along with other ideas) that perhaps a firewall or AV software is incorrectly configured but ... I am not running either of these ... this is a standard clean installation. It was this that lead to my original post since I have no idea how Hardy/Elyssa sets up the firewall which I understand is built in or, how to configure this. It would appear that I have ruled out the possibilty of any hardware malfunction ... which seems to lead to the conclusion that Hardy/Elyssa is just failing to "see" the dongle when a request for Net access is generated. I am afraid that such a question is completely outside my technical competence.

I do apologise for the length of this post but I felt that it will probably save time in the long run to provide all information that is possibly relevant, right at the outset. I thank you for taking the time to study this matter and I now look forward to your further comments in due course.

Very best regards ...

Level 1
Level 1
Posts: 41
Joined: Sun Nov 16, 2008 6:49 pm

Re: WiFi problem -- Elyssaa

Postby hatrack » Sat Nov 22, 2008 11:33 am

Hi All,

Further to my last post, I finally got fed up with struggling to enable WiFi so ... I have taken the easy route to a solution ...Use the built-in LAN card !

I now have absolutely rock-solid virtually instantaneous access. I know that this is a "work-around" ... not a solution to the problem posed but, it is the one that I am going to use from now on.

I now withdraw my enquiry (if this is allowed by the moderators) ... I don't want you kind people looking for a solution to a problem that no longer exists ...

Very best regards to all on this forum

Return to “Newbie Questions”