Page 1 of 1

[SOLVED] All google related sites are REALLY SLOW

Posted: Tue Mar 03, 2015 7:45 pm
by wrek
I can ping them fine

Code: Select all

ping google.com
PING google.com (216.58.219.78) 56(84) bytes of data.
64 bytes from mia07s24-in-f14.1e100.net (216.58.219.78): icmp_seq=1 ttl=57 time=24.9 ms
64 bytes from mia07s24-in-f14.1e100.net (216.58.219.78): icmp_seq=2 ttl=57 time=23.7 ms
64 bytes from mia07s24-in-f14.1e100.net (216.58.219.78): icmp_seq=3 ttl=57 time=24.3 ms
64 bytes from mia07s24-in-f14.1e100.net (216.58.219.78): icmp_seq=4 ttl=57 time=23.9 ms
Tracert

Code: Select all

traceroute6 google.com
traceroute to google.com (2607:f8b0:4008:804::200e) from 2602:306:838c:15e0:a16d:8b08:b67f:327, 30 hops max, 24 byte packets
 1  2602:306:838c:15e0::1 (2602:306:838c:15e0::1)  0.701 ms  0.687 ms  0.602 ms
 2  * 2602:300:c533:1510::36 (2602:300:c533:1510::36)  21.501 ms *
 3  fldfl401me3.ipv6.att.net (2001:1890:ff:ffff:12:122:120:7)  21.299 ms  85.268 ms  60.505 ms
 4  2001:1890:c00:4800::1114:8ba0 (2001:1890:c00:4800::1114:8ba0)  23.406 ms  24.302 ms  23.75 ms
 5  2001:4860::1:0:245b (2001:4860::1:0:245b)  25.162 ms  37.839 ms  24.277 ms
 6  2001:4860:0:1::f3 (2001:4860:0:1::f3)  22.939 ms  23.749 ms  23.689 ms
 7  mia07s24-in-x0e.1e100.net (2607:f8b0:4008:804::200e)  24.191 ms  23.41 ms  24.221 ms
I've tried adding a couple of IP's directly into my hosts file

Code: Select all

74.125.45.100    www.google.com
74.125.29.102	inbox.google.com
No matter what I've tried I can't get to google.com or inbox.google, etc., without serious struggles. The browser just sits there and "waiting for google.com..." for 5-10 minutes before I get a blank screen.

It goes in unpredictable spurts as well. Sometimes it's fast and sometimes no google site loads. I didn't test youtube but I've checked google+, adwords, developer, etc.,

I've tried using Google's 8.8.4.4 and 4.4.4.4 DNS as well.

Any thoughts of what I could try?

Re: All google related sites are REALLY SLOW

Posted: Tue Mar 03, 2015 8:24 pm
by peterldg
Interesting error.

Probably your connection is being MITM by the NSA or GCHQ.

Re: All google related sites are REALLY SLOW

Posted: Tue Mar 03, 2015 8:53 pm
by wrek
Damn NSA... though, interesting to note they don't seem to care how much **** I stream... hmmmm

Re: All google related sites are REALLY SLOW

Posted: Tue Mar 03, 2015 9:34 pm
by Mute Ant
The lynx console-browser is a handy tool for when the internet is working but your Xorg or GUI or Browser is out of action. No graphics, popups, java, capchas :? just text and links.

Re: All google related sites are REALLY SLOW

Posted: Wed Mar 04, 2015 7:51 pm
by wrek
Well I can't get lynx to work for me...
Google.com opens fast but any search takes a long time. If I try going to gmail or something, it's really slow.

Does anyone know anything else I could check?

Re: All google related sites are REALLY SLOW

Posted: Fri Mar 20, 2015 9:00 am
by wrek
Update for anyone else finding this issue via Google:

Disabling IPv6 fixed this issue for me.

http://www.binarytides.com/disable-ipv6-ubuntu/

Basically I just added this to the file /etc/sysctl.conf

so at shell:

Code: Select all

sudo gedit /etc/sysctl.conf
or gksudo or vim or whatever your file editor is...

Add this text to the bottom:

Code: Select all

# IPv6 disabled
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1
restart sysctrl from shell:

Code: Select all

sudo sysctl -p

Re: [SOLVED] All google related sites are REALLY SLOW

Posted: Sat Mar 21, 2015 4:45 am
by Ceilidh2
Oh yeah!

That works for me too.

Re: [SOLVED] All google related sites are REALLY SLOW

Posted: Sat Mar 21, 2015 10:52 am
by Reorx
OMG - thank you Wrek. I have been wrestling with this problem for a while... had all devices on my LAN plagued by this problem. Started a thread here over a month ago looking for a solution (http://forums.linuxmint.com/viewtopic.p ... 62#p981662).

1 piece of additional information - if you are like me and all the devices on your LAN are affected by this problem - disabling IPv6 at the router and then rebooting the router fixed the problem for all the devices on my LAN.

Thanx again!... Enjoy the Mint! :mrgreen:

P.S.: Might want to change this slightly >

Code: Select all

sudo gedit /etc/sysctl.conf
Since gedit is graphical program, gksu or gksudo (instead of "sudo") might be a better idea... just sayin'... :mrgreen:

Re: [SOLVED] All google related sites are REALLY SLOW

Posted: Sat Mar 21, 2015 6:43 pm
by wrek
Glad to help. I asked over on reddit and someone there told me about the solution so I thought I'd come share =D I hate when people solve issues then never come tell anyone what the solution was...

Re: All google related sites are REALLY SLOW

Posted: Sun Mar 22, 2015 12:19 am
by MtnDewManiac
peterldg wrote:Interesting error.

Probably your connection is being MITM by the NSA
Interesting (or, perhaps, not) side note: That agency is the one that gave the linux world the patches and utilities which make up "Security-Enhanced Linux" way back in 2000. Most distros (including Mint, IIRC) use them.

Someone once speculated to me that the only reason such an entity would unleash err, gift such a thing to the public would be to ensure that no one invented something else in its place that said entity might not be able to go through like a supernova would go through a pat of warm butter. Personally... IDK, but if a known peeping Tom makes you a gift of new blinds/curtains for your daughter's bedroom, I wouldn't expect them to have been given for 100% altruistic purposes ( :roll: :lol: ). In any case, since it is now 15 years later, it probably doesn't matter as computers have gotten much more powerful (and government budgets in certain areas much larger).

I wouldn't bother encrypting your data (with any "stock" or publicly available means) unless you are just trying to keep it out of the hands of the neighbor's ten-year old. And there are better means to achieve that goal, lol.

Regards,
MDM