Wobbly Windows doesn't do anything?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
eiger3970
Level 4
Level 4
Posts: 278
Joined: Thu Jul 19, 2012 9:48 am

Wobbly Windows doesn't do anything?

Post by eiger3970 »

Hello, how to make Wobbly Windows work?
I open Mint 17.1 Control Centre > Personal > CompizConfig Settings Manager > Effects > tick Wobbly Windows > Close > reboot, but no effects?
My machine specs:
Linux Mint 19 Tara 64-bit.
Kernel Linux 4.15.0-54-generic x86_64
MATE 1.20.1
Memory: 1.9 GiB
Processor: Intel Celeron(R) CPU N3060 @ 1.6GHz x 2
User avatar
richyrich
Level 19
Level 19
Posts: 9057
Joined: Mon May 04, 2009 8:31 pm

Re: Wobbly Windows doesn't do anything?

Post by richyrich »

Run this terminal command:

Code: Select all

compiz --replace
You may also need to enable the Window Decorations in compiz settings manager.
eiger3970
Level 4
Level 4
Posts: 278
Joined: Thu Jul 19, 2012 9:48 am

Re: Wobbly Windows doesn't do anything?

Post by eiger3970 »

Awesome! That fixed it.
I ran $ compiz --replace, and the computer screen flashed and went black.
Wobbly Windows didn't work.
I rebooted and Wobbly Windows didn't work.

I ran $ compiz --replace, and after 60 seconds the Wobbly Windows effect works!

Thanks richyrich! (scary profile photo though?)
My machine specs:
Linux Mint 19 Tara 64-bit.
Kernel Linux 4.15.0-54-generic x86_64
MATE 1.20.1
Memory: 1.9 GiB
Processor: Intel Celeron(R) CPU N3060 @ 1.6GHz x 2
eiger3970
Level 4
Level 4
Posts: 278
Joined: Thu Jul 19, 2012 9:48 am

Re: Wobbly Windows doesn't do anything?

Post by eiger3970 »

Sorry, false alarm.
Wobbly windows doesn't work again.
Worked as per step above, however now after reboots, Wobbly Windows doesn't show the effect.
The effect is selected though?
My machine specs:
Linux Mint 19 Tara 64-bit.
Kernel Linux 4.15.0-54-generic x86_64
MATE 1.20.1
Memory: 1.9 GiB
Processor: Intel Celeron(R) CPU N3060 @ 1.6GHz x 2
eiger3970
Level 4
Level 4
Posts: 278
Joined: Thu Jul 19, 2012 9:48 am

Re: Wobbly Windows doesn't do anything?

Post by eiger3970 »

Well, refreshing this issue as I have installed Mint 18 MATE 64-bit and Wobbly Windows still doesn't work?
Yes, Wobbly Windows is installed and enabled.
My machine specs:
Linux Mint 19 Tara 64-bit.
Kernel Linux 4.15.0-54-generic x86_64
MATE 1.20.1
Memory: 1.9 GiB
Processor: Intel Celeron(R) CPU N3060 @ 1.6GHz x 2
User avatar
atari800
Level 3
Level 3
Posts: 152
Joined: Thu Aug 16, 2012 10:59 pm

Re: Wobbly Windows doesn't do anything?

Post by atari800 »

*Currently NOT in front of a Linux Mint machine but...

In STARTUP APPLICATIONS app, add this
compiz --replace&

*yes include the ampersand
Deja VU: When you get killed and restart your life at a saved point in time
Always research any suggestions given to you.
Admins: Please delete my inappropriate/destructive posts - you have my authorization
deleted

Re: Wobbly Windows doesn't do anything?

Post by deleted »

Your graphics card might not support it.
As I recall, it was something like OpenGL 3 (or greater) [at least on KDE]
-H
eiger3970
Level 4
Level 4
Posts: 278
Joined: Thu Jul 19, 2012 9:48 am

Re: Wobbly Windows doesn't do anything?

Post by eiger3970 »

Refreshing issue again.

I run command $ compiz --replace and Wobbly Windows works, so the graphics card is fine.
Reboot and Wobbly Windows is gone.
I entered Startup command in Linux Mint MATE > Panel > Menu > Control Centre > Personal > Startup Applications > Add > Name: Compiz > Command: - compiz -replace > Comment: Run Compiz at Startup > Save > Reboot, but still fails.
My machine specs:
Linux Mint 19 Tara 64-bit.
Kernel Linux 4.15.0-54-generic x86_64
MATE 1.20.1
Memory: 1.9 GiB
Processor: Intel Celeron(R) CPU N3060 @ 1.6GHz x 2
eiger3970
Level 4
Level 4
Posts: 278
Joined: Thu Jul 19, 2012 9:48 am

Re: Wobbly Windows doesn't do anything?

Post by eiger3970 »

Ok working after reboot with correct command in startup applications compiz --replace.

Now all I have to do is add this note to add into the Startup Applications when I do fresh OS installs.
Here's the complete walkthrough:

Wobbly windows:
1 of 3: install:
Terminal > $ sudo apt-get install compiz-plugins-extra > Enter >
2 of 3: control centre:
Linux Mint > Panel > Menu > Control Centre > Look and Feel > CompizConfig Settings Manager > Effects > tick Wobbly Windows > Close >
3 of 3: startup applications:
Linux Mint > Panel > Menu > Control Centre > Personal > Startup Applications > Startup Programs > Add > Name: Compiz > Command: compiz --replace > Comment: Run Compiz at startup > Save > Close > Reboot > test.
My machine specs:
Linux Mint 19 Tara 64-bit.
Kernel Linux 4.15.0-54-generic x86_64
MATE 1.20.1
Memory: 1.9 GiB
Processor: Intel Celeron(R) CPU N3060 @ 1.6GHz x 2
rickNS
Level 5
Level 5
Posts: 852
Joined: Tue Jan 25, 2011 11:59 pm

Re: Wobbly Windows doesn't do anything?

Post by rickNS »

Try it the easy way...
Menu > Control center > Desktop Settings > Windows
There, select the "Window Manager" to be Compiz
Close

That should "stick" through reboots.
No need for any startup program.
No need to install compiz-plugins-extra either.
Works for me, got video.
Mint 19.0 mate on 2 identical Thinkpad T420's
User avatar
zcot
Level 6
Level 6
Posts: 1165
Joined: Wed Oct 19, 2016 6:08 pm

Re: Wobbly Windows doesn't do anything?

Post by zcot »

rickNS wrote:
Sat Jan 18, 2020 11:55 pm
Try it the easy way...
Menu > Control center > Desktop Settings > Windows
There, select the "Window Manager" to be Compiz
Close

That should "stick" through reboots.
No need for any startup program.
No need to install compiz-plugins-extra either.
Works for me, got video.
That works the same on Xfce. Just change the Window Manager then go play in the CCSM and you're good.
Post Reply

Return to “Newbie Questions”