Could not download all repository indexes

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
dietolive
Level 1
Level 1
Posts: 31
Joined: Mon Mar 23, 2009 1:24 pm
Location: Croatia

Could not download all repository indexes

Post by dietolive » Wed Aug 19, 2015 6:15 am

Hello everybody,
I am trying to Install Updates but always get this error. Please look at the attachment.
Please can you help me? Thank you very much!

ps: Using LinuxMint 16.
Attachments
error.jpeg
Linux Mint 17.3

User avatar
kc1di
Level 14
Level 14
Posts: 5334
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Could not download all repository indexes

Post by kc1di » Wed Aug 19, 2015 6:22 am

Hello dietolive,
Which version of Mint are you using?

the failed repositories are from ubuntu 13.10 and that has been end of life for about half a year now. and the repositories have been turned off.
That's why your not able to update from them.

You should upgrade to mint 17.2.
Easy tips : https://easylinuxtipsproject.blogspot.com/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

dietolive
Level 1
Level 1
Posts: 31
Joined: Mon Mar 23, 2009 1:24 pm
Location: Croatia

Re: Could not download all repository indexes

Post by dietolive » Wed Aug 19, 2015 6:26 am

kc1di, thank you for helping.
I am using LM16.
OK, I will try to upgrade. Can I do that directly from LM16?
Linux Mint 17.3

User avatar
Pjotr
Level 21
Level 21
Posts: 13510
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Could not download all repository indexes

Post by Pjotr » Wed Aug 19, 2015 6:27 am

dietolive wrote:I am using LM16.
OK, I will try to upgrade. Can I do that directly from LM16?
No. Clean install is the way to go. :)
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
kc1di
Level 14
Level 14
Posts: 5334
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Could not download all repository indexes

Post by kc1di » Wed Aug 19, 2015 6:28 am

Pjotr wrote:
dietolive wrote:I am using LM16.
OK, I will try to upgrade. Can I do that directly from LM16?
No. Clean install is the way to go. :)
I agree do a clean install. -- Hi Pjotr
Easy tips : https://easylinuxtipsproject.blogspot.com/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

dietolive
Level 1
Level 1
Posts: 31
Joined: Mon Mar 23, 2009 1:24 pm
Location: Croatia

Re: Could not download all repository indexes

Post by dietolive » Wed Aug 19, 2015 9:38 am

Thank you both very much! :)
Linux Mint 17.3

Woods
Level 1
Level 1
Posts: 18
Joined: Fri Jun 19, 2015 12:47 pm

Re: Could not download all repository indexes

Post by Woods » Wed Aug 19, 2015 10:23 pm

Hi,

I've been getting a similar error, look at the attachment.
Screenshot-2.png
Is this some unofficial package I installed that no longer is updated??

How may I know that? Thnks in advance!

User avatar
Pjotr
Level 21
Level 21
Posts: 13510
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Could not download all repository indexes

Post by Pjotr » Thu Aug 20, 2015 4:20 am

Woods wrote:Hi,

I've been getting a similar error, look at the attachment.
Screenshot-2.png
Is this some unofficial package I installed that no longer is updated??

How may I know that? Thnks in advance!
Deceased PPA..... it happens, with those unofficial software sources. Simply remove it from your sources list. :)
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
riki
Level 4
Level 4
Posts: 448
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK
Contact:

Re: Could not download all repository indexes

Post by riki » Sun Aug 30, 2015 11:10 am

I am running LM13 Maya and been getting the same error message for the last few months. It would be nice to be able to eliminate such annoying message each time there is an update. There must be a way without doing a clean install/upgrade. I am quite happy with Maya LTS which is supported until 2017.
Last edited by riki on Tue Sep 01, 2015 3:01 am, edited 1 time in total.

User avatar
Pjotr
Level 21
Level 21
Posts: 13510
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Could not download all repository indexes

Post by Pjotr » Sun Aug 30, 2015 11:57 am

riki wrote:I am running LM13 Maya and been getting the same error message for the last few months. It didn't happen before and I don't have any PPAs. It would be nice to be able to eliminate such annoying message each time there is an update. There must be a way without doing a clean install/upgrade. I am quite happy with Maya LTS which is supported until 2017.
What does this command give:

Code: Select all

inxi -r
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
riki
Level 4
Level 4
Posts: 448
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK
Contact:

Re: Could not download all repository indexes

Post by riki » Sun Aug 30, 2015 12:16 pm

Pjotr wrote:
riki wrote:I am running LM13 Maya and been getting the same error message for the last few months. It didn't happen before and I don't have any PPAs. It would be nice to be able to eliminate such annoying message each time there is an update. There must be a way without doing a clean install/upgrade. I am quite happy with Maya LTS which is supported until 2017.
What does this command give:

Code: Select all

inxi -r
Thanks for coming in Pjotr. This is what I get:
inxi.png

User avatar
Pjotr
Level 21
Level 21
Posts: 13510
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Could not download all repository indexes

Post by Pjotr » Sun Aug 30, 2015 1:16 pm

riki wrote: Thanks for coming in Pjotr. This is what I get:
inxi.png
You have three non-official sources, one of which is a PPA:
- grub-customizer;
- Chrome;
- some Epson thingy.

The Chrome repo is a very professional source, so I don't expect it to create problems. But the grub-customizer PPA and the Epson source are another matter.

What exactly is the error message you get?
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
riki
Level 4
Level 4
Posts: 448
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK
Contact:

Re: Could not download all repository indexes

Post by riki » Sun Aug 30, 2015 1:34 pm

Error 404.jpeg
Pjotr wrote:
riki wrote: Thanks for coming in Pjotr. This is what I get:
The attachment inxi.png is no longer available
You have three non-official sources, one of which is a PPA:
- grub-customizer;
- Chrome;
- some Epson thingy.

The Chrome repo is a very professional source, so I don't expect it to create problems. But the grub-customizer PPA and the Epson source are another matter.

What exactly is the error message you get?
There are 3 issues in the error message. At the moment all I can
Error 404.jpeg
show you is a screenshot which only reveals the first issue. I will scroll down and copy when I next get the error.

User avatar
riki
Level 4
Level 4
Posts: 448
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK
Contact:

Re: Could not download all repository indexes

Post by riki » Sun Aug 30, 2015 1:44 pm

riki wrote:
Error 404.jpeg
Pjotr wrote:
riki wrote: Thanks for coming in Pjotr. This is what I get:
inxi.png
You have three non-official sources, one of which is a PPA:
- grub-customizer;
- Chrome;
- some Epson thingy.

The Chrome repo is a very professional source, so I don't expect it to create problems. But the grub-customizer PPA and the Epson source are another matter.

What exactly is the error message you get?
There are 3 issues in the error message. At the moment all I can
Error 404.jpeg
show you is a screenshot which only reveals the first issue. I will scroll down and copy when I next get the error.
Epson has been there since day one, so I don't think it's the culprit. Should I remove grub-customizer without the risk of breaking something?

User avatar
Pjotr
Level 21
Level 21
Posts: 13510
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Could not download all repository indexes

Post by Pjotr » Sun Aug 30, 2015 1:49 pm

The only side effect of removing a software source is, that you won't get any updates anymore for the software that you once installed from that source.
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
riki
Level 4
Level 4
Posts: 448
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK
Contact:

Re: Could not download all repository indexes

Post by riki » Sun Aug 30, 2015 1:52 pm

Pjotr wrote:The only side effect of removing a software source is, that you won't get any updates anymore for the software that you once installed from that source.
OK thanks. I'll remove the grub-customizer before the next update and see what happens. Appreciate your help.

User avatar
riki
Level 4
Level 4
Posts: 448
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK
Contact:

Re: Could not download all repository indexes

Post by riki » Mon Aug 31, 2015 2:28 am

Two error messages:
Screenshot-5.png
Failed to fetch http://packages.mate-desktop.org/repo/u ... ce/Sources 404 Not Found
Failed to fetch http://packages.mate-desktop.org/repo/u ... 6/Packages 404 Not Found
Some index files failed to download. They have been ignored, or old ones used instead.

User avatar
riki
Level 4
Level 4
Posts: 448
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK
Contact:

Re: Could not download all repository indexes

Post by riki » Mon Aug 31, 2015 3:12 am

I have removed "grub-customizer" but the error messages are still there.

User avatar
Pjotr
Level 21
Level 21
Posts: 13510
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Could not download all repository indexes

Post by Pjotr » Mon Aug 31, 2015 4:10 am

Try another mirror server (can be done in Software Sources).
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

grizzler
Level 5
Level 5
Posts: 657
Joined: Wed Jun 15, 2011 5:19 pm
Location: The Hague, NL

Re: Could not download all repository indexes

Post by grizzler » Mon Aug 31, 2015 4:51 am

@riki
It seems there aren't any repositories for ubuntu under packages.mate-desktop.org, so you might as well remove that one.

Post Reply

Return to “Newbie Questions”