Page 3 of 3

Re: Solid state drive optimization

Posted: Sun Oct 04, 2015 10:43 am
by Pjotr
siawacsh wrote:problems with a HP laserjet 1018
This should solve them (I have an HP LaserJet 1018 myself):
https://sites.google.com/site/easylinux ... 6-to-1028-
(item 3, left column)

Re: Solid state drive optimization

Posted: Sun Oct 04, 2015 12:23 pm
by siawacsh
That solution seemed to be going well in that it installed and printed a test page. But when I rebooted I got the old usb error from days before and now cannot access my new installation.

Code: Select all

an error occurred while mounting /proc/bus/usb"
I remember another user commented that the problem has to do with FSTAB. I am going to study those articles in detail to see what can be done. Your thoughts would be appreciated. But I have lost a day already installing this.

Here is my FSTAB in case you can think of something.

Code: Select all

siawacsh@siawacsh-sager /media/siawacsh/24def9f7-44ed-4d2a-ba06-10ea9e1a95bb/etc $ cat fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb1 during installation
UUID=24def9f7-44ed-4d2a-ba06-10ea9e1a95bb /               ext4 noatime,errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=de9dd3d6-196c-4477-af08-3e2a3dea2b4a none            swap    sw              0       0
none /proc/bus/usb usbfs devgid=125,devmode=664 0 0
siawacsh@siawacsh-sager /media/siawacsh/24def9f7-44ed-4d2a-ba06-10ea9e1a95bb/etc

Re: Solid state drive optimization

Posted: Sun Oct 04, 2015 12:35 pm
by siawacsh
It is very strange. When I cat out fstab I get the above. But when I open fstab in gedit I get the following. Notice the first has one extra line.

Code: Select all


# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=d07155fe-e6d8-4756-93d2-fe1db2ab3812 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda6 during installation
UUID=6b5e05c2-f17d-49ad-8eea-33961a1bb7d3 /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=de9dd3d6-196c-4477-af08-3e2a3dea2b4a none            swap    sw              0       0

According with one of the documentation this is the trouble maker

Code: Select all

none /proc/bus/usb usbfs devgid=125,devmode=664 0 0
I can see that line when cat out fstab but not so when I open it in gedit

Re: Solid state drive optimization

Posted: Sun Oct 04, 2015 12:46 pm
by siawacsh
Hello Pjotr, I found the this line in my FSTAB and removed it.

Code: Select all


none /proc/bus/usb usbfs devgid=125,devmode=664 0 0


I also managed to boot into my system and printer is working. Thanks for you help. I know you are doing your best, which no one else seems to be prepared to do. Good on you! If this printer continues to work you would have saved me €100 on a new printer.

Re: Solid state drive optimization

Posted: Sun Oct 04, 2015 12:57 pm
by Pjotr
That /proc/bus/usb line in your fstab is weird. I think it's good that you removed it. Do you have any idea how it got there?

Re: Solid state drive optimization

Posted: Sun Oct 04, 2015 5:56 pm
by siawacsh
I used Ron-N, link to trouble shoot the USB issue.

Code: Select all

https://ubuntugenius.wordpress.com/2010/05/07/fix-an-error-occurred-while-mounting-procbususb-bootup-error-after-upgrade-to-lucid/
It seems it has something to do with Virtualbox. Not sure exactly what. Maybe the fact that I have to use Virtualbox 4.3 in order for it to work with Robolinux's windows emulator.

Re: Solid state drive optimization

Posted: Mon Oct 05, 2015 4:29 am
by Pjotr
OK.... Well, I think by removing that fstab line, the cause for your boot failures has been found and fixed. Quite unrelated to my SSD how-to, thankfully. :mrgreen:

Re: Solid state drive optimization

Posted: Sun Oct 11, 2015 12:16 pm
by xfrank
Interesting thread. I've followed in particulary Pyotr's advices here and in his site: https://sites.google.com/site/easylinuxtipsproject/ssd.
Just two points:
1 - for me, the default weekly cronjob for trim is enough. I can do extra trim actions manually.
2 - I set swappiness to 10 (I have only 2GB ram)
3 - I set Firefox cache to ram instead of 0 cache.

I'm not sure, however, if point 3 is good, bad or neutral. Several guys recommend to keep the cache on the SSD because is not harmful, and improve browsing performance. Other says that yes, is bad for the SSD's lifespan and must be moved to RAM. What's your opinion?