Page 1 of 1

Need to change graphics driver but can't get in [SOLVED]

Posted: Sun Nov 22, 2015 8:15 am
by gibbs1984
So I've had a problem running a game natively via Steam, it was a graphics issue and I figured out that changing the drivers from the recommended drivers to the 304 drivers made the game work.

That driver was a little bit choppy so I thought I'd try the other drivers, trying the 173 (I think) driver now means that I have no graphical interface and I'm at the tty1 login screen.

How can I revert back to another driver as I can't access the Driver GUI application.

Need to change graphics driver but can't get into Mint

Posted: Sun Nov 22, 2015 8:29 am
by gibbs1984
It's OK, I fixed it by following the below that I found on the internet.

I logged in as root first, no idea if that is needed though.
For 14.04 and upwards, jockey-text isn't installed or available in the repository. I have just recovered from an issue where the Noveau driver caused my computer to lockup completely after logging in and I needed to go back to the nvidia driver. Here's how I did it:

At the login screen, instead of logging in I went to a terminal using CRL + ALT + F2 Type

ubuntu-drivers devices

to get a list of your devices and identify the one you want. My output looked like this:

$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00000391sv00001462sd00000630bc03sc00i00
vendor : NVIDIA Corporation
model : G73 [GeForce 7600 GT]
driver : nvidia-304 - distro non-free recommended
driver : nvidia-173 - distro non-free
driver : xserver-xorg-video-nouveau - distro free builtin
driver : nvidia-304-updates - distro non-free

I wanted nvidia-304 so I typed:

apt-get install nvidia-304

Then I rebooted and confirmed using the desktop appliaction Additional Drivers that I was indeed using the driver I had chosen.
I'm back in now.

This is the link to place where I found the above:

http://askubuntu.com/questions/319671/h ... a-terminal