Need apt-get to fetch updated version of sextractor to in...

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
andrejfavia
Level 1
Level 1
Posts: 40
Joined: Thu Aug 16, 2012 10:04 am

Need apt-get to fetch updated version of sextractor to in...

Post by andrejfavia » Mon Dec 21, 2015 3:36 pm

Need apt-get to fetch updated version of sextractor to install it


Greetings.

I need apt-get to fetch updated version of sextractor to install it. Currently apt-get tries to install 2.8.6, whereas the current version is 2.19.5.

The software is: https://www.astromatic.net/software/sextractor

So, I tried to look up some other directions to install it, using gcc, FFTW (which I assume is under libfftw-dev), and ATLAS, and then doing a ./configure on the sextractor code.

But that doesn't work. I have tried to go through this process on a few machines and OSs in years' past. With each time that I go through this process from a fresh install, and following the same directions, something goes wrong, but each time it's a different "something." So, I've tried following other people's directions, but they don't work either, which leaves me to guess my way through each installation to figure out why and I'm just confused.

Meanwhile, it would just be easier if someone would submit a formula to have 2.19.5 automatically install and download any extra libraries, and to utilize dual core.

I can attempt to troubleshoot how to get sextractor 2.19.5 to work from Linux Mint 17.2 (somewhat fresh copy), but I will be away from the test machine over the new year's break. Anyway, how do I request an updated formula?

cwsnyder
Level 6
Level 6
Posts: 1242
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Need apt-get to fetch updated version of sextractor to i

Post by cwsnyder » Mon Dec 21, 2015 4:14 pm

You seem to be totally confused on how software for Linux is distributed. dpkg , apt , apt-get , Software Center, and/or Synaptic only install from the distribution packaged files which have been tested to work on Linux Mint, which version 2.8.6 has been.

Occasionally someone wants a newer package of files, have some programming experience, and puts together a Personal Package Archive (or PPA) which can be shared and used on both Ubuntu and main line Linux Mint. These have not been extensively tested, but have been compiled to executable format, and have package dependencies listed so that dpkg, apt, et. al. can properly link the libraries on which it depends and can update the files if newer ones become available from those PPAs.

Random packages off the Internet, unlike with Windows, are not usually distributed in executable file format. Normally they are distributed in source code format which must be compiled and linked to become executable and may or may not have the proper library dependencies listed and available. Also unstated, you must have the proper development packages for the Linux kernel on which you are attempting to install so that the links to the proper system calls are made. Further reading here: http://packaging.ubuntu.com/html/ . Ubuntu and Debian provide most of the packages for the Mint libraries.

Basically, if you need the latest package and do not find it supported in PPA or form or available from the distro packaging via apt-get you have 2 choices: Learn enough to install the source: http://www.howtogeek.com/105413/how-to- ... on-ubuntu/ , https://help.ubuntu.com/community/CompilingEasyHowTo . Or talk a programmer who is interested into installing it for you.
LMDE Mate 64-bit, LM17.3 Cinnamon 64-bit
Debian Mate 64-bit, Xubuntu xenial 64-bit, Ubuntu-Mate 14.04 64-bit, Antergos Xfce 64-bit, PCLinuxOS Mate 64-bit

User avatar
jimallyn
Level 18
Level 18
Posts: 8945
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Need apt-get to fetch updated version of sextractor to i

Post by jimallyn » Mon Dec 21, 2015 6:45 pm

Sometimes - but not always - you can convert an RPM file to a .deb with alien. You might give that a shot. Else, it's compile from source.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

andrejfavia
Level 1
Level 1
Posts: 40
Joined: Thu Aug 16, 2012 10:04 am

Re: Need apt-get to fetch updated version of sextractor to i

Post by andrejfavia » Tue Jan 19, 2016 8:59 am

So, how do I request that version 2.19.5 be tested? That's what I'm asking.

As for source, when I have tried to install it from source, from experiences in the past, I keep getting all kinds of errors. Something goes wrong, but each time it's a different "something." So, I've tried following other people's directions, but they don't work either. For instance, it might be a problem with dependencies LAPACK or CBLAS, or I get make[...] errors that have no explanation for what the problem is, so I'm guessing at what to do.

So, what is the proper forum to ask these questions to troubleshoot the installation?

cwsnyder
Level 6
Level 6
Posts: 1242
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Need apt-get to fetch updated version of sextractor to i

Post by cwsnyder » Sat Jan 23, 2016 10:14 pm

andrejfavia wrote:So, how do I request that version 2.19.5 be tested? That's what I'm asking.
This is probably the place to request that, but your request subject is poorly formulated and no interest was generated.

You can probably test the version in Linux Mint by following this procedure, which worked for me to at least install 2.19.5 on my computer:
First, download the sextractor-2.19.5-1.x86_64.rpm file from http://www.astromatic.net/software/sextractor or by clicking the following link http://www.astromatic.net/download/sext ... x86_64.rpm
Next, install the alien package on Mint to allow translation of an RPM package to a DEB package with dpkg on Mint. I used the following in a terminal to install both alien and all recommended dependencies.

Code: Select all

sudo apt-get update
sudo apt-get install alien --install-suggests
The following terminal code then translates the RPM package to a DEB package, assuming your RPM package is in the ~/Downloads/ folder.

Code: Select all

sudo alien --to-deb ~/Downloads/sextractor-2.19.5-1.x86_64.rpm
This should leave your new .DEB package in the folder your terminal is using as default (probably ~). To install the new DEB package, you can double-click on the filename.deb file (should be sextractor-2.19.5-2.x86-64.deb) or use the following terminal code.

Code: Select all

sudo dpkg -i sextractor-2.19.5-2.x86_64.deb
You should now be able to run the program from the terminal by typing in sextractor or find it in your menu.
LMDE Mate 64-bit, LM17.3 Cinnamon 64-bit
Debian Mate 64-bit, Xubuntu xenial 64-bit, Ubuntu-Mate 14.04 64-bit, Antergos Xfce 64-bit, PCLinuxOS Mate 64-bit

andrejfavia
Level 1
Level 1
Posts: 40
Joined: Thu Aug 16, 2012 10:04 am

Re: Need apt-get to fetch updated version of sextractor to in...

Post by andrejfavia » Thu Mar 03, 2016 11:15 am

Well I was able to install alien, and when I double-click on the .deb file and ask it to install, it tells me:

"Package `sextractor_2.19.5-2_amd64.deb' was installed."

But when I type

sextractor

into a Terminal window, it tells me: "The program 'sextractor' is currently not installed."

So, what's going on?


Also, I was trying to install sextractor by hand using the "brute force" method of installing gcc, fftw, atlas... the problem is when I try to run make on fftw 3.3.4, using the source code located at

http://www.fftw.org/download.html

I receive error message, and I am not sure where to ask questions to get help on this. For example, using the brute force method, I receive this error message:

"../libtool: line 1088: /usr/bin/ranlib: cannot execute binary file: Exec format error
make[2]: *** [libkernel.la] Error 126
make[2]: Leaving directory `/home/mintuser/Desktop/fftw-3.3.4/kernel'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/mintuser/Desktop/fftw-3.3.4'
"

When I type

ranlib

into the Terminal window, I receive the following error message:

bash: /usr/bin/ranlib: cannot execute binary file: Exec format error

So, it seems that ranlib is getting in the way of my installing fftw and sextractor.

How do I fix this?

Mute Ant
Level 14
Level 14
Posts: 5135
Joined: Tue Sep 03, 2013 7:45 pm
Location: Norfolk UK

Re: Need apt-get to fetch updated version of sextractor to in...

Post by Mute Ant » Thu Mar 03, 2016 5:55 pm

Via the RPM -> DEB route, just as you have already...

SExtractor version 2.19.5 (2014-03-19)
SYNTAX: sex <image> [<image2>][-c <configuration_file>][-<keyword> <value>]

...not sextractor notice, just plain sex --smirk--

https://wikis.bris.ac.uk/display/astro/Sextractor
While you're waiting, read the free novel we sent you. It's a Spanish story about a guy named "manual".

andrejfavia
Level 1
Level 1
Posts: 40
Joined: Thu Aug 16, 2012 10:04 am

Re: Need apt-get to fetch updated version of sextractor to in...

Post by andrejfavia » Fri Mar 04, 2016 10:25 am

But what about FFTW and the issues with ranlib?

andrejfavia
Level 1
Level 1
Posts: 40
Joined: Thu Aug 16, 2012 10:04 am

Re: Need apt-get to fetch updated version of sextractor to in...

Post by andrejfavia » Tue Mar 22, 2016 11:42 am

Greetings again.

I have not yet received a response to my question about why a direct installation of FFTW fails with an error message about ranlib. Can someone help me?

Hoser Rob
Level 14
Level 14
Posts: 5439
Joined: Sat Dec 15, 2012 8:57 am

Re: Need apt-get to fetch updated version of sextractor to in...

Post by Hoser Rob » Tue Mar 22, 2016 1:00 pm

No one who knows anythng is going to be particularly interested in how to make an rpm package install in a debian based system like Mint. If the people who develop it can't be bothered ... the Debian packaging system as used by ubuntu/mint/many others is the most common one by far AFAIK ... why should they? Installing rpm packages in a ubuntu/mint install is possible but unreliable. I certainly couldn't be bothered.

As mentioned in an earlier post, you ask unreasonable questions and apparently don't read the answers.

If you really need it that much install Fedora. But good luck getting your hand held on their tech support, or any rpm based distro I know of.

andrejfavia
Level 1
Level 1
Posts: 40
Joined: Thu Aug 16, 2012 10:04 am

Re: Need apt-get to fetch updated version of sextractor to in...

Post by andrejfavia » Fri Mar 25, 2016 11:38 am

Hoser Rob wrote:As mentioned in an earlier post, you ask unreasonable questions and apparently don't read the answers.
No I do not ask unreasonable questions. And I DO read the answers. Why are you being rude? How do you feel when you get wrongly accused?

Nor was I asking about rpm. I was clearly asking about FFTW and ranlib.

What does Debian has to do with any of this when I have already established that it provided me with an outdated version of Source Extractor and I am trying to install the current version manually?

Can you help... why does my compile-from-source method fail?

andrejfavia
Level 1
Level 1
Posts: 40
Joined: Thu Aug 16, 2012 10:04 am

Re: Need apt-get to fetch updated version of sextractor to in...

Post by andrejfavia » Fri Apr 22, 2016 1:51 pm

[...4 weeks later...]

Greetings once again!

I still don't have an answer. Can someone answer me concerning FFTW and ranlib?

User avatar
Tomgin5
Level 5
Level 5
Posts: 933
Joined: Sat Mar 19, 2016 2:37 pm
Location: Beaverton, Oregon USA

Re: Need apt-get to fetch updated version of sextractor to in...

Post by Tomgin5 » Tue Apr 26, 2016 4:45 pm

Sorry! It looked like the thread diverged a couple of months back. just before you split and asked the last question it looked like you were not responding to the questions of those trying to help you. Keep it light!!! Maybe an accumulated :? :lol: bug in the "sextractor".

User avatar
Tomgin5
Level 5
Level 5
Posts: 933
Joined: Sat Mar 19, 2016 2:37 pm
Location: Beaverton, Oregon USA

Re: Need apt-get to fetch updated version of sextractor to in...

Post by Tomgin5 » Tue Apr 26, 2016 10:19 pm

Try re reading the manual and instructions from the original manual at the site, I think you got the program from.
It went right in on my LM17.3 Cinnimon64. I had a bit of a problem with the * .rpm file but I used the same method on it as I used on my Xerox printer with the factory Linux driver. It runs very similar and looks much fancier than the one I still have in my old commodore 64. It runs off of a floppy. :shock:
BTW is is a nice astronomical studies program.

https://www.astromatic.net/pubsvn/softw ... sextractor.

andrejfavia
Level 1
Level 1
Posts: 40
Joined: Thu Aug 16, 2012 10:04 am

Re: Need apt-get to fetch updated version of sextractor to in...

Post by andrejfavia » Mon May 09, 2016 9:44 am

Well the only way that I have gotten SExtractor 2.19.5 to install, is not through sudo apt-get, since all that did was install the OLD version (2.8.6), but by downloading the .rpm file and converting it via alien, just as you did. That was the only way that it would work.

So, can someone recommend another website where I can ask about FFTW/ranlib in case I ever need to compile it myself without alien? And where in the manual does it tell me why FFTW and ran lib aren't cooperating?

Post Reply

Return to “Newbie Questions”