Getting wifi working with a atheros card

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
pfd27
Level 2
Level 2
Posts: 90
Joined: Sun Feb 15, 2015 11:13 am

Getting wifi working with a atheros card

Post by pfd27 » Mon Dec 28, 2015 9:04 pm

Hi Guys

I just bought a Lenovo G50 laptop today and I cant get the wifi to work.
I have searched it and tried a few things including installing a 4.2 kernel, but
have had no luck yet. Any help would be wonderful

JeremyB
Level 20
Level 20
Posts: 11106
Joined: Fri Feb 21, 2014 8:17 am

Re: Getting wifi working with a atheros card

Post by JeremyB » Mon Dec 28, 2015 9:08 pm

What Atheros card? Post the result from terminal for

Code: Select all

lspci -nnk | grep -iA2 net; uname -a
There are some new ones out that I know how to get going

User avatar
pfd27
Level 2
Level 2
Posts: 90
Joined: Sun Feb 15, 2015 11:13 am

Re: Getting wifi working with a atheros card

Post by pfd27 » Mon Dec 28, 2015 9:15 pm

rob@rob-Lenovo ~ $ lspci -nnk | grep -iA2 net; uname -a
01:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:0041] (rev 20)
Subsystem: Lenovo Device [17aa:3545]
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
Subsystem: Lenovo Device [17aa:3812]
Kernel driver in use: r8169
Linux rob-Lenovo 4.2.0-22-generic #27~14.04.1-Ubuntu SMP Fri Dec 18 10:57:53 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

JeremyB
Level 20
Level 20
Posts: 11106
Joined: Fri Feb 21, 2014 8:17 am

Re: Getting wifi working with a atheros card

Post by JeremyB » Tue Dec 29, 2015 7:41 am

See https://bugs.launchpad.net/ubuntu/+sour ... mments/118

In terminal you just need to

Code: Select all

wget https://www.dropbox.com/s/nmgb5li6sd6i7ij/backath10k-dkms_2.0_all.deb
dpkg -i backath10k-dkms_2.0_all.deb
Reboot and it should work. If you have a USB wifi that you want to use, there is another route as that deb only supports wirless cards that use ath10k module

User avatar
pfd27
Level 2
Level 2
Posts: 90
Joined: Sun Feb 15, 2015 11:13 am

Re: Getting wifi working with a atheros card

Post by pfd27 » Tue Dec 29, 2015 8:56 pm

Worked like a charm. thank you very much

User avatar
pfd27
Level 2
Level 2
Posts: 90
Joined: Sun Feb 15, 2015 11:13 am

Re: Getting wifi working with a atheros card

Post by pfd27 » Sat Jun 11, 2016 6:08 pm

I reinstalled 17.3 mate. When I ran

Code: Select all

wget https://www.dropbox.com/s/nmgb5li6sd6i7ij/backath10k-dkms_2.0_all.deb
dpkg -i backath10k-dkms_2.0_all.deb
I got this error

Code: Select all

 backath10k-dkms_2.0_all.deb
rob@rob ~ $ sudo dpkg -i backath10k-dkms_2.0_all.deb
dpkg-deb: error: `backath10k-dkms_2.0_all.deb' is not a debian format archive
dpkg: error processing archive backath10k-dkms_2.0_all.deb (--install):
 subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
 backath10k-dkms_2.0_all.deb
This has worked great in the past.What could be causing the error now?

JeremyB
Level 20
Level 20
Posts: 11106
Joined: Fri Feb 21, 2014 8:17 am

Re: Getting wifi working with a atheros card

Post by JeremyB » Sat Jun 11, 2016 6:49 pm

That is strange but there is an easier method, use Linux Mint Update Manager to install a 4.4.0 kernel, click view then Linux kernels, select a 4.4.0 kernel then select install.
Then

Code: Select all

wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.158_all.deb
sudo dpkg -i linux-firmware_1.158_all.deb
Reboot

User avatar
pfd27
Level 2
Level 2
Posts: 90
Joined: Sun Feb 15, 2015 11:13 am

Re: Getting wifi working with a atheros card

Post by pfd27 » Sat Jun 11, 2016 9:40 pm

Worked good. Thanks.

Would the same thing work in lm18 beta?

JeremyB
Level 20
Level 20
Posts: 11106
Joined: Fri Feb 21, 2014 8:17 am

Re: Getting wifi working with a atheros card

Post by JeremyB » Sun Jun 12, 2016 4:44 am

Yes as it has the 4.4 kernel already

User avatar
pfd27
Level 2
Level 2
Posts: 90
Joined: Sun Feb 15, 2015 11:13 am

Re: Getting wifi working with a atheros card

Post by pfd27 » Thu Aug 18, 2016 1:51 pm

Getting this error now when trying to run. Where can I find this file or is there a new way to make this work?

Code: Select all

rob@Lenovo ~ $ wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.158_all.deb
--2016-08-18 13:49:49--  http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.158_all.deb
Resolving mirrors.kernel.org (mirrors.kernel.org)... 198.145.20.143, 149.20.37.36, 2620:3:c000:a:0:1994:3:14, ...
Connecting to mirrors.kernel.org (mirrors.kernel.org)|198.145.20.143|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2016-08-18 13:49:49 ERROR 404: Not Found.

JeremyB
Level 20
Level 20
Posts: 11106
Joined: Fri Feb 21, 2014 8:17 am

Re: Getting wifi working with a atheros card

Post by JeremyB » Thu Aug 18, 2016 5:20 pm

If you are now using LM18 just do

Code: Select all

sudo apt-get install --reinstall linux-firmware
and reboot as it should update linux-firmware to the newest Ubuntu version

User avatar
pfd27
Level 2
Level 2
Posts: 90
Joined: Sun Feb 15, 2015 11:13 am

Re: Getting wifi working with a atheros card

Post by pfd27 » Thu Aug 18, 2016 9:28 pm

I'm using 17.3 with the 4.4 kernel. I have tried all the tricks to get it working that have worked in the past with no luck
.

JeremyB
Level 20
Level 20
Posts: 11106
Joined: Fri Feb 21, 2014 8:17 am

Re: Getting wifi working with a atheros card

Post by JeremyB » Fri Aug 19, 2016 5:58 am

http://packages.ubuntu.com/yakkety/all/ ... e/download is a list of mirror sites to the firmware

User avatar
pfd27
Level 2
Level 2
Posts: 90
Joined: Sun Feb 15, 2015 11:13 am

Re: Getting wifi working with a atheros card

Post by pfd27 » Fri Aug 19, 2016 7:39 am

Thankyou

Post Reply

Return to “Newbie Questions”