Page 1 of 1

Getting wifi working with a atheros card

Posted: Mon Dec 28, 2015 9:04 pm
by pfd27
Hi Guys

I just bought a Lenovo G50 laptop today and I cant get the wifi to work.
I have searched it and tried a few things including installing a 4.2 kernel, but
have had no luck yet. Any help would be wonderful

Re: Getting wifi working with a atheros card

Posted: Mon Dec 28, 2015 9:08 pm
by JeremyB
What Atheros card? Post the result from terminal for

Code: Select all

lspci -nnk | grep -iA2 net; uname -a
There are some new ones out that I know how to get going

Re: Getting wifi working with a atheros card

Posted: Mon Dec 28, 2015 9:15 pm
by pfd27
rob@rob-Lenovo ~ $ lspci -nnk | grep -iA2 net; uname -a
01:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:0041] (rev 20)
Subsystem: Lenovo Device [17aa:3545]
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
Subsystem: Lenovo Device [17aa:3812]
Kernel driver in use: r8169
Linux rob-Lenovo 4.2.0-22-generic #27~14.04.1-Ubuntu SMP Fri Dec 18 10:57:53 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Re: Getting wifi working with a atheros card

Posted: Tue Dec 29, 2015 7:41 am
by JeremyB
See https://bugs.launchpad.net/ubuntu/+sour ... mments/118

In terminal you just need to

Code: Select all

wget https://www.dropbox.com/s/nmgb5li6sd6i7ij/backath10k-dkms_2.0_all.deb
dpkg -i backath10k-dkms_2.0_all.deb
Reboot and it should work. If you have a USB wifi that you want to use, there is another route as that deb only supports wirless cards that use ath10k module

Re: Getting wifi working with a atheros card

Posted: Tue Dec 29, 2015 8:56 pm
by pfd27
Worked like a charm. thank you very much

Re: Getting wifi working with a atheros card

Posted: Sat Jun 11, 2016 6:08 pm
by pfd27
I reinstalled 17.3 mate. When I ran

Code: Select all

wget https://www.dropbox.com/s/nmgb5li6sd6i7ij/backath10k-dkms_2.0_all.deb
dpkg -i backath10k-dkms_2.0_all.deb
I got this error

Code: Select all

 backath10k-dkms_2.0_all.deb
rob@rob ~ $ sudo dpkg -i backath10k-dkms_2.0_all.deb
dpkg-deb: error: `backath10k-dkms_2.0_all.deb' is not a debian format archive
dpkg: error processing archive backath10k-dkms_2.0_all.deb (--install):
 subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
 backath10k-dkms_2.0_all.deb
This has worked great in the past.What could be causing the error now?

Re: Getting wifi working with a atheros card

Posted: Sat Jun 11, 2016 6:49 pm
by JeremyB
That is strange but there is an easier method, use Linux Mint Update Manager to install a 4.4.0 kernel, click view then Linux kernels, select a 4.4.0 kernel then select install.
Then

Code: Select all

wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.158_all.deb
sudo dpkg -i linux-firmware_1.158_all.deb
Reboot

Re: Getting wifi working with a atheros card

Posted: Sat Jun 11, 2016 9:40 pm
by pfd27
Worked good. Thanks.

Would the same thing work in lm18 beta?

Re: Getting wifi working with a atheros card

Posted: Sun Jun 12, 2016 4:44 am
by JeremyB
Yes as it has the 4.4 kernel already

Re: Getting wifi working with a atheros card

Posted: Thu Aug 18, 2016 1:51 pm
by pfd27
Getting this error now when trying to run. Where can I find this file or is there a new way to make this work?

Code: Select all

rob@Lenovo ~ $ wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.158_all.deb
--2016-08-18 13:49:49--  http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.158_all.deb
Resolving mirrors.kernel.org (mirrors.kernel.org)... 198.145.20.143, 149.20.37.36, 2620:3:c000:a:0:1994:3:14, ...
Connecting to mirrors.kernel.org (mirrors.kernel.org)|198.145.20.143|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2016-08-18 13:49:49 ERROR 404: Not Found.

Re: Getting wifi working with a atheros card

Posted: Thu Aug 18, 2016 5:20 pm
by JeremyB
If you are now using LM18 just do

Code: Select all

sudo apt-get install --reinstall linux-firmware
and reboot as it should update linux-firmware to the newest Ubuntu version

Re: Getting wifi working with a atheros card

Posted: Thu Aug 18, 2016 9:28 pm
by pfd27
I'm using 17.3 with the 4.4 kernel. I have tried all the tricks to get it working that have worked in the past with no luck
.

Re: Getting wifi working with a atheros card

Posted: Fri Aug 19, 2016 5:58 am
by JeremyB
http://packages.ubuntu.com/yakkety/all/ ... e/download is a list of mirror sites to the firmware

Re: Getting wifi working with a atheros card

Posted: Fri Aug 19, 2016 7:39 am
by pfd27
Thankyou