Page 2 of 2

Re: File being ignored on start up

Posted: Tue Jan 12, 2016 7:01 pm
by Cosmo.
altair4 wrote:All of my ubuntu machines regardless of DE have it set to 644 just like the error message suggests. All of the Mint machines have it set to 600.
Do you say, that in Ubuntu 644 is - in contrast to Mint - the default setting? This would indeed explain, why the error message suggests this. But it creates the new question, why Mint changes this. :?:

Re: File being ignored on start up

Posted: Wed Jan 13, 2016 8:57 am
by altair4
Cosmo. wrote:
altair4 wrote:All of my ubuntu machines regardless of DE have it set to 644 just like the error message suggests. All of the Mint machines have it set to 600.
Do you say, that in Ubuntu 644 is - in contrast to Mint - the default setting? This would indeed explain, why the error message suggests this. But it creates the new question, why Mint changes this. :?:
I have Ubuntu MATE, XFCE (Xubuntu), and Unity and they are all 644. Like you suggested above I don't know if it matters as long as it's not 664 or 666.

There's a few other unexplained anomalies between Ubuntu and Mint. The way Ubuntu is built the default umask is 0002. I can change it to something else easy enough but in Mint it's 0022 and it seems to be hard coded to that value. All of the internal settings that make it 0002 in Ubuntu are present in Mint yet Mint's is different. In this case it's the display manager that Mint uses which would have never occurred to me had I not read the bug report on it.

Re: File being ignored on start up (SOLVED)

Posted: Wed Jan 13, 2016 10:09 am
by Cosmo.
Regarding umask:

In the German Ubuntu-forum I read, that the default has been changed from 0022 to 0002 in Ubuntu 11.10; the background seems to be found here.

Further I read there, that the correct place to change this for the system is now /etc/login.defs. You find the setting for umask=022 somewhere near the middle, together with some notes in comment lines saying, that there is no true answer for the "correct" setting. I didn't bother much with that, because I didn't notice a reason to do so.

Re: File being ignored on start up (SOLVED)

Posted: Wed Jan 13, 2016 10:19 am
by altair4
Cosmo. wrote:Regarding umask:

In the German Ubuntu-forum I read, that the default has been changed from 0022 to 0002 in Ubuntu 11.10; the background seems to be found here.

Further I read there, that the correct place to change this for the system is now /etc/login.defs. You find the setting for umask=022 somewhere near the middle, together with some notes in comment lines saying, that there is no true answer for the "correct" setting. I didn't bother much with that, because I didn't notice a reason to do so.
You didn't read my link and the bug report within that link :) : Resetting Mint's Default umask to 0002

Re: File being ignored on start up (SOLVED)

Posted: Wed Jan 13, 2016 10:28 am
by Cosmo.
I did read it, but as said, I never had the need to bother myself with the question (inclusive the question, if USERGROUPS_ENAB gets honored or not). I only added the info from the German Ubuntu-wiki, that the place for changing the umask value has changed.

Re: File being ignored on start up (SOLVED)

Posted: Wed Jan 13, 2016 10:35 am
by altair4
Cosmo. wrote:I did read it, but as said, I never had the need to bother myself with the question (inclusive the question, if USERGROUPS_ENAB gets honored or not). I only added the info from the German Ubuntu-wiki, that the place for changing the umask value has changed.
And my point is that changing it there will do nothing - in Mint. It's just another quirk between Ubuntu and Mint like Mint not installing all the dependencies that Ubuntu does when you install a package.

Re: File being ignored on start up (SOLVED)

Posted: Thu Jul 28, 2016 5:39 am
by How-old!
Got the same accursed message with new installation of LM18-Xfce-beta. Never had this before. It happens after I give the PW, but can log-in by clicking OK in the error message box. Tried changing the 644 to 600 with chmod as recommended above. Hard restart: same error message. Am a user, not a guru, so appreciate any detailed suggestions; am a lot less than happy at the CLI. Thank you.
[Not sure if this is the correct place or date to ask but my problem is exactly as described above so this is obviously still a live issue for some of us.]