BIOS not recognizing HDD

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
AverageMintIceCream
Level 1
Level 1
Posts: 1
Joined: Tue Jan 19, 2016 4:48 pm

BIOS not recognizing HDD

Post by AverageMintIceCream »

I have run into some problems getting Linux Mint on my Acer Aspire E1-111M

I am unable to get my PC to boot without a USB. I booted from USB to install Linux Mint "Rosa" with the Cinnamon desktop. I followed the install directions, and it said it succeeded. If I shut down the computer, unplug the USB, and start the computer up again, then the computer is unable to boot, even after disabling UEFI. I have the HDD as being the first in boot order, but the computer still says it has no bootable disk. I feel like I am missing something.
Mute Ant
Level 14
Level 14
Posts: 5129
Joined: Tue Sep 03, 2013 7:45 pm
Location: Norfolk UK

Re: BIOS not recognizing HDD

Post by Mute Ant »

o It's worth checking in the BIOS that there really is a hard drive to boot from...no bootable disk might be the literal truth.

o It is possible the Linux boot loader (GRUB) failed to install in the main drive but skipped giving an error message because it saw no error...for example the new system boot loader has gone into the USB. Put the Live-Session USB back in and boot from that. If you don't get a Live Session, but you do get the installed system running, it's a simple command to put a copy of GRUB where you want it; on the same drive as the system partition.

If you get Live Session booting from USB, you can use it as a diagnostic environment, or as a boot loader, or as a re-installer...

o Start a Live Session and try the Boot from Hard Drive option in the start-up menu.

o Start a Live Session and run gparted. Post a screen shot here of the state of /dev/sda.

More complex...but already detailed somewhere in the forum answers...

o Start a Live Session and edit the menu text from boot=casper to root=/dev/sda1 to start an installed Mint on /dev/sda1 (which is where it usually goes for me...that's what the screen shot is for).

o Start a Live Session and chroot into the installed system...experts only for this because there's no GUI, only console commands.

Easy way out...reinstall Mint to /dev/sda and double-check the boot-loader is sent to the same drive as the system. Watch closely for error messages. You may need a new Live Session USB if something got written to the old one. /dev/sda may not be an appropriate destination for your hardware, it usually is, but I am having to guess.
While you're waiting, read the free novel we sent you. It's a Spanish story about a guy named "manual".
Aristotelian
Level 3
Level 3
Posts: 131
Joined: Tue Dec 24, 2013 7:12 pm

Re: BIOS not recognizing HDD

Post by Aristotelian »

Whenever I have gotten "no bootable disc" it is because BIOS is trying to boot CD-ROM. It is possible you have the correct order of HDDs but it is still going to CD-ROM first.
Post Reply

Return to “Newbie Questions”