No HDMI video on HDTV

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
echofactor42
Level 1
Level 1
Posts: 4
Joined: Sat Mar 12, 2016 9:53 pm

No HDMI video on HDTV

Post by echofactor42 » Sat Mar 12, 2016 10:14 pm

Hi all,

Hopefully this is just some glaring oversight on my part. I have a great laptop with a dead display that I cannot get parts for so I'm attempting to use my HDTV as a second monitor. I currently have a VGA monitor connected and running fine so that I can see what I'm doing as well as my TV connected by HDMI. Linux can see the TV - xrandr can detect available resolutions and it is visible in my monitor settings but get-edid gets no results. I've installed arandr and lxrandr after some reading.

The TV is recognized by my laptop but every time I load an application (Display settings, lxrandr), the HDMI is set to "off". If I enable it and hit apply, the application will close and the TV still says no signal. If I load arandr and enable the HDMI, the application stays open and resolution options are displayed, but no settings I try will fix the signal.

The HDMI cable does function properly with my Pi so that's OK. Most of my searches for HDMI issues in Linux bring up no audio solutions only. I am hesitant to try to try to install proprietary NVIDEA anything since if anything screws up my ability to use the VGA monitor I'll be screwed and the laptop will be completely useless (I'm sure it's a minute possibility but I'm scared).

Any advice is appreciated, even if it's just pointing me in the right direction to research. Thanks for reading.

echofactor42
Level 1
Level 1
Posts: 4
Joined: Sat Mar 12, 2016 9:53 pm

Re: No HDMI video on HDTV

Post by echofactor42 » Sun Mar 13, 2016 3:12 pm

Still digging - Geforce 9300M, changed to nouveau driver (even though it's older, I saw some threads showing success with it). Still no video. I keep seeing posts about the video working perfectly, why not me? I must be doing something ridiculously wrong.

echofactor42
Level 1
Level 1
Posts: 4
Joined: Sat Mar 12, 2016 9:53 pm

Re: No HDMI video on HDTV

Post by echofactor42 » Sun Mar 13, 2016 6:04 pm

So I realized afterwards that when I was using the Display Settings and attempting to activate the HDMI there was a bunch of errors popping up that were just off screen, since the attempt kept resizing my VGA display. Once I discovered Nvidia X Server Settings (thank you YouTube), I did get to the step of activating a new x screen which requires a reboot - but I can't save to the config file to wrap it all up.

Originally I had no xorg.config to update. I read up on how to create one but it has no content. Now my Nvidia X server settings cannot parse xorg.config and I'm stuck.

Can anybody give me a hand with how to fix / edit my xorg.config file? My poor dog is pouting at me because I'm trying to do all this next to the TV and my chair has displaced his bed :oops:

User avatar
WharfRat
Level 21
Level 21
Posts: 12938
Joined: Thu Apr 07, 2011 8:15 pm

Re: No HDMI video on HDTV

Post by WharfRat » Sun Mar 13, 2016 8:26 pm

Poor dog :(

From my past experiences with nvidia, the installation should have created that file /etc/X11/

If worse comes to worse just reinstall the nvidia driver.

I was going to suggest trying

Code: Select all

xrandr --output VGA-0 --off --output HDMI-0 --auto
but now that you installed nvidia, I'm not sure it's pertinent.

Naturally you would have to match the outputs with

Code: Select all

xrandr -q
ImageImage

echofactor42
Level 1
Level 1
Posts: 4
Joined: Sat Mar 12, 2016 9:53 pm

Re: No HDMI video on HDTV

Post by echofactor42 » Wed Mar 16, 2016 8:56 pm

WharfRat wrote: I was going to suggest trying

Code: Select all

xrandr --output VGA-0 --off --output HDMI-0 --auto
Looking at that code I'm guessing that would disable the VGA out? Then I'd be blind if the HDMI didn't kick in - but without a proper config file I guess it wouldn't be persistent so I could just hard reset if necessary right? I'll give that a shot tonight unless someone corrects me.

User avatar
WharfRat
Level 21
Level 21
Posts: 12938
Joined: Thu Apr 07, 2011 8:15 pm

Re: No HDMI video on HDTV

Post by WharfRat » Thu Mar 17, 2016 12:17 am

That's not a persistent change meaning it's only in effect for the current session.

Just make sure you get the approptiate video assignments from xrandr.
ImageImage

User avatar
LinuxJim
Level 5
Level 5
Posts: 659
Joined: Tue Jan 26, 2016 8:01 pm
Location: Oregon, USA

Re: No HDMI video on HDTV

Post by LinuxJim » Thu Mar 17, 2016 3:52 am

echofactor42 wrote: I have a great laptop with a dead display that I cannot get parts for
What is the make/model of laptop?

I've had very little problem getting parts (especially displays) for *any* laptop. Maybe I can point you in the rigt direction to get it fixed...

albaberto
Level 1
Level 1
Posts: 20
Joined: Fri Jan 11, 2013 6:12 pm

Re: No HDMI video on HDTV

Post by albaberto » Thu Jul 21, 2016 3:19 am

Hi!

I've the same problem here..

Connecting LinuxMint with HDMI to the tv I get "no signal" on the tv screen. If I connect the LinuxMint pc with a VGA cable no problem. If I connect another pc running windows with the same HDMI cable to the same tv no problem.

I have asus k52f with intel graph.. All the drivers are updated.

I saw other posts with similar problem but without proper solutions...

Waiting for help as well :?

architora
Level 1
Level 1
Posts: 16
Joined: Fri Jul 22, 2016 4:37 am

Re: No HDMI video on HDTV

Post by architora » Fri Jul 22, 2016 4:40 am


User avatar
karlchen
Level 20
Level 20
Posts: 10847
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: No HDMI video on HDTV

Post by karlchen » Fri Jul 22, 2016 4:45 am

The video illustrates the steps of solving the reported problem? Right?
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.22a 64-bit
Ubuntu 18.04.2 32-bit Mate Desktop, Total Commander 9.22a 32-bit
Windows? - 1 window in every room

albaberto
Level 1
Level 1
Posts: 20
Joined: Fri Jan 11, 2013 6:12 pm

Re: No HDMI video on HDTV

Post by albaberto » Sat Jul 23, 2016 10:26 am

The video didn't solve the problem, I think it is not so straightforward.

that's the output of xrandr -q and sudo lshw -c video while being connected with the hdmi to the tv:

Code: Select all

xrandr -q
Screen 0: minimum 8 x 8, current 3286 x 1080, maximum 32767 x 32767
LVDS1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1366x768      60.02*+
   1360x768      59.80    59.96 
   1280x720      60.00 
   1024x768      60.00 
   1024x576      60.00 
   960x540       60.00 
   800x600       60.32    56.25 
   864x486       60.00 
   640x480       59.94 
   720x405       60.00 
   680x384       60.00 
   640x360       60.00 
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1080+1366+0 (normal left inverted right x axis y axis) 575mm x 323mm
   1920x1080     60.00*+  60.00    50.00    59.94    24.00    23.98 
   1920x1080i    60.00    50.00    59.94 
   1280x720      60.00    50.00    59.94 
   1024x768      75.08    70.07    60.00 
   800x600       75.00    60.32 
   720x576       50.00 
   720x576i      50.00 
   720x480       60.00    59.94 
   720x480i      60.00    59.94 
   640x480       75.00    60.00    59.94 
   720x400       70.08 
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Code: Select all

sudo lshw -c video
  *-display               
       description: VGA compatible controller
       product: Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 18
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:29 memory:d0000000-d03fffff memory:c0000000-cfffffff ioport:e080(size=8)



From what I could understand with the xrandr --listmonitors --verbose, my problem is a wrong output from the HDMI: instead of duplicating the LVDS1 is duplicating the VGA1

Code: Select all

 xrandr --listmonitors --verbose
Screen 0: minimum 8 x 8, current 1366 x 768, maximum 32767 x 32767
LVDS1 connected primary 1366x768+0+0 (0x48) normal (normal left inverted right x axis y axis) 344mm x 193mm
	Identifier: 0x42
	Timestamp:  487129
	Subpixel:   horizontal rgb
	Gamma:      1.0:1.0:1.0
	Brightness: 1.0
	Clones:    
	CRTC:       0
	CRTCs:      0 1
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	EDID: 
		00ffffffffffff004ca3463000000000
		00120103802213780ace859e5b4c9426
		17505400000001010101010101010101
		0101010101017d1e5618510016303020
		250058c1100000190000000f00000000
		00000000001eb4027400000000fe0053
		414d53554e470a2020202020000000fe
		00313536415430312d5030370a200025
	BACKLIGHT: 13 
		range: (0, 15)
	Backlight: 13 
		range: (0, 15)
	scaling mode: Full aspect 
		supported: None, Full, Center, Full aspect
  1366x768 (0x48) 78.050MHz -HSync -VSync *current +preferred
        h: width  1366 start 1414 end 1446 total 1646 skew    0 clock  47.42KHz
        v: height  768 start  770 end  775 total  790           clock  60.02Hz
  1360x768 (0xab) 84.750MHz -HSync +VSync
        h: width  1360 start 1432 end 1568 total 1776 skew    0 clock  47.72KHz
        v: height  768 start  771 end  781 total  798           clock  59.80Hz
  1360x768 (0xac) 72.000MHz +HSync -VSync
        h: width  1360 start 1408 end 1440 total 1520 skew    0 clock  47.37KHz
        v: height  768 start  771 end  781 total  790           clock  59.96Hz
  1280x720 (0xad) 74.480MHz -HSync +VSync
        h: width  1280 start 1336 end 1472 total 1664 skew    0 clock  44.76KHz
        v: height  720 start  721 end  724 total  746           clock  60.00Hz
  1024x768 (0xae) 65.000MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock  48.36KHz
        v: height  768 start  771 end  777 total  806           clock  60.00Hz
  1024x576 (0xaf) 46.995MHz -HSync +VSync
        h: width  1024 start 1064 end 1168 total 1312 skew    0 clock  35.82KHz
        v: height  576 start  577 end  580 total  597           clock  60.00Hz
  960x540 (0xb0) 40.784MHz -HSync +VSync
        h: width   960 start  992 end 1088 total 1216 skew    0 clock  33.54KHz
        v: height  540 start  541 end  544 total  559           clock  60.00Hz
  800x600 (0xb1) 40.000MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock  37.88KHz
        v: height  600 start  601 end  605 total  628           clock  60.32Hz
  800x600 (0xb2) 36.000MHz +HSync +VSync
        h: width   800 start  824 end  896 total 1024 skew    0 clock  35.16KHz
        v: height  600 start  601 end  603 total  625           clock  56.25Hz
  864x486 (0xb3) 32.901MHz -HSync +VSync
        h: width   864 start  888 end  976 total 1088 skew    0 clock  30.24KHz
        v: height  486 start  487 end  490 total  504           clock  60.00Hz
  640x480 (0xb4) 25.175MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
        v: height  480 start  490 end  492 total  525           clock  59.94Hz
  720x405 (0xb5) 22.176MHz -HSync +VSync
        h: width   720 start  728 end  800 total  880 skew    0 clock  25.20KHz
        v: height  405 start  406 end  409 total  420           clock  60.00Hz
  680x384 (0xb6) 19.677MHz -HSync +VSync
        h: width   680 start  688 end  752 total  824 skew    0 clock  23.88KHz
        v: height  384 start  385 end  388 total  398           clock  60.00Hz
  640x360 (0xb7) 17.187MHz -HSync +VSync
        h: width   640 start  640 end  704 total  768 skew    0 clock  22.38KHz
        v: height  360 start  361 end  364 total  373           clock  60.00Hz
DP1 disconnected (normal left inverted right x axis y axis)
	Identifier: 0x43
	Timestamp:  487129
	Subpixel:   unknown
	Clones:    
	CRTCs:      0 1
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	Broadcast RGB: Automatic 
		supported: Automatic, Full, Limited 16:235
	audio: auto 
		supported: force-dvi, off, auto, on
HDMI1 connected (normal left inverted right x axis y axis)
	Identifier: 0x44
	Timestamp:  487129
	Subpixel:   unknown
	Clones:     VGA1
	CRTCs:      0 1
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	EDID: 
		00ffffffffffff000421000000000000
		06160103800000008aee95a3544c9926
		0f5054a54e0001010101010101010101
		010101010101023a801871382d40582c
		45003f432100001a000000fd0018550f
		5010000a202020202020000000fc0048
		4454560a202020202020202000000000
		0000000000000000000000000000012c
		020324745090050403070206011f1413
		1216111520230907038301000066030c
		00200080011d00bc52d01e20b8285540
		c48e2100001e011d80d0721c1620102c
		2580c48e2100009e8c0ad08a20e02d10
		103e9600138e210000188c0ad0902040
		31200c405500138e2100001800000000
		00000000000000000000000000000073
	aspect ratio: Automatic 
		supported: Automatic, 4:3, 16:9
	Broadcast RGB: Automatic 
		supported: Automatic, Full, Limited 16:235
	audio: auto 
		supported: force-dvi, off, auto, on
  1920x1080 (0xcc) 148.500MHz +HSync -VSync +preferred
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  67.50KHz
        v: height 1080 start 1084 end 1089 total 1125           clock  60.00Hz
  1920x1080 (0xcd) 148.500MHz +HSync +VSync
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  67.50KHz
        v: height 1080 start 1084 end 1089 total 1125           clock  60.00Hz
  1920x1080 (0xce) 148.500MHz +HSync +VSync
        h: width  1920 start 2448 end 2492 total 2640 skew    0 clock  56.25KHz
        v: height 1080 start 1084 end 1089 total 1125           clock  50.00Hz
  1920x1080 (0xcf) 148.352MHz +HSync +VSync
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  67.43KHz
        v: height 1080 start 1084 end 1089 total 1125           clock  59.94Hz
  1920x1080i (0xd0) 74.250MHz +HSync +VSync Interlace
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  33.75KHz
        v: height 1080 start 1084 end 1094 total 1125           clock  60.00Hz
  1920x1080i (0xd1) 74.250MHz +HSync +VSync Interlace
        h: width  1920 start 2448 end 2492 total 2640 skew    0 clock  28.12KHz
        v: height 1080 start 1084 end 1094 total 1125           clock  50.00Hz
  1920x1080 (0xd2) 74.250MHz +HSync +VSync
        h: width  1920 start 2558 end 2602 total 2750 skew    0 clock  27.00KHz
        v: height 1080 start 1084 end 1089 total 1125           clock  24.00Hz
  1920x1080i (0xd3) 74.176MHz +HSync +VSync Interlace
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  33.72KHz
        v: height 1080 start 1084 end 1094 total 1125           clock  59.94Hz
  1920x1080 (0xd4) 74.176MHz +HSync +VSync
        h: width  1920 start 2558 end 2602 total 2750 skew    0 clock  26.97KHz
        v: height 1080 start 1084 end 1089 total 1125           clock  23.98Hz
  1280x720 (0xd5) 74.250MHz +HSync +VSync
        h: width  1280 start 1390 end 1430 total 1650 skew    0 clock  45.00KHz
        v: height  720 start  725 end  730 total  750           clock  60.00Hz
  1280x720 (0xd6) 74.250MHz +HSync +VSync
        h: width  1280 start 1720 end 1760 total 1980 skew    0 clock  37.50KHz
        v: height  720 start  725 end  730 total  750           clock  50.00Hz
  1280x720 (0xd7) 74.176MHz +HSync +VSync
        h: width  1280 start 1390 end 1430 total 1650 skew    0 clock  44.96KHz
        v: height  720 start  725 end  730 total  750           clock  59.94Hz
  1024x768 (0xd8) 78.800MHz +HSync +VSync
        h: width  1024 start 1040 end 1136 total 1312 skew    0 clock  60.06KHz
        v: height  768 start  769 end  772 total  800           clock  75.08Hz
  1024x768 (0xd9) 75.000MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1328 skew    0 clock  56.48KHz
        v: height  768 start  771 end  777 total  806           clock  70.07Hz
  1024x768 (0xae) 65.000MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock  48.36KHz
        v: height  768 start  771 end  777 total  806           clock  60.00Hz
  800x600 (0xda) 49.500MHz +HSync +VSync
        h: width   800 start  816 end  896 total 1056 skew    0 clock  46.88KHz
        v: height  600 start  601 end  604 total  625           clock  75.00Hz
  800x600 (0xb1) 40.000MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock  37.88KHz
        v: height  600 start  601 end  605 total  628           clock  60.32Hz
  720x576 (0xdb) 27.000MHz -HSync -VSync
        h: width   720 start  732 end  796 total  864 skew    0 clock  31.25KHz
        v: height  576 start  581 end  586 total  625           clock  50.00Hz
  720x576i (0xdc) 13.500MHz -HSync -VSync Interlace
        h: width   720 start  732 end  795 total  864 skew    0 clock  15.62KHz
        v: height  576 start  580 end  586 total  625           clock  50.00Hz
  720x480 (0xdd) 27.027MHz -HSync -VSync
        h: width   720 start  736 end  798 total  858 skew    0 clock  31.50KHz
        v: height  480 start  489 end  495 total  525           clock  60.00Hz
  720x480 (0xde) 27.000MHz -HSync -VSync
        h: width   720 start  736 end  798 total  858 skew    0 clock  31.47KHz
        v: height  480 start  489 end  495 total  525           clock  59.94Hz
  720x480i (0xdf) 13.514MHz -HSync -VSync Interlace
        h: width   720 start  739 end  801 total  858 skew    0 clock  15.75KHz
        v: height  480 start  488 end  494 total  525           clock  60.00Hz
  720x480i (0xe0) 13.500MHz -HSync -VSync Interlace
        h: width   720 start  739 end  801 total  858 skew    0 clock  15.73KHz
        v: height  480 start  488 end  494 total  525           clock  59.94Hz
  640x480 (0xe1) 31.500MHz -HSync -VSync
        h: width   640 start  656 end  720 total  840 skew    0 clock  37.50KHz
        v: height  480 start  481 end  484 total  500           clock  75.00Hz
  640x480 (0xe2) 25.200MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.50KHz
        v: height  480 start  490 end  492 total  525           clock  60.00Hz
  640x480 (0xb4) 25.175MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
        v: height  480 start  490 end  492 total  525           clock  59.94Hz
  720x400 (0xe3) 28.320MHz -HSync +VSync
        h: width   720 start  738 end  846 total  900 skew    0 clock  31.47KHz
        v: height  400 start  412 end  414 total  449           clock  70.08Hz
VGA1 disconnected (normal left inverted right x axis y axis)
	Identifier: 0x45
	Timestamp:  487129
	Subpixel:   unknown
	Clones:     HDMI1
	CRTCs:      0 1
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
	Identifier: 0x46
	Timestamp:  487129
	Subpixel:   no subpixels
	Clones:    
	CRTCs:      2
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 

I tried to configure the `xorg.conf` file but I don't have it and I can not create it.

I saw there are several questions on the same topic but none referred to intel (like this).

I have Intel graphs and I think from Ubuntu 16.04 (Xenial) the procedure

Code: Select all

sudo service mdm stop
    sudo X -configure
    sudo service mdm start
does not work anymore.

Post Reply

Return to “Newbie Questions”